LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-04-2007, 10:38 PM   #1
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Rep: Reputation: 15
SAMBA and Network Media Player Please Help


1 Please be language friendly I am a Linux noob, just installed it for the first time.


I have MediaGate MG350 HD players:

I want to make it play my network shared files. What I did so far was right click on the folder and share it using SMB - Read Only mode (I also tried none read only mode)

I can see the folders that I have shared on my mediagate player but I cannot access them.

What happens on my other windows computers when I try to access the folders - it asks me for the password and I have no idea what it is, my root password is not the correct one.

I have Ubuntu 6.10

Please help.
I want to make it play my network shared files. What I did so far was right click on the folder and share it using SMB - Read Only mode (I also tried none read only mode)

I can see the folders that I have shared on my mediagate player but I cannot access them.

What happens on my other windows computers when I try to access the folders - it asks me for the password and I have no idea what it is, my root password is not the correct one.

I have Ubuntu 6.10



Here is how my samba config looks:

http://pastebin.com/851555


It does not work.

Here is the detailed manual on how to setup access in Windows for this player:

http://www.airlinktek.com/english/at...keyfield=&key=

From what I understand it that it needs "Guest" and "Everyone" access without password.


This guy here: #374390 - 12/15/05 04:56 PM

http://www.macworld.com/forums/ubbt...sb=5&o=&fpart=1

Has it working.

I tried his settings and still it does not work for me.

If someone can please help me I would really appreciate it.
 
Old 01-05-2007, 03:27 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Not sure what a mediagate player is, but here is a minimal smb.conf for Samba that should allow remote systems passwordless access to your share. I guess that the mediagate thingy you have won't access the share because it asks for a password, and the firmware on the device cannot cope with this - viz a viz that you state that Windows machines asks for a password when you try to access the share...

Try this smb.conf and substitute stuff as needed to fit your IP addresses / disk setup:

[global]

netbios name = stefan
workgroup = GOEDEHOOP10
security = share
log file = /var/log/samba.log
log level = 1
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=16384 SO_SNDBUF=16384
wins support = yes
domain logons = no
logon drive = f:
logon home = \\stefan\%U
os level = 99
preferred master = yes
local master = yes
hosts allow = 192.254.255.10 192.254.255.20 192.254.255.30 127.0.0.1 192.254.255.40 192.254.255.50 192.254.255.60 192.254.255.70 192.254.255.80
encrypt passwords = yes
browseable = yes
lanman auth = yes
lm announce = yes

[shared]
path = /mnt/win/shared
guest ok = yes
writeable = yes
create mode = 0666
directory mode = 0777
browseable = yes
public = yes

The above should then give you passwordless access from Windows machines to the defined share above... it might also mean that your "mediagate" device might now be able to access the share, because it should not ask for a password...
 
Old 01-05-2007, 08:33 AM   #3
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
There are always two issues when using Samba and any file access from a remote computer. First you need to allow Samba to access the files and then you have to set up the Linux file permissions to allow access. In your case you might want to allow root to own the files and then set up a group to access the files. Do this in your Linux file directory setup and then use the same group in Samba. Try that and give it a repost if you need more help.
 
Old 01-05-2007, 11:07 AM   #4
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ScooterB
There are always two issues when using Samba and any file access from a remote computer. First you need to allow Samba to access the files and then you have to set up the Linux file permissions to allow access. In your case you might want to allow root to own the files and then set up a group to access the files. Do this in your Linux file directory setup and then use the same group in Samba. Try that and give it a repost if you need more help.
Sorry, but me being a linux noob, it is a bit hard to understand how to do these things.
 
Old 01-05-2007, 11:08 AM   #5
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Here is how my smb.conf looks

http://pastebin.com/851988

security =s hare

is there


Same thing happens again, mediagate - whenever I try to access any of the folders it sees them but once I try to enter it it tries to open it and it cannot, just open a blank page and only option I have is to go back to folder list.

On windows machine it still asks me for the password. ? I though that "security = share" will make it so that it will not ask for the password.

Yes, I do restart samba after I change my smb.conf


Please see my smb.conf. Any more ideas ?

Last edited by robertpolson; 01-05-2007 at 11:11 AM.
 
Old 01-05-2007, 11:37 AM   #6
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
According to the Samaba manual, the "share" security level (as all of them do) require a user name and password. One way around this is on the Windows machines, when you first try to log on (the first time) click on the remember me box and you wont have to do it again. There is one caveat that you can mess around with. You could try the guest account. It will not ask for a user name and password. But you must set up the share with
guest ok = yes
guest only = yes

Remove any other users that you might have setup for the share.

This type of access must still have the linux file permissions set though. I didn't notice in your smb.conf file if you had browseable = yes for this share but you will need to do that.

Take a look at that and repost.
 
Old 01-05-2007, 11:58 AM   #7
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Here is how the 2 folders look:

[Movies]
path = /media/Media/Movies
guest ok = yes
guest only = yes
available = yes
browsable = yes
public = yes
writable = yes
create mode = 0666
directory mode = 0777

[Files]
path = /home/slyfox/Desktop/Files
guest ok = yes
guest only = yes
available = yes
browsable = yes
public = yes
writable = yes
create mode = 0666
directory mode = 0777


Adding guest only = yes did not help
 
Old 01-06-2007, 02:44 PM   #8
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
It is a shame.

I uninstalled Ubuntu and installed Vista. Perhpas some time later smaba will catch up to function properly without wasting all day in a txt file.

Thank you very much for you help though. I wanted open source to work, but it is too early.

Another problem with Linux is that there is no Internet Explorer there, there is via wine and I tried it, but there is no way to make the fonts big enough for my 1680x1050 resolution and it is pain to look at tiny fonts.

Why explorer? Because the stupid site I need for work only supports Internet Explorer. :-(
 
Old 01-06-2007, 07:03 PM   #9
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
On the second thought, I really do want to switch to open source Linux.

If someone can still help to solve this problem, this would be great.
 
Old 01-06-2007, 07:13 PM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
There is a Force User and Force Group option you can use in the samba config that allows free and open access to a share. It may still require a username and password entry, but it doesn't matter what you enter. I don't know if that would help. In the back of my mind is a feature that should always be disabled ( using the registry editor ) called password caching. This is not secure, but I wonder if the media player requires it.

The "Force User" and "Force Group" options are used in a couple sample configurations in the "Samba 3 by Example" book that you can download from the Samba.org website.
 
Old 01-07-2007, 01:18 AM   #11
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
I did get it working but only for ext3 ubuntu folder. I cannot share fat32 flash drive or my 400 gig NTFS drive.

I was trying to share folders from my NTFS drive all this time.

Any ideas?

The only way I could share my fat32 usb flash drive is if I add

force user = root which is not a good thing

If I do not add this line and share it the stadard way, windows sees the folder but cannot enter it.

This is my samba.conf that worked for ext3 folder share:

http://pastebin.com/853328

Any more ideas ?
 
Old 01-07-2007, 12:48 PM   #12
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
You might try looking at this link to the Samaba help pages on using NTFS: http://lists.samba.org/archive/samba...er/076459.html

I got a lot of responses when I just typed in "Samba NTFS" on Google. Might try that and see what you can come up with.
 
Old 01-07-2007, 01:59 PM   #13
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
What about fat32 ? Isn't linux supposed to use fat32 system ? How come regular sharing does not work for fat32 like it does for ext3 ? Same crap needs to be done as for the ntfs file system.
 
Old 01-08-2007, 09:08 PM   #14
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
I'll do some research and post back
 
Old 01-16-2007, 02:58 PM   #15
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
To close the thread, solution is found here:

http://www.avsforum.com/avs-vb/showt...ghlight=ubuntu
 
  


Reply

Tags
samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Default Media Player Not Playing Windows Media Player Files kenlitting Suse/Novell 2 11-29-2006 11:05 AM
Need a media-player that can build a collection over a network raccoonone Linux - Newbie 5 09-12-2006 10:15 PM
Linux Network Media Player scentMaster Linux - Hardware 4 07-29-2005 09:36 AM
I want to make a standalone network media player from a 200MHz PII resnak Linux - Software 1 05-06-2005 06:00 PM
Media Player That shares tunes across the network sethgeekx86 Linux - Software 2 05-02-2004 06:55 PM


All times are GMT -5. The time now is 02:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration