LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-24-2003, 02:21 PM   #1
dlucas10
LQ Newbie
 
Registered: Aug 2001
Posts: 18

Rep: Reputation: 0
Question Samba and Home Directories


Samba and Home Directories

Ok, I think I got winbind to authenticate off the win2k domain. Iím running Red Hat 9.0 with Samba 3.0. All my other shares work except my home directories. Windows says that I donít have access to the network share. Here is my smb.conf file:

[global]
workgroup = LUCASSAURUS
netbios name = guinness
server string = Guinness RedHat Samba Server %v
security = ads
realm = LUCASSAURUS.COM
password server = 192.168.0.3
auth methods = winbind
passwd program = /usr/bin/passwd %u
passwd chat = *New*password:* %n\r *Retype*new*password:* %n\r *passwd:*all*authentication*tokens*updated*successfully.* \r
unix password sync = Yes
encrypt passwords = yes
log level = 4
log file = /var/log/samba/log.%m
max log size = 500
name resolve order = wins, host, bcast
time server = Yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
load printers = No
add user script = /usr/sbin/useradd -G lucas -d %H -s /bin/bash -m %U
delete user script = /usr/sbin/userdel -r %u
logon path =
preferred master = No
local master = no
domain master = No
wins server = 192.168.0.3
lock directory = /var/lock/samba/locks
winbind enable local accounts = yes
winbind separator = +
winbind uid = 10000-20000
winbind gid = 10000-20000
winbind enum users = yes
winbind enum groups = yes
template homedir = /home/%U
template shell = /bin/bash
winbind use default domain = no
obey pam restrictions = yes
admin users = @LUCASSAURUS+Domain Admins
force group = LUCASSAURUS+Lucas
create mask = 0666
directory mask = 0777
hosts allow = 192.168.0.0/255.255.255.0, 127.0.0.1/255.255.255.0

[homes]
comment = Home Directories for: %U
valid users = %U
read only = No
create mask = 0600
directory mask = 0700
browseable = No

Does anyone have any ideas as to why this isnít working???

Also, can any one tell me why the linux box is not creating the account automatically??
 
Old 10-24-2003, 03:34 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Try changing:
valid users = %U

To:
valid users = %S
 
Old 10-24-2003, 05:51 PM   #3
dlucas10
LQ Newbie
 
Registered: Aug 2001
Posts: 18

Original Poster
Rep: Reputation: 0
I just tried that with no luck. If I open a command prompt on my desktop machine and type 'net view \\guinness' I get:

Shared resources at \\guinness

Guinness RedHat Samba Server 3.0.0

Share name Type Used as Comment

----------------------------------------------------------------------
dave Disk Z: Home Directories for: lucassaurus.com_dave

Do you have any other suggestions??

 
Old 10-24-2003, 06:22 PM   #4
dlucas10
LQ Newbie
 
Registered: Aug 2001
Posts: 18

Original Poster
Rep: Reputation: 0
OK, so I got my desktop machine to connect to my home directory and I feel stupid... I forgot that I needed to change the owner of the directories to be that of the domain. So that works now.

One last thing - if anyone can please help me figure out how to get the users added automatically after I add them to the windows domain I'll be one happy camper!!! I know winbind is working because I can have a user who does not have an account on the linux box to log in via telnet but the home directory is not added.
 
Old 10-27-2003, 03:42 PM   #5
sokol
LQ Newbie
 
Registered: Oct 2003
Distribution: slackware (temporarily down)
Posts: 7

Rep: Reputation: 0
Uhm, I have a question.

When accessing my samba-shared directories from Windows, there is always a 'Printers' icon visible. Well, it is not annoying or disruptive, but I'd rather like samba not to display that icon. How to achieve it?

I'm quite a newbie, so forgive me If I asked a stupid question.
 
Old 10-28-2003, 12:51 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Welcome to LQ.

Just remove the printer share from smb.conf

I future please start a new thread if you have a new question. Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache Root/Home Directory and setting up FTP for home directories? Mankind75 Linux - Newbie 6 07-23-2006 02:37 PM
Samba does not allow writing to public shares / browsing home directories disallowed Xolo Linux - Software 6 02-14-2005 04:22 PM
samba: home directories not visible flipboi Linux - Networking 1 05-27-2004 11:06 PM
Creating home directories with samba and PAM mkhomedir ferrantepunto Linux - Software 2 01-21-2004 09:13 AM
mounting home directories from samba? tommyj27 Linux - Networking 2 08-27-2003 04:49 PM


All times are GMT -5. The time now is 08:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration