LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 01-24-2006, 10:46 PM   #1
Grunty
LQ Newbie
 
Registered: Jun 2004
Distribution: Slackware
Posts: 25

Rep: Reputation: 15
Samba always crash


Im maintaning a small network using a fedora 3 server with samba and cups for printing. Problem is, samba almost always stop after sometime. The next day when i get back to the office, the samba is no longer running.

A simple smb restart makes samba up and running again but then the cycle continues. My suspicion is that theres a corrupt file somewhere. Either samba, cups, or the printer drivers. This is the log of smbd.

[2006/01/23 18:04:16, 0] smbd/server.c:main(760)
smbd version 3.0.8pre1-0.pre1.3 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004
[2006/01/23 18:04:19, 0] printing/nt_printing.c:nt_printing_init(383)
nt_printing_init: error checking published printers: WERR_ACCESS_DENIED
[2006/01/23 18:04:24, 0] smbd/server.c:main(760)
smbd version 3.0.8pre1-0.pre1.3 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004
[2006/01/23 18:04:25, 0] printing/nt_printing.c:nt_printing_init(383)
nt_printing_init: error checking published printers: WERR_ACCESS_DENIED
[2006/01/23 18:24:28, 0] lib/util_sock.c:get_peer_addr(1000)
getpeername failed. Error was Transport endpoint is not connected
[2006/01/23 19:24:10, 0] smbd/server.c:main(760)
smbd version 3.0.10-1.fc3 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004
[2006/01/23 19:26:00, 0] smbd/server.c:main(760)
smbd version 3.0.10-1.fc3 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004
[2006/01/23 19:26:05, 0] smbd/server.c:main(760)
smbd version 3.0.10-1.fc3 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004
[2006/01/23 19:26:05, 0] smbd/server.c:main(794)
standard input is not a socket, assuming -D option
[2006/01/23 19:26:05, 0] lib/pidfile.cidfile_create(91)
ERROR: smbd is already running. File /var/run/smbd.pid exists and process id 13304 is running.
[2006/01/23 19:26:09, 0] smbd/server.c:main(760)
smbd version 3.0.10-1.fc3 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004
[2006/01/23 19:26:09, 0] smbd/server.c:main(794)
standard input is not a socket, assuming -D option
[2006/01/23 19:26:09, 0] lib/pidfile.cidfile_create(91)
ERROR: smbd is already running. File /var/run/smbd.pid exists and process id 13304 is running.
[2006/01/23 19:27:51, 0] lib/util_sock.c:get_peer_addr(1000)
getpeername failed. Error was Transport endpoint is not connected
[2006/01/23 19:31:39, 0] lib/util_sock.c:get_peer_addr(1000)
getpeername failed. Error was Transport endpoint is not connected
[2006/01/23 19:31:54, 0] tdb/tdbutil.c:tdb_log(725)
tdb(/var/cache/samba/printing/HP720c.tdb): rec_read bad magic 0x2d206472 at offset=20880
[2006/01/23 19:31:54, 0] tdb/tdbutil.c:tdb_log(725)
tdb(/var/cache/samba/printing/HP720c.tdb): rec_read bad magic 0x2d206472 at offset=20880
[2006/01/23 19:32:05, 0] tdb/tdbutil.c:tdb_log(725)
tdb(/var/cache/samba/printing/HP720c.tdb): rec_read bad magic 0x2d206472 at offset=20880
[2006/01/23 19:32:05, 0] tdb/tdbutil.c:tdb_log(725)
tdb(/var/cache/samba/printing/HP720c.tdb): rec_read bad magic 0x2d206472 at offset=20880
[2006/01/23 19:32:24, 0] tdb/tdbutil.c:tdb_log(725)
tdb(/var/cache/samba/printing/HP720c.tdb): rec_read bad magic 0x2d206472 at offset=20880
[2006/01/23 19:32:24, 0] tdb/tdbutil.c:tdb_log(725)
tdb(/var/cache/samba/printing/HP720c.tdb): rec_read bad magic 0x2d206472 at offset=20880
[2006/01/23 19:32:35, 0] tdb/tdbutil.c:tdb_log(725)

Ive already updated samba (as shown in the log) and cups. Im particularly interested in the tdb error.
Any help would be greatly appreciated.
 
Old 01-26-2006, 08:03 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
I have had problems (in the past) with the samba packages as supplied by Red Hat / Fedora. I now build my own from the main source rpm from kernel.org and have no problems.

http://us2.samba.org/samba/ftp/Binary_Packages/Fedora/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba shares crash Windows clients GT_Onizuka Linux - Software 5 07-01-2005 11:02 AM
xmms crash xine crash mplayer crash paledread Linux - Software 9 03-09-2004 07:09 AM
Samba 3.0 i386 RH9.0 slow/crash on WinXP using DeamonScript OmegaTron Linux - Networking 2 02-29-2004 05:03 PM
samba pdc explorer crash pretoriano Linux - Networking 0 09-09-2003 10:27 AM
Samba crash!! elwis Linux - Networking 6 04-28-2001 12:49 AM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration