LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   samba: 5718 session request failed (http://www.linuxquestions.org/questions/linux-networking-3/samba-5718-session-request-failed-332211/)

ragecyr 06-10-2005 10:16 AM

samba: 5718 session request failed
 
I am trying to map a network share.
This computer is on a DHCP, and it is getting it's IP correctly. I can ping and be pinged from the computer to others on the network, including the dhcp computer where i am trying to get a share from.

IP is changed to 2.2.2.222 for this.
Code:

mount -t smbfs //2.2.2.222/sharename /mnt/N -o user=administrator
2.2.2.222 is a windows NT box.

I get
5756: session request to 2.2.2.222 failed (Called name not present)
5756: session request to 10 failed (Called name not present)
Password:

i put in the admin pass for the box and get:
5756: session setup failed: ERRDOS -ERRnoaccess (Access denied.)
SMB connection failed



to me the errors mean 'hey, cant find 2.2.222', 'still cant find it', 'give me the password for the share even though i cant find it', 'could find it, so fail'


Can anyone point me in the right direction?

Mega Man X 06-10-2005 10:31 AM

Doesn't the administratior have a password in that machine? Try:

Code:

mount -t smbfs -o username=your_user_name,password=your_password //2.2.2.222/sharename /mnt/N

ragecyr 06-10-2005 10:36 AM

it does, and it prompts me for the pass (and i put it in).
Tried your code, same results as above but without it asking for my pass.


5756: session request to 2.2.2.222 failed (Called name not present)
5756: session request to 10 failed (Called name not present)
5756: session setup failed: ERRDOS -ERRnoaccess (Access denied.)



incase it helps at all, i was able to print to a shared printer on that same computer (2.2.2.222), so it doesn't seem like a network problem.

Mega Man X 06-10-2005 11:01 AM

I get the exact same error message if I try to mount a samba shared without the password on the mount line. Give the command I suggested above a try and see if it makes any difference ;)

ragecyr 06-10-2005 11:05 AM

Quote:

Originally posted by ragecyr
Tried your code, same results as above but without it asking for my pass.
5756: session request to 2.2.2.222 failed (Called name not present)
5756: session request to 10 failed (Called name not present)
5756: session setup failed: ERRDOS -ERRnoaccess (Access denied.)


same thing, no luck.

Mega Man X 06-10-2005 11:28 AM

That's very strange. I will play a last card, I'm not so good with networking, I just had luck to get things to work I guess :).

1 - Make sure both computers are on the same network. You can edit your /etc/smb.conf (or wherever your smb.conf is, could be /etc/samba/smb.conf, for example). For Windows, I think the default is MSHOME or something. Anyway, my network is called LIGHT, so, my smb.conf looks like this:

Code:

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
  workgroup = LIGHT

You can change the network name in Windows by right-clicking on "My Computer" if I remember right.

2 - Try referring to your computer name ratter then the IP address. I doubt this step will make any difference, but if you are also running out of ideas... :)

Code:

mount -t smbfs -o username=your_user_name,password=your_password //computer_name/sharename /mnt/N
You computer name is your hostname. In Linux, it could be changed by editing /etc/hostname. In Windows, once again right-click the My Computer icon and choose the name.

3 - Make sure the share points are right. In Windows, it's just a matter to edit right click in a folder and choose properties, shared, or something like that.... you will find it ;). In Linux, you've to add your share points by once again editing your /etc/smb.conf. Example:

Code:

[shared]
path = /home/shared
comment = Zero's shared files
available = yes
browseable = yes
public = yes
writable = yes

Here is a bad ASCII illustration of my network.

Code:


            |--------- megamanx
router -- |--------- sigma
            |--------- zero

I always pass as argument to mount, the computer name ratter then IP address. For example, mounting Zero's share under Megaman X:

Code:

mount -t smbfs -o username=your_user_name,password=your_password //zero/shared /mnt/data
In Linux, it's necessary to add an samba user. Let's say I have an user in my system called tux. To add tux to the samba share, I do:

Code:

smbpasswd -a tux
You may want to read this too:

http://www.tldp.org/HOWTO/SMB-HOWTO.html

I'm afraid I can offer no more help my friend. I wish you luck though :)

ragecyr 06-10-2005 12:02 PM

i went through that howto, and most of it is sharing linux to windows and linux to linux, not accessing windows from linux.

on the smb.conf you were right on there, i had it as whatever the default is, not what it should have been.
fixed that and rebooted.

Now i am getting close to the same errors but different numbers.


4192: Session request to 2.2.2.222 failed (called name not present)
4192: session request to 2 failed (called name not present)

trying it with the server name instead of the ip yielded
4251: connection to computername failed
SMB connection failed.










If there is a howto or instruction guide for accessing windows shares from linux in a domain environment, i would love to read it and not waiste any more of your time, but everything ive read is for the inverse.

Thanks for your help though, i know its a pain to troubleshoot linux problems!

Mega Man X 06-10-2005 12:21 PM

No problems mate. I hope you can get it to run though ;). I've found a .pdf file on google which is exactly what you were looking for, accessing files located on a Windows machine with Linux:

http://portal.dfpug.de/dFPUG/Dokumen...orkstation.pdf

Don't worry, it's in English ;) There's also a .html version, but I found the .pdf nicer to read and has pictures. But if you prefer the .html:

http://216.239.59.104/search?q=cache...=sv&lr=lang_en|lang_pt|lang_sv%20target=nw[/url]

I know how frustrating things can be sometimes mate. But keep on to it, at the end you learn a lot and if you have nothing to do in the weekend as me, you will have some fun :)

Good luck!

Note: the above link looks all messed up, but it works. I'm removing the smiles =)


All times are GMT -5. The time now is 03:19 AM.