LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-26-2005, 01:11 AM   #1
bburnham1141
LQ Newbie
 
Registered: Aug 2003
Location: Columbus, OH
Distribution: Knoppix 3.7 ( HD install )
Posts: 11

Rep: Reputation: 0
Samba 3.0 as PDC - adding computer accounts help


hello this is my first thread so here it goes.

i recently installed Samba 3.0

i have been working from a book on linux i picked up, and so far it is great ( Using Samba by O'Reilly ISBN 0596002564) i have followed the directions on editing the smb.conf file or creating a new one. this is what i have so far:

[global]

workgroup = knoppix
encrypt passwords = yes
netbios name = knoppix

domain master = yes
local master = yes
preferred master = yes
os level = 65

security = user
domain logons = yes
logon path = \\%L\profiles\%u\%m
logon script = logon.bat
logon drive = H:
logon home = \\%L\%u\.win_profile\%m

time server = yes

domain admin group = root Benjamin Burnham

[netlogon]
path = /usr/local/samba/lib/netlogon
writable = no
browsable = no

[profiles]
path = /home/samba-ntprof
browsable = no
writable = yes
create mask = 0600
directory mask = 0700

[homes]
read only = no
browsable = no
guest ok = no
map archive = yes

[test]
comment = for testing only, please
path = /usr/local/samba/tmp
read only = no
guest ok = yes
[HDC1]
comment = shared folder HD
path = /mnt/hdc1
read only = yes
guest = yes


please ignore the last share as i don't know if i did it right

the examples on how to add a computer account is not easily understood, i need help. from my XP Pro box i can connect to Samba PDC but the authentication fails. ( i tried to add a computer account ) if there is anybody out there that kows how i might solve this problem great!!! or even a way to improve my smb.conf file.

Thanks for anything!!!
 
Old 03-26-2005, 09:16 AM   #2
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
Follow the links in this post should provide you some help:

http://www.justlinux.com/forum/showt...ight=samba+pdc

Some of the versions may be out of date but the principles should still work.
 
Old 03-26-2005, 08:02 PM   #3
bburnham1141
LQ Newbie
 
Registered: Aug 2003
Location: Columbus, OH
Distribution: Knoppix 3.7 ( HD install )
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for the thread info!! it helped some, but when i try to log in now i get "access denied"

oh and i stumbled onto something else, don't know if this is the problem or not. i have two smaba directories
1; /usr/local/smaba
2: /etc/samba

does this mean that i have two copies of samba? could they be conflicting?

i know that i have two separate smb.conf files, one in each dir.

The samba that i installed my self is at /usr/local/samba
 
Old 03-27-2005, 07:31 AM   #4
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
Were you able to successfully join your XP workstations to the Samba domain?

Where Samba is installed in Linux depends on how you installed it.
If you install it from some sort of package that is designed for Linux, you'll probably find the configuration files in /etc/samba. That's because Linux is designed to have all configuration files under /etc so that the /usr directory can be mounted as read only for security purposes.
If you compile Samba on your machine and install if from that, you'll probably find the configuration files under /usr/local/samba which is the default for Unix.
On my RH machine, I have no /usr/local/samba directory. The configuration files are in /etc/samba, the executables are in /usr/bin and /usr/sbin and the documentation is under /usr/share/doc. I installed Samba from an rpm package available from samba.org, not from an rpm package from Red Hat.
If you have an smb.conf file in 2 places and you're not sure which one is actually being used, make some minor changes to them and restart samba. Which one the changes occur after is the smb.conf file your installation of Samba is actually using.
 
Old 03-27-2005, 03:39 PM   #5
bburnham1141
LQ Newbie
 
Registered: Aug 2003
Location: Columbus, OH
Distribution: Knoppix 3.7 ( HD install )
Posts: 11

Original Poster
Rep: Reputation: 0
i am not able to join the PDC. i am at a loss as to what it could be........i think i will try to start over with a new smb.conf file or just reinstall samba so i have a clean slate


Thank you for all your help!!!!!!!!!!!!!!!!!
 
Old 03-30-2005, 01:11 AM   #6
bburnham1141
LQ Newbie
 
Registered: Aug 2003
Location: Columbus, OH
Distribution: Knoppix 3.7 ( HD install )
Posts: 11

Original Poster
Rep: Reputation: 0
update

OK this is where i am now:

1. new smb.conf file:


;************************************************************************************************
; Samba Primary Domain Controller Configuration file
;************************************************************************************************
[GLOBAL]

workgroup = knoppix
netbios name = Samba
encrypt passwords = yes
security = user
time server = no

;************************************PDC-INFO****************************************************

domain master =yes
local master = yes
preferred master = yes
os level = 64
domain logons = yes
wins support = yes
dns proxy = no

logon path = \\%L\profiles\%u\%m
logon script = logon.bat
logon drive = H:
logon home = \\knoppix\%u\.win_profile\%m
smb passwd file = /etc/samba/smbpasswd
unix password sync = yes
passwd program = /usr/bin/passwd %u
add user script = /usr/sbin/useradd -d /dev/null -g machines -c 'Machine Account' -s 100 -s /bin/false -M $u
host msdfs = yes
server string = Primary Domain Server running SAMBA %v
Socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192

[netlogon]
path = /etc/samba/lib/netlogon
writable = no
browsable = no

[profiles]
path = /etc/samba/ntprof
browsable = no
writable = yes
create mask = 0600
directory mask = 0700

;*******************************************Shares***********************************************



[homes]
read only = no
browsable = no
guest ok = no
map archive =yes


[TEST]

comment = For Testing Only, Please!!
path = usr/local/samba/tmp
read only = no
guest ok = yes



2. i have edited my XP Pro registry value from 1 to 0
3. have rune smbpasswd -a root
.......
4. have also added samba user "domain"

when i try to logon to the PDC for the first time with username "root" and error message says the the user cannot be found

but

when i try to logon with user " domain" the error message says "access denied"

so....my XP Pro machine is reaching the PDC but cannot verify any user info.....or......i have no idea lol!!!!


please help
 
Old 12-16-2005, 11:38 AM   #7
amitsharma_26
Member
 
Registered: Sep 2005
Location: New delhi
Distribution: RHEL 3.0/4.0
Posts: 777

Rep: Reputation: 31
First thing you need to do on your *nix box.
useradd -s /bin/false/ -d /dev/null <machine-name>$

&

smbpasswd -a -e -m <machine-name>

Thats it. Your work is now finished on your *nix box.

Now go to your XP box & add your machine to domain. I guess for that you have to Right-Click on My-computer & go to properties tab & there under identification tab, you have to change your box from your existing workgroup to your preffered domain. It will soon ask you for user & pass, you have to enter your *nix root & pass over there.

Domain will welcome you.

Prior to all this, you should add your 'root' user to smbpasswd.

I hope its clear.

..amit..
 
Old 05-07-2009, 07:22 PM   #8
brollyson
LQ Newbie
 
Registered: May 2009
Posts: 2

Rep: Reputation: 0
Smile

Quote:
Originally Posted by amitsharma_26 View Post
First thing you need to do on your *nix box.
useradd -s /bin/false/ -d /dev/null <machine-name>$

&

smbpasswd -a -e -m <machine-name>

Thats it. Your work is now finished on your *nix box.

Now go to your XP box & add your machine to domain. I guess for that you have to Right-Click on My-computer & go to properties tab & there under identification tab, you have to change your box from your existing workgroup to your preffered domain. It will soon ask you for user & pass, you have to enter your *nix root & pass over there.

Domain will welcome you.

Prior to all this, you should add your 'root' user to smbpasswd.

I hope its clear.

..amit..
I was really troubled that I couldn't join my samba domain with my XP pro box ... here is what I did and it worked great....

I used putty to ssh into my centos/samba box -- I ran the command #net join <name of computer to join> followed by a $

then went to my windows box and was able to join just fine using administrator and the password for root.

It was that simple for me.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding Linux Clients to Samba PDC, 2 things RaVilj Linux - Networking 1 09-27-2005 04:42 PM
samba accounts/ unix accounts Buzz88 Linux - Newbie 3 09-25-2005 08:16 AM
adding new email accounts with qmail tebucky Linux - Newbie 0 09-15-2005 10:55 AM
2nd root (for adding client machines to Samba PDC) ? muah Linux - Security 4 02-01-2004 09:26 AM
PDC user Accounts saavik Linux - Networking 2 07-28-2003 07:51 AM


All times are GMT -5. The time now is 09:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration