LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 04-07-2009, 04:34 AM   #1
vyruz18
LQ Newbie
 
Registered: Apr 2009
Posts: 3

Rep: Reputation: 0
Samba 3.0.33 - problems accessing windows domain, and shares not visible


Hi, I'm new here

I just got my Gentoo installation running, which was also the first time ever I compiled a kernel myself
It's running kernel 2.6.27-r8
I'm setting this virtual box (runs on VMware server 2.0) up to be used as a webserver (apache/php/mysql).

I've got samba 3.0.33 installed, but i'm having some difficulties getting everything running as I want it:
There are 2 main problems:
- I cannot get the box onto our windows domain (not active directory)
- I've got a share setup in the box, but this share is not visible to windows boxes

This is my smb.conf (changed domain for obvious reasons, but notice there are 2 dots in there...):

Code:
[global]
workgroup               = BLABLA.COMPANY.COM
netbios name            = GENTOO
security                = domain
encrypt passwords       = yes
password server         = *
unix password sync      = yes
log file                = /var/log/samba/log.%m
max log size            = 50

[data]
comment                 = public share
path                    = /pub
guest ok                = yes
public                  = yes
browsable               = yes
First of all, when I try to join the domain with:
Code:
net join -w BLABLA.COMPANY.COM -U user1
I get:
Code:
Unable to find a suitable server
Unable to find a suitable server
When I do a wireshark trace on that box, I see that the Gentoo box
tries to reach the DC on hostname "BLABLA.COMPANY" (it's droppping the .COM!!) which obviously doesn't work.

So I use:
Code:
net join -w BLABLA.COMPANY.COM -S <our DC's IP> -U user1
Now the communication with the DC is working but I get:
Code:
[2009/04/07 09:40:44, 0] utils/net_rpc_join.c:net_rpc_join_newstyle(367)
  Error in domain join verification (credential setup failed): NT_STATUS_INVALID_COMPUTER_NAME
This seems like a strange error since our domain is set up to auto-create computers if they try to connect, provided that the giver user has the appropriate rights (user1 does).

I read somewhere that you should emerge samba with the +kerberos option, however when I do:
Code:
emerve -pv samba
I get:
Code:
[ebuild   R   ] net-fs/samba-3.0.33  USE="acl cups ldap pam python readline winbind -ads -async -automount -caps -debug -doc -examples -fam -ipv6 -oav -quotas (-selinux) -swat -syslog" 0 kB
So apparently in my setup there is no kerberos option.
Even manually putting in the /etc/portage/package.use file like so:
Code:
net-fs/samba acl winbind kerberos -ipv6
Doesn't install the kerberos option...

Any Ideas??
It's probably something I'm looking over the head as this is my first Gentoo install (only experience with graphical installations so far...)

Edit : Removed question about not being able to access the share on my linux box from a windows box.
Changing security = from domain to share fixed this problem, so I probably need to get security = domain working first...

Last edited by vyruz18; 04-07-2009 at 05:13 AM.
 
Old 04-08-2009, 03:08 PM   #2
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2
Posts: 1,571
Blog Entries: 13

Rep: Reputation: 182Reputation: 182
I presume you've looked at www.samba.org; I particularly recommend the By-Example user guide:
http://us6.samba.org/samba/docs/man/Samba-Guide/ (assuming you're in the us)
Welcome to LQ!

Last edited by mostlyharmless; 04-08-2009 at 03:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing samba workgroup shares from a different domain? FastForward Linux - Server 3 03-12-2009 04:47 PM
accessing samba shares from windows xubuntu_idiot Linux - Software 1 09-05-2006 01:25 PM
Accessing Windows shares in a domain humbletech99 Linux - Networking 6 03-29-2006 02:02 AM
Accessing samba shares from a windows machine lacitpo Linux - Software 2 12-13-2004 07:47 AM
Problem accessing windows shares using samba Tinku Linux - Software 6 08-05-2004 08:47 PM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration