LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-25-2006, 11:59 PM   #1
KneeLess
Member
 
Registered: May 2003
Distribution: Debian GNU/Linux 3.0 Sid, OpenBSD 3.5
Posts: 190

Rep: Reputation: 30
Running my own top level domain with BIND9


Hello, I am attempting to run my own TLD but named is telling me that it has no NS records, and won't resolve. I don't know much about BIND, and what I have is a crudely amalgamated configuration pieced together from several books and websites. The command 'host emory.athf' doesn't work (well, obviously).

named.conf:
Code:
zone "athf" IN {
  type master;
  file "athf";
  allow-transfer { 10.0.0.0/8; };
  allow-query { 10.0.0.0/8; };
};
/etc/namedb/athf:
Code:
$ORIGIN athf.
$TTL 86400

@ IN SOA emory.athf. root.emory.athf. (
2002090100 ;
10800 ;
3600 ;
604800 ;
60 ;
)

IN NS emory.

ns IN A 10.0.0.1
nic IN A 10.0.0.1

emory IN A 10.0.0.1
majorshake IN A 10.0.0.50
And here is the actual error from /var/log/messages:
Code:
Mar 26 00:48:50 Emory named[1302]: zone athf/IN: has no NS records
 
Old 03-26-2006, 07:24 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,897

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
IN NS emory.
Well, this is wrong. You should either remove the trailing dot, or write the full hostname ending whith the dot.
Code:
IN NS emory
or
IN NS emory.athf.
That is because if the dot is not present, bind adds the domain at the end
 
Old 03-26-2006, 11:14 AM   #3
KneeLess
Member
 
Registered: May 2003
Distribution: Debian GNU/Linux 3.0 Sid, OpenBSD 3.5
Posts: 190

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by bathory
Well, this is wrong. You should either remove the trailing dot, or write the full hostname ending whith the dot.
Okay, I changed my file to this now:
Code:
$ORIGIN athf.
$TTL 86400

@ IN SOA emory.athf. root.emory.athf. (
2002090100 ;
10800 ;
3600 ;
604800 ;
60 ;
)

IN NS emory

ns IN A 10.0.0.1
nic IN A 10.0.0.1

emory IN A 10.0.0.1
majorshake IN A 10.0.0.50
Unfortunately, the same error comes up with either of your fixes.
 
Old 03-26-2006, 12:26 PM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,897

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
2002090100 ;
You didn't change the serial? Everytime you make a change in a zone file you must increase the serial, so that named re-reads it. Note that the format of the seriai is usually YYYYMMDDNN (Year, Month, Day, revision Number), so you always know when you last changed it.
 
Old 03-26-2006, 06:29 PM   #5
scowles
Member
 
Registered: Sep 2004
Location: Texas, USA
Distribution: Fedora
Posts: 620

Rep: Reputation: 31
Either indent your NS record (continuation from previous record) or change it to:

@ IN NS emory
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Top Level Domain Names wwnexc Linux - Networking 3 03-12-2006 02:03 PM
[bind9] how set default search domain? nio Linux - Software 2 08-13-2005 03:52 PM
Missing top level topics in yelp for some users in RH9 timyaukey Red Hat 0 01-03-2005 08:30 AM
DNS & Top Level Domain JJX Linux - Networking 2 03-28-2004 07:56 AM
FTP - setting top level dir donokono Linux - Networking 2 06-18-2002 06:17 PM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration