LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-06-2009, 12:51 PM   #1
chackercon
Member
 
Registered: Jan 2008
Location: Oklahoma
Distribution: Slackware, QNX, Centos 5.2, Dream Linux, BackTrack, Fedora
Posts: 53

Rep: Reputation: 18
RSH connect to address 192.168.1.xxx port 544: Connection refused Permission denied


I am installing some software that uses a MPI to pass parts of programs to cluster computers. This requires RSH to run the commands on the compute nodes.

I am running CENTOS 5

uname -a
Linux 2.6.18-92.el5 #1 SMP Tue Jun 10 18:51:06 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

I have setup IP MASQ so the head node routs all the traffic.

iptables -L

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

I know that this is working.

cat securetty

tty11
rsh
rlogin
rexec

xinetd.d/rsh
disable = no
socket_type = stream
wait = no
user = root
log_on_success += USERID
log_on_failure += USERID
server = /usr/sbin/in.rshd
}
xinetd.d/rlogin

service login
{
socket_type = stream
wait = no
user = root
log_on_success += USERID
log_on_failure += USERID
server = /usr/sbin/in.rlogind
disable = no

xinetd/rexec

socket_type = stream
wait = no
user = root
log_on_success += USERID
log_on_failure += USERID
server = /usr/sbin/in.rexecd
disable = no
chkconfig --list |grep rsh
rsh: on

I know that this is probably something that I am doing wrong any help would be apreciated.

Thank you
Mike
 
Old 04-07-2009, 06:19 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Your port probably is not open for incoming connections.
 
Old 04-07-2009, 09:52 AM   #3
chackercon
Member
 
Registered: Jan 2008
Location: Oklahoma
Distribution: Slackware, QNX, Centos 5.2, Dream Linux, BackTrack, Fedora
Posts: 53

Original Poster
Rep: Reputation: 18
Thank you for the reply
I have confirmed that the ports are open and that I can contact the port via telnet.

What about the hosts.equiv? should I be putting machines and users in this file?

Last edited by chackercon; 04-07-2009 at 10:44 AM.
 
Old 04-09-2009, 04:24 PM   #4
chackercon
Member
 
Registered: Jan 2008
Location: Oklahoma
Distribution: Slackware, QNX, Centos 5.2, Dream Linux, BackTrack, Fedora
Posts: 53

Original Poster
Rep: Reputation: 18
I got this to work. It has taken a few days for me to think about posting this so sorry for the delay. The issue was with authentication, if you go into the /etc/pam.d/rsh file and move rlogin and rsh to the top and make it look like this it will work just fine.
# For root login to succeed here with pam_securetty, "rsh" must be
# listed in /etc/securetty.
auth required pam_nologin.so
auth required pam_securetty.so
auth required pam_env.so
auth required pam_rhosts_auth.so
account include system-auth
session optional pam_keyinit.so force revoke
session include system-auth

Thank you for the input.

Mike
 
Old 04-10-2009, 12:28 PM   #5
shada
LQ Newbie
 
Registered: Apr 2009
Posts: 5

Rep: Reputation: 1
Quote:
Originally Posted by chackercon View Post
I got this to work. It has taken a few days for me to think about posting this so sorry for the delay. The issue was with authentication, if you go into the /etc/pam.d/rsh file and move rlogin and rsh to the top and make it look like this it will work just fine.
# For root login to succeed here with pam_securetty, "rsh" must be
# listed in /etc/securetty.
auth required pam_nologin.so
auth required pam_securetty.so
auth required pam_env.so
auth required pam_rhosts_auth.so
account include system-auth
session optional pam_keyinit.so force revoke
session include system-auth

Thank you for the input.

Mike
Hi,
Using your post. I was able to enable rlogin. However, rsh is still not working. Any pointers will be appreciated...
 
Old 04-10-2009, 09:10 PM   #6
chackercon
Member
 
Registered: Jan 2008
Location: Oklahoma
Distribution: Slackware, QNX, Centos 5.2, Dream Linux, BackTrack, Fedora
Posts: 53

Original Poster
Rep: Reputation: 18
Did you get my email? Make sure that you have the hosts.equiv and the .rhosts file created the contents of these file need to be +host +user. Other options are available if you have any more questions please let me know.

Thank you
Mike
 
Old 04-10-2009, 11:57 PM   #7
shada
LQ Newbie
 
Registered: Apr 2009
Posts: 5

Rep: Reputation: 1
Can you please post your /etc/pam.d/rsh

May be my /etc/pam.d/rsh file is messed up. Is it different from /etc/pam.d/rlogin file?

Can you please post your /etc/pam.d/rsh ?
 
Old 04-11-2009, 12:02 AM   #8
shada
LQ Newbie
 
Registered: Apr 2009
Posts: 5

Rep: Reputation: 1
Smile

Quote:
Originally Posted by chackercon View Post
Did you get my email? Make sure that you have the hosts.equiv and the .rhosts file created the contents of these file need to be +host +user. Other options are available if you have any more questions please let me know.

Thank you
Mike

Got it working. Thank you for your help and tips. I am thanking you officially as well.
 
Old 04-23-2009, 02:06 AM   #9
shada
LQ Newbie
 
Registered: Apr 2009
Posts: 5

Rep: Reputation: 1
>Thank you did you get VNC server running?

Yes, I finally got vino (vncserver) working. As root:
yum install vino

sudo reboot

Then enable vncserver service from:
System ---> Administration ---> Services ---> vncserver
"Enable"

After it is enabled, start the the service.
System ---> Administration ---> Services ---> vncserver
"Start"

It may say "refreshing service" but eventually gets done.

Reboot, it should have started automatically.

As a normal user, configure vncserver from:
System ---> Preferences ---> Internet and Network ---> Remote Desktop

You select the options. You can also, switch to the "Advanced" tab and change the port for the service.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: connection to "192.168.0.10:2.0" refused by server lumix Linux - Newbie 1 05-21-2008 06:04 PM
mount: mount to NFS server '192.168.0.3' failed: System Error: Connection refused. fakie_flip Linux - Server 1 04-10-2008 12:28 AM
What route to access daisy chained 2d router 192.168.1.1 after 192.168.0.1 (subnets?) Emmanuel_uk Linux - Networking 6 05-05-2006 01:47 AM
[new bie] sshd: refused connect from 192.168.x.x jmcollin92 Linux - Security 2 12-14-2003 02:39 AM
Permission Denied on a RSH Connection Eluminator Linux - Software 4 11-08-2002 03:06 AM


All times are GMT -5. The time now is 05:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration