-   Linux - Networking (
-   -   Routing Problem? Help Needed. (

KevinGuy 07-10-2003 05:01 PM

Routing Problem? Help Needed.
Alright, Here is the situation.

First of all, I am new to linux sort of. I am running RedHat 8.0

Ok, There is two seperate networks.

The first is

The second is is a network that is using DHCP for there internet access. will be using static IP's. There will be about 3 - 6 machines that will be using this network. This network will be connecting through to gain internet access. is using a router given to them by Qwest. Router's address is of course. will be using the linux machine.

The linux maching will be acting as router to pass packets from to for internet access.

Alright, now that you know all that.. Here is the problem.

My Linux machine has of course two network cards in it, one being by DHCP) and the other being

From the linux box I can ping everything from the internet to my inside network, example being a station with

Now when I go to that station I can ping everything to and anything past that I cannot ping, an example being or the internet.

Does this relate to my routing tables or does this relate to Permission and my iptables.

Here is my netstat -r

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface * U 40 0 0 eth0 * U 40 0 0 eth1 * U 40 0 0 eth0 * U 40 0 0 lo
default UG 40 0 0 eth0

Am I missing something in there, To me it doesnt look like I am, but I coudl be over looking something.


serz 07-10-2003 07:17 PM

I belive it is because your second NIC is using other broadcast.

Try changing to or something.

KevinGuy 07-10-2003 07:29 PM is just another computer on the network.

The two network cards on the Router are.



KevinGuy 07-11-2003 03:11 PM


david_ross 07-11-2003 03:18 PM

You have 2 cards using the same network - this won't work properly. Like serz said - change one of your networks.

neo77777 07-11-2003 03:21 PM

Yep, it is right there in your routing table * U 40 0 0 eth0 * U 40 0 0 eth0

KevinGuy 07-11-2003 03:39 PM

Hrmm, I have one card using the outsiide network which is and I have one card for out inside network which is

How are they using the same network?

What do I need to change in my routing table?

david_ross 07-12-2003 05:21 AM

route del netmask dev eth0

All times are GMT -5. The time now is 08:24 AM.