LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-03-2012, 02:37 PM   #1
sdonald
LQ Newbie
 
Registered: Feb 2010
Posts: 10

Rep: Reputation: 0
Routes showing up twice in route command


I am having network problems and hopefully have a pointer to my problem. Executing the route command shows:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
89.89.41.0 * 255.255.255.0 U 0 0 0 eth1
89.89.41.0 * 255.255.255.0 U 0 0 0 eth1
89.89.43.0 * 255.255.255.0 U 0 0 0 eth0
89.89.43.0 * 255.255.255.0 U 0 0 0 eth0
89.89.42.0 * 255.255.255.0 U 0 0 0 eth2
89.89.42.0 * 255.255.255.0 U 0 0 0 eth2
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default Wfleet43 0.0.0.0 UG 0 0 0 eth0

Why does each entry show up twice? Could this be causing a problem?
I tried removing one of each route, but they come back on reboot.
Any information would be helpful.
 
Old 07-03-2012, 09:39 PM   #2
zer0signal
Member
 
Registered: Oct 2010
Location: Cleveland
Distribution: Slackware, Fedora, RHEL (4,5), LFS 6.7, CentOS
Posts: 258

Rep: Reputation: 29
What Distro is this running on....


If this is a Redhat based OS, please look in:

ls -l /etc/sysconfig/network-scripts/

for a route file...
 
Old 07-05-2012, 02:10 PM   #3
sdonald
LQ Newbie
 
Registered: Feb 2010
Posts: 10

Original Poster
Rep: Reputation: 0
It is redhat linux.
There is an ifcfg-eth0, ifcfg-eth1, and ifcfg-eth2 with the correct data. They were last modified in 2004.
None of the other files in /etc/sysconfig/network-scripts have been modified since installation.

linuxconf --hint routing returns
IPV4ROUTING="true"
DEV_RECONF_ROUTES=""

/etc/sysconfig/static-routes has length of 0 and is empty.

Why would these routes be added twice at boot time?
 
  


Reply

Tags
network, route


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] problem in adding routes with ip route pendrive Linux - Networking 3 07-04-2013 09:30 AM
[SOLVED] howto to route 2 subnets between 2 routes sys7em Linux - Networking 1 10-28-2010 02:39 PM
Linux HA: ipvsadm showing inconsistent routes ptemmerman Linux - Server 1 11-10-2008 10:04 AM
static routes using route-eth0 file sti2envy Linux - Networking 2 09-08-2007 09:10 AM
I am not able to add a new route to my route table using route command prashanth s j Linux - Networking 2 09-03-2005 04:34 AM


All times are GMT -5. The time now is 09:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration