LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 08-17-2006, 08:01 PM   #1
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Rep: Reputation: 15
Router/Security settings to enable FTP


Hey all,

I have a CentOS box running on my local network, and am trying to ftp to it. vsftpd is running, and the box can successfully ftp to itself without issue. However, when trying to ftp to the box from another computer, it spits out errors.

I either get "No route to host", or the ftp client enters "extended passive mode" and then spits out "bad EPRT protocol".

I'm thinking it is my router, though I suppose it could be security settings on the CentOS box itself. I have a WRT54GL linksys router, with the original firmware.

Also, iptables are configured to allow FTP on the server.

Edit: I have my router set to allow port 21 TCP connections for the server's IP.

Anyone have any ideas?

Thanks!

Last edited by Gamezace; 08-17-2006 at 08:16 PM.
 
Old 08-17-2006, 08:23 PM   #2
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
Quote:
No route to host
can you ping the machine from this computer? I guess you havent properly configured your network settings on this computer.
 
Old 08-17-2006, 08:25 PM   #3
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Original Poster
Rep: Reputation: 15
Yes, I can ping the machine from all the computers on the network.
 
Old 08-18-2006, 05:02 PM   #4
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Original Poster
Rep: Reputation: 15
I figured it out - for anyone who finds this thread with similar troubles, I needed to create the settings for passive FTP mode.
 
  


Reply

Tags
ftp, pasv, router


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable OSPF in Linux Router becky_starr Linux - Networking 1 12-21-2004 01:11 PM
security settings buzzycoy Linux - Security 2 12-09-2004 09:22 AM
security settings!! blind958 Mandriva 1 07-16-2004 02:49 PM
How do I enable loopback in a router? Usalabs Linux - Wireless Networking 1 04-09-2004 10:43 PM
security settings infamous41md Linux - Newbie 1 06-03-2003 10:18 PM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration