LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-18-2003, 12:31 PM   #1
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Rep: Reputation: 30
Router/NAT and Dynaimc DNS


Im trying to use Dynamic DNS service http://www.dynu.com or http://www.no-ip.com and others, I think that my current config is NATt/PAT, I did a reverse mapping to my NAT, I added "ip nat inside source static tcp 192.168.25.3 80 10.28.1.29 80 extendable" and still doesnt works. Also I tried with the below config
ip nat inside source static tcp 192.168.25.3 80 interface ATM0 80
and
ip nat inside source static tcp 192.168.25.3 80 interface ATM0 711

I think the router doesn't have port forwarding configured so it just denies the connection. So I need to configure port forwarding.

why cannot access my webserver? what could be the problem?

Current Config
-------------------------------------------------------------------

Current configuration : 1287 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Client_Name
!
enable secret 5 $%&/()=!"!"$%%$$$&
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip dhcp excluded-address 192.168.25.1
ip dhcp excluded-address 192.168.25.5 192.168.25.254
!
ip dhcp pool dsl1
network 192.168.25.0 255.255.255.0
default-router 192.168.25.1
domain-name ilrnet.net
dns-server 216.230.128.3 216.230.128.32
!
!
!
!
interface Ethernet0
ip address 192.168.25.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface ATM0
description Client_No.Serie_DSLAM_Port DSLAM_ TEL
ip address 10.28.1.30 255.255.255.252
ip nat outside
no atm ilmi-keepalive
pvc 0/32
protocol ip 10.28.1.29
encapsulation aal5snap
!
dsl operating-mode auto
hold-queue 224 in
!
ip nat inside source list 101 interface ATM0 overload
ip nat inside source static tcp 192.168.25.3 80 10.28.1.29 80 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 10.28.1.29
no ip http server
ip pim bidir-enable
!
access-list 101 permit ip 192.168.25.0 0.0.0.255 any
!
line con 0
stopbits 1
line vty 0 4
password 7 888888999273534
login
!
scheduler max-task-time 5000
end
 
Old 11-18-2003, 02:51 PM   #2
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
>ip nat inside source static tcp 192.168.25.3 80 10.28.1.29 80 extendable

Both of those ip addresses are reserved-for-lan addresses. Neither of those addresses can be reached from the internet.

If 10.28.1.29 is the address given to you by your isp then you are going to have to ask your ISP for an address that is reachable from the internet or for them to forward the port through their NAT.

>NATt/PAT
I assume you mean NAT/PAT. If your isp is using NAT then incoming connections to your port 80 are blocked.
 
Old 11-18-2003, 04:16 PM   #3
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Original Poster
Rep: Reputation: 30
My IP address reachable from the internet is 216.230.149.10, and yes, my ISP is suing NAT, what I need to do if the 80 port is blocked? below my ip nat trans

Name_Client#sh ip nat trans
Pro Inside global Inside local Outside local Outside global
tcp 10.28.1.30:36668 192.168.25.3:36668 216.230.149.10:21 216.230.149.10:21
tcp 10.28.1.30:36660 192.168.25.3:36660 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36661 192.168.25.3:36661 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36694 192.168.25.3:36694 198.144.7.122:23 198.144.7.122:23
tcp 10.28.1.30:36664 192.168.25.3:36664 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36672 192.168.25.3:36672 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36686 192.168.25.3:36686 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36685 192.168.25.3:36685 198.144.7.122:80 198.144.7.122:80
tcp 10.28.1.30:36712 192.168.25.3:36712 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36717 192.168.25.3:36717 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36727 192.168.25.3:36727 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:36726 192.168.25.3:36726 198.144.7.122:80 198.144.7.122:80
udp 10.28.1.30:35865 192.168.25.2:35865 66.98.158.185:33033 66.98.158.185:33033
tcp 10.28.1.30:36695 192.168.25.3:36695 24.118.52.210:443 24.118.52.210:443
tcp 10.28.1.30:36701 192.168.25.3:36701 24.118.52.210:443 24.118.52.210:443
tcp 10.28.1.30:36728 192.168.25.3:36728 24.118.52.210:443 24.118.52.210:443
tcp 10.28.1.30:1029 192.168.25.2:1029 64.246.49.60:33033 64.246.49.60:33033
tcp 10.28.1.30:36653 192.168.25.3:36653 216.239.39.99:80 216.239.39.99:80
tcp 10.28.1.30:1028 192.168.25.2:1028 80.160.91.13:80 80.160.91.13:80
tcp 10.28.1.30:80 192.168.25.3:80 --- ---
udp 10.28.1.30:35865 192.168.25.2:35865 64.246.49.61:53802 64.246.49.61:53802
udp 10.28.1.30:32776 192.168.25.3:32776 216.230.128.3:53 216.230.128.3:53
tcp 10.28.1.30:36748 192.168.25.3:36748 63.215.241.204:8245 63.215.241.204:8245
tcp 10.28.1.30:1036 192.168.25.2:1036 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:1065 192.168.25.2:1065 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:1068 192.168.25.2:1068 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:1070 192.168.25.2:1070 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:1072 192.168.25.2:1072 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:1074 192.168.25.2:1074 216.230.149.10:80 216.230.149.10:80
tcp 10.28.1.30:1073 192.168.25.2:1073 198.144.7.122:80 198.144.7.122:80
tcp 10.28.1.30:36745 192.168.25.3:36745 204.69.199.39:80 204.69.199.39:80
tcp 10.28.1.30:36747 192.168.25.3:36747 204.69.199.39:80 204.69.199.39:80
tcp 10.28.1.30:36749 192.168.25.3:36749 204.69.199.39:80 204.69.199.39:80
tcp 10.28.1.30:36750 192.168.25.3:36750 204.69.199.39:80 204.69.199.39:80
tcp 10.28.1.30:36752 192.168.25.3:36752 204.69.199.39:80 204.69.199.39:80
udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33438 198.144.7.122:33438
udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33439 198.144.7.122:33439
udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33440 198.144.7.122:33440
udp 10.28.1.30:33556 192.168.25.3:33556 198.144.7.122:33441 198.144.7.122:33441
 
Old 11-21-2003, 11:06 AM   #4
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
This is outside my experiance. Perhaps someone will be able to help if you describe more about you network setup. How is the ATM connection hooked in to the machine?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAT and DNS Question whohasit Linux - Networking 1 07-19-2005 10:29 PM
dns unavailable through nat jobano Linux - Networking 4 07-05-2004 06:44 AM
NAT / Router RH9 kdd281 Linux - Networking 3 11-24-2003 02:02 PM
DNS / Mail / NAT capable modem-router / Linux firewall stealthy1 Linux - Networking 9 04-01-2003 08:35 PM
Router/NAT/Firewal Bluee Linux - Networking 4 02-28-2002 11:01 AM


All times are GMT -5. The time now is 09:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration