LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-03-2005, 01:46 PM   #1
dolvmin
Member
 
Registered: Jul 2003
Location: Florida
Distribution: Red Hat 7.2/8/9, Fedora Core 1/2/3, Smoothwall, Mandrake 7.0/10, Vecter 4, Arch 0.6, EnGuarde
Posts: 289

Rep: Reputation: 30
Router/Gateway - Small Fix/Need Help...


I'm using Mandrake 10.1. I just finished compiling, scripting and installing a new wireless NIC. Using either the Mandrake GUI, or a script I created which auto-loads from rc.local, I can get the card working. Using the Mandrake GUI, I can get Internet Connection Sharing (ipmasq...) working too! But every time I reboot this god forsaken computer, ICS turns off and settings are reset! I believe the problem is due to my new wireless NIC I installed. Thus, I believe I have to create a script to set and activate ICS from rc.local. Does anyone have any templates or suggestions?

Let me update this a bit... My problem is not just mandrake ics. Though my wlan0 (ra0) will work, it will not run with dhcpd unless I re-initialize it by going through the ICS Mandrake GUI after each bootup. This means, without doing this, no wireless connections can be made.

Goals:
To allow laptop to connect to Internet through Mandrake 10.1 box (target of concern).

Summery:
Laptop can see wireless Nic in Mandrake 10.1 box. Laptop can connect to it (but not through ethernet level, thus consider this only as physicall connection). Laptop is not assigned IP address, and thus ethernet connectivity is not active.

Last edited by dolvmin; 11-03-2005 at 02:02 PM.
 
Old 11-03-2005, 05:06 PM   #2
dolvmin
Member
 
Registered: Jul 2003
Location: Florida
Distribution: Red Hat 7.2/8/9, Fedora Core 1/2/3, Smoothwall, Mandrake 7.0/10, Vecter 4, Arch 0.6, EnGuarde
Posts: 289

Original Poster
Rep: Reputation: 30
Problem fixed.

I am now able to access my server through wireless connection after bootup.

It seems the dhcpd server was not activating for ra0 connection because ra0 was compiled, not rpm'ed into mandrake's kernel. Created the string and placed the string within my rc.local.

Now I have a new problem, but that's for a different topic so this one ends happily.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Small Linux Router/firewall behind D-Link Hardware router dleidlein Linux - Networking 6 04-30-2007 05:12 AM
Router Gateway inescapeableus Linux - Networking 11 09-21-2005 10:39 AM
router-gateway-AP? bigearsbilly Linux - Wireless Networking 1 01-28-2005 07:47 AM
TTL exceeds on Gateway how can I fix that? queezythegreat Linux - Networking 4 04-24-2004 02:30 PM
Nic card changes Gateway address for ppp0 How can I fix this? Tiyogi Red Hat 2 03-30-2004 09:45 PM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration