LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-23-2005, 03:39 AM   #1
Vijayasarathy
LQ Newbie
 
Registered: Mar 2005
Distribution: Redhat Lnux 9.0
Posts: 12

Rep: Reputation: 0
"route add default gw" - trouble


Hello all,

I am currently setting up an Internet gateway with the help of a linux machine. I am using the route command to set up the default gateway, giving the addres of the router which connects me to the external world.

The problem now is that, everytime I reboot the linux machine, I have to add the default route, even though the corresponding ethernet interfaces are getting activated automatically.

I use the command "route add default gw 'ipaddress of the router' " command, but I have to do this everytime I reboot.

What could be the possible problem ?are there any files that I need to change ?when I went to the man page of route, it indicated me that changes would be made to the file /proc/net/route, but then automatic gateway setting is not being done here.

Help me out please. Thanks in Advance.

Regards
 
Old 03-23-2005, 06:09 AM   #2
huibert.alblas
Member
 
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
You did not mention the distribution you are running.
On gentoo, for instance, you add extra information like this in /etc/conf.d/net
There should be a similar file in your distro

Another posibiliity would be to add the line to script in /etc/init.d which brings up the network at boot.
Normaly this would be /etc/init.d/network or /etc/init.d/net.eth0 or something like that.
 
Old 03-23-2005, 07:54 AM   #3
Vijayasarathy
LQ Newbie
 
Registered: Mar 2005
Distribution: Redhat Lnux 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Hey,

Really sorry for that .....I miss this every time I post a query ...I am using RHL9

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
default route takes a "name" asouldja Linux - Networking 2 05-18-2005 03:48 PM
add "Artist" and "Album Title" to mp3 files powah Linux - Software 2 04-05-2005 03:04 AM
Route to subnet exists but I get "Network unreachable" when adding default route fciuffani Linux - Networking 4 08-18-2004 02:11 PM
"route add" gets reset at reboot trees Linux - Networking 5 01-21-2004 04:18 PM
Permanently set "route add" -host and default gw sacants Linux - Newbie 1 07-18-2003 04:04 AM


All times are GMT -5. The time now is 11:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration