LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-10-2004, 12:51 AM   #1
bahadur
Member
 
Registered: Apr 2004
Distribution: Linux Red Hat
Posts: 141

Rep: Reputation: 15
root cannot login through gdm


HI,

ok was succesfully able to use use windows 2000 AD domain user names on my linux red hat 9.0 box. local users can also login through GUI but root cannot.

to enable users to login through te GUI prompt of red hat i changed the file gdm in the pam.d directory.

presently my gdm file is some thing lilke this

[junaid@NIIT158 pam.d]$ more gdm
#%PAM-1.0
auth required /lib/security/pam_securetty.so
auth required /lib/security/pam_nologin.so
auth sufficient /lib/security/pam_winbind.so
auth required /lib/security/pam_pwdb.so use_first_pass shadow nullok

account required /lib/security/pam_winbind.so

password required pam_stack.so service=system-auth

session required pam_mkhomedir.so skel=/etc/skel umask=0022
session required pam_stack.so service=system-auth
session optional pam_console.so

can any one plz tell me what change do i make so that root can also login through gdm.
 
Old 06-10-2004, 02:40 AM   #2
indeterminate
Member
 
Registered: Oct 2003
Location: Virginia, US
Distribution: Debian, Ubuntu, Knoppix.
Posts: 76

Rep: Reputation: 17
um you've probably already done this but in the file /etc/X11/gdm/gdm.conf it should be AllowRemoteRoot=true
you can also change this with gdmconfig, i think.
 
Old 06-12-2004, 10:09 AM   #3
bahadur
Member
 
Registered: Apr 2004
Distribution: Linux Red Hat
Posts: 141

Original Poster
Rep: Reputation: 15
the problem is some thing else.

cause when i checked that /etc/X11/gdm.conf

in the security sections the AllowRoot= parameter was true

i also added gdm in the securetty file but still things dont work.
 
Old 06-12-2004, 03:56 PM   #4
askjha
Newbie
 
Registered: Jun 2004
Location: INDIA
Distribution: RedHat 9.2,Mandrake 10.2
Posts: 21

Rep: Reputation: 15
Hi Look problem is
#%PAM-1.0
auth required /lib/security/pam_securetty.so
auth required /lib/security/pam_nologin.so <--Here
auth sufficient /lib/security/pam_winbind.so
auth required /lib/security/pam_pwdb.so use_first_pass shadow nullok

comment that line by putting {B]#[/B] at the beging of the line.i think it should work because pam man page says that pam_nologin.so file wont let u log in .
u may also try these entries in you pam.d/gdm if above does not work

auth required pam_env.so
auth required pam_stack.so service=system-auth
auth required pam_nologin.so
account required pam_stack.so service=system-auth
password required pam_stack.so service=system-auth
session required pam_stack.so service=system-auth
session optional pam_console.so

to do this make a back of your /pam.d/gdm before trying this
hope it works for you for you
askjha
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gdm, cannot login as root. Why Biased turkey Linux - Security 10 09-29-2009 04:03 PM
How to run a Script as root, after Login as User, in GDM MHOOO Red Hat 14 03-08-2005 08:41 AM
gdm login help moschi Linux - Newbie 2 07-03-2004 12:30 PM
root cannot login through gdm bahadur Linux - Security 1 06-10-2004 01:31 AM
X login using GDM koyi Slackware 2 07-24-2003 11:00 PM


All times are GMT -5. The time now is 01:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration