LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 10-02-2003, 04:01 PM   #1
gjalexei
LQ Newbie
 
Registered: Oct 2003
Location: Los Angeles
Posts: 1

Rep: Reputation: 0
RH9 on MSI 875P Neo m/b can't find on-board ethernet


This web site is amazing! -- But I didn't see an answer to this question:
I have a new system w/ an MSI 875P Neo motherboard. It has an on-board ethernet capability that is billed as Intel e1000 - equivalent. When I configure eth0 for an Intel e1000 and try to activate the connection, RH9 returns an error message, that the card is not found.
I am obviously doing something wrong.

My system dual-boots with RH9 or Win2000. When the system boots the bios displays an active Ethernet interface at IRQ10.
Under Win2000, installing the Windows network driver that came with the motherboard resulted in a working "Intel(R) PRO/1000 CT" network connection (Local Area Connection Properties dialog under the Control Panel | Networking applet).

(Ifconfig reports only the loopback, and doesn't see the ethernet chips).

How can I get this machine on the network under RH9? I know that I could get a NIC card that RH9 will see, and disable the on-board ethernet, but darn it, I want RH9 to use the on-board capability, saving me some $$$.

Last edited by gjalexei; 10-02-2003 at 04:44 PM.
 
Old 12-04-2003, 05:10 PM   #2
Newman
LQ Newbie
 
Registered: Nov 2003
Location: USA
Posts: 5

Rep: Reputation: 0
I'm very new at linux myself. But maybe these will help.

http://www.linuxhardware.org/article...56&mode=thread

http://downloadfinder.intel.com/scri...ProductID=1070
 
Old 12-11-2003, 12:39 PM   #3
Newman
LQ Newbie
 
Registered: Nov 2003
Location: USA
Posts: 5

Rep: Reputation: 0
The website at linuxhardware says kernel 2.4.21 will work well with your motherboard. Just yesterday I finally got kernel 2.4.22 installed and working, thanks to a lot of help from a friend at work. Kernel 2.4.22 works fine and automatically recognized the ethernet onboard the motherboard. Sadly the kernel 2.4.22 disabled the NVIDIA driver for my MSI FX5600 graphics card so I've had to go back to using the generic graphics driver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MSI RS480m2/RX480m2 mother board - no sound card detected lv2golf Linux - General 8 03-20-2006 12:47 PM
suse 9.1 pro and msi k8n neo plat etho problem ronss Linux - Networking 2 02-16-2005 12:59 PM
Cannot install RH9 on MSI mother board tmitz Linux - Hardware 0 02-03-2005 04:40 AM
Redhat 9.0 Install w/ MSI NEO2-PFISR 865PE Board on SATA DanishC Linux - Newbie 0 11-15-2004 02:26 PM
MSI 875P NEO-FIS2R i875P boot problem TheGr81 Linux - Hardware 2 01-11-2004 01:51 AM


All times are GMT -5. The time now is 05:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration