LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-28-2012, 06:59 AM   #1
sharan
LQ Newbie
 
Registered: Dec 2012
Posts: 2

Rep: Reputation: Disabled
Restarting squid takes more than 1 minute


I have squid server running on my linux. Whenever I restart squid service it takes more than 1 minute stop the service and same for starting service. But all other services like httpd dhcpd are working fine. I m not able to find the cause.Please help.
 
Old 12-28-2012, 08:46 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,991
Blog Entries: 54

Rep: Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744
Often errors will be logged so I suggest you train yourself to always check your logs for clues first. If no errors are logged check your squid.conf for the debug_options directive. Setting it to "debug_options ALL,1" could make Squid emit more nfo (temporarily because you probably don't want more disk I/O than strictly necessary). If that isn't enough you could tune individual debug sections by section code like debug routines, disk I/O, like that.
 
Old 12-28-2012, 03:02 PM   #3
LVsFINEST
Member
 
Registered: Aug 2006
Posts: 94

Rep: Reputation: 21
I have a very minimalistic implementation of Squid and it takes 10x longer than most other services running on the same box. That's just how Squid is IMO. As long as it starts and runs fine, why is it an issue? I've never worried about it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Lilo bios data check takes more then a minute porphyry5 Slackware 5 06-19-2011 09:37 AM
[SOLVED] Any interaction with CUPS server takes over minute Doug Hutcheson Linux - Software 3 05-08-2010 03:35 AM
[SOLVED] xmbc sshfs takes about 1 minute to navigate directories schneidz Linux - Server 3 07-02-2009 01:01 AM
xmms takes about one minute before playing a file bliblu Linux - Software 3 05-13-2006 11:25 AM
Modem takes more than a minute to dial out with kppp jimdaworm Slackware 2 02-25-2004 06:21 PM


All times are GMT -5. The time now is 12:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration