LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   resolve cname of a cname with a bind dns server (http://www.linuxquestions.org/questions/linux-networking-3/resolve-cname-of-a-cname-with-a-bind-dns-server-878938/)

mariogarcia 05-05-2011 04:03 AM

resolve cname of a cname with a bind dns server
 
hello
there's this issue I do not understand.

there's this domain, that is apparently a cname of a cname which is, i know, not recommended, but it's not forbidden by the rfc.

the domain is www.groenegordel.be. if i try with windows or bind dns i get this results in nslookup


** server can't find www.groenegordel.be: NXDOMAIN

but if i try with opendns I have some results.
> www.groenegordel.be
Server: 208.67.222.222
Address: 208.67.222.222#53

Non-authoritative answer:
www.groenegordel.be canonical name = www.vlaamsbrabant.be.
www.vlaamsbrabant.be canonical name = waf.vlaamsbrabant.be.
Name: waf.vlaamsbrabant.be
Address: 193.53.37.42

with this I see it's a www.groenegordel.be it's a cname or a cname.
is there a way to force bind to resolve this domain? is this a limitation of bind?

thank you in advance.

Mario

bathory 05-05-2011 04:51 AM

It works here:
Quote:

; <<>> DiG 9.7.3 <<>> www.groenegordel.be
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59954
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;www.groenegordel.be. IN A

;; ANSWER SECTION:
www.groenegordel.be. 86400 IN CNAME www.vlaamsbrabant.be.
www.vlaamsbrabant.be. 86400 IN CNAME waf.vlaamsbrabant.be.
waf.vlaamsbrabant.be. 86400 IN A 193.53.37.42

;; AUTHORITY SECTION:
vlaamsbrabant.be. 86400 IN NS ns.belnet.be.
vlaamsbrabant.be. 86400 IN NS proxy1.vlaamsbrabant.be.

;; ADDITIONAL SECTION:
ns.belnet.be. 604799 IN A 193.190.198.14
ns.belnet.be. 604799 IN A 193.190.182.40

;; Query time: 477 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu May 5 11:49:17 2011
;; MSG SIZE rcvd: 180
Maybe you use wrong forwarders or something

mariogarcia 05-09-2011 07:16 AM

Quote:

Originally Posted by bathory (Post 4347121)
It works here:
Maybe you use wrong forwarders or something

are you using also bind?

thank you

bathory 05-09-2011 08:32 AM

Yes, I'm running bind.


All times are GMT -5. The time now is 11:11 AM.