LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 09-23-2007, 04:31 PM   #1
GSMD
Member
 
Registered: Dec 2005
Distribution: Gentoo
Posts: 87

Rep: Reputation: 16
Resetting eth naming?


I'm running ubuntu gutsy under vmware and here is the situation I'm facing under moving the virtual machine to a different host I was unable to use eth0 on the virtual machine. It's somehow moved to eth1 now!
For now I have 2 interfaces attached to the virtual machine and here's what dmesg tells:
Code:
...
[   13.744365] eth0: registered as PCnet/PCI II 79C970A
[   13.744909] eth1: registered as PCnet/PCI II 79C970A
[   14.407523] eth2: link up
[   15.065252] eth1: link up
...
which is somewhat weird. Interfaces are basically shifted by one.

Any ideas how to resurrect eth0?

TIA.
 
Old 09-24-2007, 10:39 AM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
What does your /etc/network/interfaces say?
 
Old 09-24-2007, 12:31 PM   #3
GSMD
Member
 
Registered: Dec 2005
Distribution: Gentoo
Posts: 87

Original Poster
Rep: Reputation: 16
Thanks for your reply.

Both interfaces are assigned ips by dhcp:

Code:
auto eth1
iface eth1 inet dhcp
auto eth2
iface eth2 inet dhcp
Replacing eth2 with eth0 would lead to an interface that won't get up.

Now, I've moved the VM under another host OS and guess what! eth1 and eth2 are not available anymore. I get eth3 and eth4 instead.

Still no clue (don't consider running "grep "eth1" /**" and looking through the numerous results an option).
 
Old 12-14-2007, 09:41 AM   #4
GSMD
Member
 
Registered: Dec 2005
Distribution: Gentoo
Posts: 87

Original Poster
Rep: Reputation: 16
Ok, figured this out long ago. In case anyone faces this issue.
Just remove problematic interfaces from /etc/udev/rules.d/70-persistent-net.rules and that's it.
 
Old 12-14-2007, 03:23 PM   #5
SiegeX
Member
 
Registered: Jul 2004
Location: Silicon Valley, CA
Distribution: Slackware
Posts: 171

Rep: Reputation: 38
/etc/udev/rules.d/75-network-devices.rules is where you can map interface names to NIC's by using their MAC address. Here is the format.

KERNEL=="eth?", ATTR{address}=="<MAC ADDY FOR eth0>", NAME="eth0"
KERNEL=="eth?", ATTR{address}=="<MAC ADDY FOR eth1>", NAME="eth1"
 
  


Reply

Tags
eth, rename


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
device naming didi156 Linux - General 3 07-14-2006 06:37 AM
Is there a way to have grub translate its own naming to naming scheme under Linux zhjim Linux - Software 6 05-28-2006 08:09 AM
Help Naming my Shop vyperkt400 General 3 05-28-2006 04:31 AM
mail server the naming naming convention problem kashan Linux - Newbie 0 07-16-2004 02:08 PM
Reference naming. liguorir Linux - Software 1 06-08-2004 10:36 AM


All times are GMT -5. The time now is 02:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration