LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-22-2005, 01:35 PM   #1
DeIgor
LQ Newbie
 
Registered: Jun 2005
Location: USA, NM
Distribution: Debian
Posts: 4

Rep: Reputation: 0
Replace eepro100 with e100


Hi to everybody!
After I spend half day to find solution for my problem, I realize that I need an advise from PROs.

Here's a problem.
I have custom distro (Debian) 2.6.
It try to load eepro100 module. But I need to replace it with e100.
I can do it manually
rmmod eepro100
then
modprobe e100

But I have 100 computers (((.

How I can disable to load module eepro100 and load e100 instead?

Any help appreciate it.
 
Old 06-24-2005, 02:40 AM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
in /etc/modules.conf:

alias eth0 e100

and also check /etc/modules - you can do it there too.
 
Old 06-24-2005, 09:08 AM   #3
DeIgor
LQ Newbie
 
Registered: Jun 2005
Location: USA, NM
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks!

OK, it will load module, but how I can stop load eepto100 on boot?
I saw people say that I have to edit blacklist file.
What you think?
 
Old 06-26-2005, 10:00 PM   #4
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
yeah, try it. or, you can edit /etc/rc.local and add an rmmod entry there (/sbin/rmmod eepro100)
 
Old 06-27-2005, 12:37 AM   #5
Noth
Member
 
Registered: Jun 2005
Distribution: Debian
Posts: 356

Rep: Reputation: 30
Just change /etc/modules, that's loaded before hotplug so even if hotplug loads the eepro100 after e100 it won't matter.

And looking at my Debian sid system, /etc/hotplug/blacklist already contains eepro100 and I know I didn't add it myself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with eepro100 etcetera Linux - Networking 8 12-14-2004 03:15 PM
confused e100 on 2.6.8.1 spirosd Linux - Networking 1 08-22-2004 12:21 AM
eepro100 driver c0c0deuz Fedora 2 03-10-2004 07:50 AM
problem in perl replace command with slash (/) in search/replace string ramesh_ps1 Red Hat 4 09-10-2003 01:04 AM
eepro100 HANG! vtam Linux - Networking 7 12-07-2001 04:45 AM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration