LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 06-18-2004, 12:40 AM   #1
smaida
Member
 
Registered: Apr 2004
Location: Richmond, VA - USA
Distribution: Debian
Posts: 62

Rep: Reputation: 15
Redhat - Nic Bonding/Teaming


Hello,

I am currently tasked with teaming two sets of dual nics on a redhat es3 server. I am able to team both ports on the first nic without error, but when I try and create the second team I am unable to bring up the interfaces.

The first set of nics are configured as follows:

# /etc/sysconfig/network-scripts/ifcfg-eth1
# Intel Corp.|82557/8/9 [Ethernet Pro 100]
DEVICE=eth1
USERCTL=no
BOOTPROTO=none
HWADDR=xx:xx:xx:xx:xx:xx
ONBOOT=yes
MASTER=bond0
SLAVE=yes
TYPE=Ethernet

# /etc/sysconfig/network-scripts/ifcfg-eth2
# Intel Corp.|82557/8/9 [Ethernet Pro 100]
DEVICE=eth2
BOOTPROTO=none
HWADDR=xx:xx:xx:xx:xx:xx
USERCTL=no
ONBOOT=yes
SLAVE=yes
MASTER=bond0
TYPE=Ethernet

# /etc/sysconfig/network-scripts/ifcfg-bond0
# Intel Corp.|82557/8/9 [Ethernet Pro 100]
DEVICE=bond0
USERCTL=no
BOOTPROTO=static
BROADCAST=xxx.xx.xx.xxx
IPADDR=xxx.xx.xx.xx
NETMASK=255.255.255.0
NETWORK=xxx.xx.xx.x
ONBOOT=yes
TYPE=Ethernet



I then added the following line to /etc/modules.conf
alias bond0 bonding

The settings work great as long as I only have the one team. When I try and create a second team using eth3,eth4, and bond1 the interface fails to start.

The error received is:

bonding device bond1 does not seem be present.


Any ideas or help would be greatly appreciated.

Thanks,
Shawn

Last edited by smaida; 06-18-2004 at 04:33 AM.
 
Old 02-18-2009, 04:40 AM   #2
watcher69b
Member
 
Registered: Nov 2007
Location: /home/watcher69b
Distribution: RH, Fedora & CentOS
Posts: 539

Rep: Reputation: 39
Quote:
I then added the following line to /etc/modules.conf
alias bond0 bonding
did you add this line for bond1 ?
 
Old 09-07-2009, 04:15 AM   #3
chandramani_yadav
Member
 
Registered: Jan 2007
Location: Vienna
Distribution: Redhat
Posts: 47

Rep: Reputation: 19
add the following lines to /etc/modprobe.conf or /etc/module.conf (depending on your distro)

alias bond0 bonding
options bond0 miimon=80 mode=1

alias bond1 bonding
options bond1 miimon=80 mode=1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC Card Bonding fleshwound Linux - Networking 0 11-26-2005 07:50 PM
OpenBSD and NIC bonding? lil_drummaboy *BSD 2 11-04-2005 01:49 PM
NIC Bonding Problem jon3k Linux - Networking 4 08-31-2004 02:36 PM
Redhat 8.0 bonding Problem FragInHell Linux - Networking 0 05-26-2004 01:26 PM
NIC Teaming w/IBM x345 MontanaD Linux - Networking 0 11-26-2003 01:21 PM


All times are GMT -5. The time now is 08:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration