LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-30-2002, 11:05 AM   #1
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Rep: Reputation: 15
redhat and samba need help


I'm trying to get samba working on Redhat 7.2 and having no luck (three days and nothing). I have set samba up in Mandrake using SWAT but I can't get SWAT working on Redhat 7.2. What would be of great help would be if I could see a working Redhat 7.2 smb.conf file. I've looked at the smb.conf man page and searched the Internet with no luck. I saved a copy of my smb.conf before I started editing so I do have a fresh smb.conf file. I can't even get the workgroup and computer name to show in Network Places.

When I do a "rpm -qa | grep samba" I ger:
[root@localhost kenny]# rpm -qa | grep samba
samba-client-2.2.1a-4
samba-common-2.2.1a-4
samba-2.2.1a-4
samba-swat-2.2.1a-4

Does this mean SWAT is install? And if so how do I access it?

Last edited by loganwva; 03-30-2002 at 12:50 PM.
 
Old 03-30-2002, 03:35 PM   #2
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
point your browser on the linux box to "http://localhost:901"
 
Old 03-31-2002, 12:52 AM   #3
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Original Poster
Rep: Reputation: 15
When I point my browser to http://localhost:901 it takes me to:

http://search.netscape.com/search.ps...arch=localhost
 
Old 03-31-2002, 02:28 AM   #4
ryandelany
Member
 
Registered: Dec 2001
Location: Orange County, CA
Distribution: RedHat 7.2, 7.3, 8.0
Posts: 66

Rep: Reputation: 15
It would appear, based on your rpm -qa output that swat is installed.

In RedHat, all the xinetd services are disabled by default. Go to /etc/xinetd.d and check out the swat file. There should be a line that says:

disabled = yes

Change if to:

disabled = no

restart xinetd after you are done, and try accessing it with that URL again. You might also need to remove the line that starts with:

only_from

and restart xinetd again.

Good luck!

Ryan
 
Old 03-31-2002, 10:32 AM   #5
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Original Poster
Rep: Reputation: 15
Changing the line disabled from yes to no gave me access to swat.

I didn't change the only_from line, could you tell me what the line is for?

One thing, you said to restart xinitd. Can this be done without rebooting?

Thank you ever much. You have got me one step further.

Last edited by loganwva; 03-31-2002 at 11:31 AM.
 
Old 03-31-2002, 11:57 AM   #6
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
If swat comes up now, there's no need to restart xinetd. The "only from" line is there to keep people from accessing swat on your machine remotely.
 
Old 03-31-2002, 12:00 PM   #7
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Original Poster
Rep: Reputation: 15
I can now see the workgroup and linux box (named redhat) in Network Places but I'm getting a error message:

\\Redhat is not accessible.

The network path was not found.
 
Old 03-31-2002, 12:18 PM   #8
ryandelany
Member
 
Registered: Dec 2001
Location: Orange County, CA
Distribution: RedHat 7.2, 7.3, 8.0
Posts: 66

Rep: Reputation: 15
The only_from line is used to limit connections to that particular service. Basically you are telling swat to only accept connections from those IP addresses listed on that line.

As far as not being accessible, I don't have a good answer for that one. It is most likely a configuration issue or you might need to restart samba.

Sorry I can't be of more help!

Ryan
 
Old 03-31-2002, 12:50 PM   #9
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
Quote:
I'm getting a error message:

\\Redhat is not accessible.
That's probably because you don't have any accessible shares setup on the Linux box.

What I usually do is make a /public directory, then go into SWAT and create a new share called public and set:

path = /public
browsable = true
writeable = true
guest ok = true

There's literally thousands of ways you can setup a share in Linux. Check the man page for smb.conf to get an idea.
 
Old 03-31-2002, 02:33 PM   #10
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Original Poster
Rep: Reputation: 15
Sixpac have my shares set-up just like I have on my Mandrake system, so I think there ok. I did remove the only_from line, but it didn't help, should I add it back in?

I'm at a lose to why it doesn't work. I seem to have everything set-up ok, but I'm sure I don't or it would work. I'll try all suggestion.
 
Old 03-31-2002, 02:38 PM   #11
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
Post your smb.conf file please.
 
Old 03-31-2002, 03:16 PM   #12
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Original Poster
Rep: Reputation: 15
Sixpac here's my smb.conf file:

# Samba config file created using SWAT
# from localhost.localdomain (127.0.0.1)
# Date: 2002/03/31 15:16:21

# Global parameters
[global]
workgroup = WORKGROUP
netbios name = REDHAT
server string = Samba Server %v
encrypt passwords = Yes
update encrypted = Yes
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = lpstat
preferred master = False
domain master = False
wins support = Yes
hosts allow = 192.168.0.1
printing = cups
print command = /usr/bin/lp -d%p -oraw %s; rm %s
lpq command = /usr/bin/lpstat -o%p
lprm command = /usr/bin/cancel %p-%j
queuepause command = /usr/bin/disable %p
queueresume command = /usr/bin/enable %p

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
lpq command = lpstat -o %p
lprm command = cancel %p-%j
browseable = No

[system]
path = /pub
admin users = admin user = kenny
write list = write user = kenny
read only = No
create mask = 0775
guest ok = Yes

Last edited by loganwva; 03-31-2002 at 03:29 PM.
 
Old 03-31-2002, 06:20 PM   #13
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
I suspect your problem is the line that reads:

hosts allow = 192.168.0.1

You should try taking that out and restarting samba. If you are worried about security, change it to a class C or B designation rather than a specific subnet:

hosts allow = 192.168

or you could specify all the hosts you are accessing it from:

hosts allow = 192.168.0.1,192.168.0.2,192.168.0.3
 
Old 03-31-2002, 10:21 PM   #14
loganwva
Member
 
Registered: Jul 2001
Location: West Virginia
Distribution: SuSE 9.1
Posts: 117

Original Poster
Rep: Reputation: 15
Guys, I've had no luck getting Samba running, with or without swat. I'm going to give it up for now, but I'd like to thank all of you for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba on RedHat 9 lumux Linux - Networking 1 01-06-2004 07:43 AM
Samba with RedHat 9 Panzerfrost Linux - Newbie 1 09-21-2003 09:09 AM
installing samba-3.0alpha24-1.i386.rpm into RedHat 8 and RedHat 9 Linh Linux - Newbie 2 06-04-2003 06:50 AM
Samba on Redhat 8 juanb Linux - General 1 03-27-2003 12:00 AM
SAMBA on REDHAT 7 Frinux Linux - Networking 7 11-07-2002 01:35 AM


All times are GMT -5. The time now is 11:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration