LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Redhat 9.0/Windows and DDNS - no update in Bind9 (http://www.linuxquestions.org/questions/linux-networking-3/redhat-9-0-windows-and-ddns-no-update-in-bind9-85371/)

mule 08-25-2003 01:38 AM

Redhat 9.0/Windows and DDNS - no update in Bind9
 
i've a very small network with 2 pc's and 2 notebooks to serve with DDNS-function.

if i have a notebook with suse 8.2 and redhat 9.0...why the hell is the suse getting updated in de database of bind 9 and the the redhat 9.0 not???

it seems as they have a complete different dhclient.conf (didn't yet verify).
--> suse works without any problem at all!!!

Does anybody know enough how to handle this? Eventually the dhclient-script in /sbin/ from the redhat-machine? what do we have to tell the redhat 9.0 machine to update bind?

i have even a windows-client in this network with an even more strange behaviour.....he lets updating bind the reverse zone (0.0.10.in-addr.arpa) but not the forward-zone.

i think, even here it's a client issue to resolve. does anybody have here an idea??

mule 08-27-2003 02:04 AM

ok, it's done. it was because of:

- the win-clients have been putted into the windows-domain at installation
- this generates automatically the hostname in the form "hostname.domain.tld"

-> Solution: leave your client in the windows-domain, change hostname: just delete out the domainname and uncheck the automatic apply of the dns-suffix. that all

jimrib 03-01-2006 09:36 AM

How about the RedHat Client?
 
I am having the same issue, I have a SUSE 9 ddns setup, and have a RedHat machine that will not register with ddns. All other cients in the network register (windows, other redhat clients, etc.), but not this one redhat machine.

the redhat box does get it's IP and all other network setting properly from the suse server (including dns server info), but it will not show up in bind.

did you get yours fixed or did I interpret your post incorrectly?

thanks JimRib

mule 03-01-2006 02:54 PM

i remember some versions of rh forgot a file called /etc/dhclient.conf and /etc/dhclient-eth0.conf

if you use ifdown / ifup, they should get used.

the content of those should be:

::::::::::::::
dhclient.conf
::::::::::::::
send host-name "neo";


::::::::::::::
dhclient-eth0.conf
::::::::::::::
send host-name "neo";

...whilst neo is your hostname. The hostname should be written with "".

HTH
Roger

jimrib 04-03-2006 09:52 AM

Solution Found for DDNS
 
I discovered that Red Hat 9.0 will not automatically register with DDNS (at least with the default packages from the CDs).

Solution was to run the "nsupdate update add" command, and build a script to run this at boot.


JimRib


All times are GMT -5. The time now is 03:44 AM.