LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-30-2004, 03:19 AM   #1
alvalee
LQ Newbie
 
Registered: Feb 2004
Posts: 3

Rep: Reputation: 0
redhat 8.0 cannot startup NIC automatically


hi all,

i have a pentium machine for some testing use. i tried to install Redhat 8.0 but the NIC failed to startup automatically.
NIC tried: 3Com 3c509, 3Com 3c900B, generic NIC with RTL8029AS.

some remedial works done:
1. stop the kudzu in rc3, 4 and 5.
2. updated with kudzu 0.99.99 from RH9.0 updates.
3. kernel (rpm) upgrade (though i don't think it would help solve the problem)

instead, i have to manually do the ifdown/ifup everytime to bring up the eth0.

some notes: i have stopped the 3Com 3c509 PnP with 3com DOS program. also do the modprobe, edit modules.conf, edit ifcfg-eth0.

do you guys have any suggestion?
 
Old 03-30-2004, 07:15 AM   #2
Tiyogi
Member
 
Registered: Nov 2003
Location: Hyde Park, Ny
Distribution: Ubunta
Posts: 117

Rep: Reputation: 15
Hi alvalee,

I am also new to linux.

Have you enable the nic to start up at boot.

This done thru the "Network device control".
To find it do the following,[list=1][*]Click on the redhat[*]Click on System tools[*]click on network device control[*]Is the nic card active or deactive?[*]Pick the "eth0"[*]click on the button "configure"[*]A new panel opens "Network Configuration"[*]Make sure "eth0" is highlighted and click on "EDIT"[*]New panel opens "Ethernet Device"[*]Is the box label "Active when computer starts up" check off?[*]If not, the check so it has a check mark[*]Hit ok, then it should have started.[*]Then close all panels[*]Restart you computer.[*]Once restarted using the first steps check to see if nic is active.[/list=1]
This advice is only for the nic card do not active your modem for startup I repeat do not active your modem for startup. I did an the system would not boot.

As I said at the beginning I am new to Linux and only have a limited knowledge of its. So give it a try it maybe the answer to you problem.
 
Old 03-30-2004, 08:24 AM   #3
skel
Member
 
Registered: Jan 2004
Distribution: Slackware 10 ; Gentoo ; OpenBSD 3.6
Posts: 101

Rep: Reputation: 15
look at
/etc/sysconfig/network-scripts/ifcfg-eth0

add/modify the line:
ONBOOT=yes
 
Old 03-30-2004, 08:35 PM   #4
alvalee
LQ Newbie
 
Registered: Feb 2004
Posts: 3

Original Poster
Rep: Reputation: 0
hi tiyogi,

i mostly use the command line interface. that doesn't mean that i hate GNOME or KDE. it's a matter of the harddrive size and i don't use linux as my desktop. mostly i am using it as an alternative to traditional unix platforms. most of the small pentium machines has only 32MB or 64MB of RAM, and a tight 1GB or less harddisk space. however they are quite good for small development projects like dialup access, log capture and so forth.

i just went back to my favorite RH7.3 (but need to patch kernel!) and the 3com 3C509 works ok by disabling the PnP and manually configure the NIC.

i would probably try the X windows someday.


Quote:
Originally posted by Tiyogi
Hi alvalee,

I am also new to linux.

Have you enable the nic to start up at boot.

This done thru the "Network device control".
To find it do the following,[list=1][*]Click on the redhat[*]Click on System tools[*]click on network device control[*]Is the nic card active or deactive?[*]Pick the "eth0"[*]click on the button "configure"[*]A new panel opens "Network Configuration"[*]Make sure "eth0" is highlighted and click on "EDIT"[*]New panel opens "Ethernet Device"[*]Is the box label "Active when computer starts up" check off?[*]If not, the check so it has a check mark[*]Hit ok, then it should have started.[*]Then close all panels[*]Restart you computer.[*]Once restarted using the first steps check to see if nic is active.[/list=1]
This advice is only for the nic card do not active your modem for startup I repeat do not active your modem for startup. I did an the system would not boot.

As I said at the beginning I am new to Linux and only have a limited knowledge of its. So give it a try it maybe the answer to you problem.
 
Old 03-30-2004, 09:07 PM   #5
alvalee
LQ Newbie
 
Registered: Feb 2004
Posts: 3

Original Poster
Rep: Reputation: 0
i would try and see if it works.

i have read some comments here about the kudzu bugs on some NIC. seems like the older version (PCI or ISA) of 3Com NICs are troublemakers.

have you guys got the same problem with 3Com NICs?

Quote:
Originally posted by skel
look at
/etc/sysconfig/network-scripts/ifcfg-eth0

add/modify the line:
ONBOOT=yes
 
Old 03-30-2004, 11:36 PM   #6
eccles23
Member
 
Registered: Jun 2003
Location: Australia
Distribution: Gentoo/kernel 2.6.2
Posts: 45

Rep: Reputation: 15
Quote:
add/modify the line 'ONBOOT=yes' in /etc/sysconfig/network-scripts/ifcfg-eth0
VS

Quote:
1. Click on the redhat
2. Click on System tools
3. click on network device control
4. Is the nic card active or deactive?
5. Pick the "eth0"
6. click on the button "configure"
7. A new panel opens "Network Configuration"
8. Make sure "eth0" is highlighted and click on "EDIT"
9. New panel opens "Ethernet Device"
10. Is the box label "Active when computer starts up" check off?
11. If not, the check so it has a check mark
12. Hit ok, then it should have started.
13. Then close all panels
14. Restart you computer.
15. Once restarted using the first steps check to see if nic is active.
does anyone still wonder why some of us prefer to configure our systems from the console?


(with no offence meant to Tiyogi, you obviously went to quite a bit of effort to help)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to automatically connect on startup? PerfectReign Linux - Wireless Networking 6 09-16-2005 01:44 AM
Any way to startup daemon automatically? Niceman2005 Linux - Newbie 2 01-12-2005 09:27 PM
Automatically run scripts on startup? Phaethar Fedora 10 09-24-2004 02:35 AM
automatically startup a program after booting? caicai Linux - Software 7 08-12-2004 07:16 AM
startup the service automatically ashley75 Linux - General 4 09-24-2003 02:14 AM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration