LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Realtek 8139/8168/8169 on 2.6.21.3 or newer (http://www.linuxquestions.org/questions/linux-networking-3/realtek-8139-8168-8169-on-2-6-21-3-or-newer-593495/)

Gato Azul 10-21-2007 12:56 PM

Realtek 8139/8168/8169 on 2.6.21.3 or newer
 
I just wanted to post this information to save others from some of the frustration that this bug has brought me.

Who this applies to
If you're dual booting Windows and using a newer Linux distro, specifically one with kernel 2.6.21.3 or newer and are having problems getting your Realtek 8139/8168/8169 card to function, then this thread's for you.

The problem
Unable to connect using a Realtek 8139/8168/8169 (possibly others). In my case, ifconfig and ethtool showed that the card was present, enabled, and that a link was detected, but I had no link lights and obviously no connectivity.

The issue
Something got broken in kernel 2.6.21.3. The problem, according to the Gentoo Wiki and the Ubuntu Forums, is that:
Quote:

As of 27 May 2007, in kernel 2.6.21.3, you may experience the issues with the r8169 driver if you dual boot Windows on some systems. Windows by defaults disables the NIC at Windows shutdown time in order to disable Wake-On-Lan, and this NIC will remain disabled until the next time Windows turns it on. The r8169 driver in the kernel does not know how to turn the NIC on from this disabled state; therefore, the device will not respond, even if the driver loads and reports that the device is up. To work around this problem, simply enable the feature "Wake-on-lan after shutdown." You can set this options through Windows' device manager.
The solution
- Boot up Windows
- Right click on My Computer
- Click on Properties -> Hardware -> Device Manager
- Expand your network card section and double click on your Realtek network card
- Set "Wake-on-lan after shutdown" to enabled

For my part, I've confirmed that this works for Ubuntu 7.10, but it should fix the issue for any distro with a newer kernel such as openSUSE 10.3.

Edit: according to the Gentoo wiki (if I ever learned how to read!), this may be an issue with older kernels as well -- all the way back down to 2.6.19.5. Yuck.

atheist 10-21-2007 10:04 PM

Thanks. Thanks. Thanks. :D:D:D

I had no idea what the fuck was wrong with my network card. :D

Gato Azul 10-21-2007 11:20 PM

You're most welcome, I'm glad it helped! :cool:

packetgod 12-02-2007 12:28 AM

Hey, thanks much I just encountered the same issue after booting up a friends windows drive to help troubleshoot it. I thought it infected the boot sector or some other nefarious thing.

Who would have thought it.

Thanks again.

tonygibbs16 02-24-2008 10:24 AM

Realtek 8139/8168/8169 on 2.6.21.3 or newer
 
Thanks for this information. It worked for me with a Windows-XP system and with Linux 2.6.23.14 on Fedora 8.

Thanks,
Tony

zhenghuihu 04-11-2008 02:18 AM

Thank you very much. I thought it was the kernel and was about to re-compile it.
You are genius.

azelliot246 05-05-2009 09:56 PM

I'm not dual boot!
 
I am having the EXACT same issue but my HDD is in no way infected with MS software, lol. In 11.0 i used a driver mod install that I had to compile, but that isn't working for some reason, and being that I am not a programmer, I cannot troubleshoot the output. r8169 to be exact. I remember for my laptop wireless I had to use an XP driver, but had no need being that I "upgraded" and openSUSE 11.1 didn't boot when I had the root and swap partitions on a separate HDD as my home partition, so I did a fresh install, and NOW the realtek won't work. Anyone know of a linux only fix? Thanks.


All times are GMT -5. The time now is 09:56 AM.