LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-03-2004, 09:37 AM   #1
Ninaw
Member
 
Registered: Jun 2004
Location: QC, Philippines
Distribution: Ubuntu
Posts: 30

Rep: Reputation: 15
Really strange browsing problem


Lately I've been having a really strange browsing problem.
Here's my setup.

Dualboot:
Slackware 9.0
Windoze XP

Internet Connection: DSL-PPPoE
-Configured the router to use its DHCP server.
-Used Slack's netconfig util to configure the DHCP client.

Router (D-Link DPT DI-704P)
--A. 5-port Switch
--------1. My own computer (Let's call it PC1)
--------2. Another computer
--------3. Another computer
--B. Single computer

(A and B directly connected to the router; 1,2,3 connected to A)

Under linux in PC1, I can't visit some sites, particularly .org domains and some subdomains, e.g. ctan.org, fluxbox.sourceforge.net. I tried pinging the said sites only to get "host not found" errors. Yet I can visit some subdomains like groups.yahoo.com. When I used the router's own ping tool it reported that it was able to ping the sites that I was not able to ping under linux.

However, under windoze in PC1, I can visit the said sites without any problems.

So now I am quite confused whether it is a problem with the hub, or with how linux interacts with the router, or it's something really mysterious that I am not supposed to discover.
 
Old 07-03-2004, 10:07 AM   #2
Ninaw
Member
 
Registered: Jun 2004
Location: QC, Philippines
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
I noticed also after I have visited a site using its IP address, I can use its url for subsequent visits.

Also, the host name of PC1, 'anino,' isn't showing up in the router's browser-based control interface; only the IP address is present in the DHCP clients list.

Last edited by Ninaw; 07-03-2004 at 10:30 AM.
 
Old 07-03-2004, 01:01 PM   #3
Ninaw
Member
 
Registered: Jun 2004
Location: QC, Philippines
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
I've discovered the problem. DHCP places the nameservers of my isp in my resolv.conf file although the correct value should be the ip address of my router. The question I have now is how to maintain the dynamically set IP addresses yet have a fixed nameserver.
 
Old 07-03-2004, 03:01 PM   #4
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Have a look in /etc/sysconfig/network/ (or at least that's where it is in SuSE) for ifcfg-ethX where X is whatever your NIC is (usually 0 if you only have one NIC).

In there you may have the following or there may be nothing like this as it could be using defaults. You can put these in there and they will override any defaults. Just change the 'yes' to 'no' for MODIFY_RESOLV_CONF and it won't modify your resolv.conf

BOOTPROTO='dhcp'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'
 
Old 07-03-2004, 09:17 PM   #5
Ninaw
Member
 
Registered: Jun 2004
Location: QC, Philippines
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by andrewdodsworth
Have a look in /etc/sysconfig/network/ (or at least that's where it is in SuSE) for ifcfg-ethX where X is whatever your NIC is (usually 0 if you only have one NIC).

In there you may have the following or there may be nothing like this as it could be using defaults. You can put these in there and they will override any defaults. Just change the 'yes' to 'no' for MODIFY_RESOLV_CONF and it won't modify your resolv.conf

BOOTPROTO='dhcp'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'
thanks, this is probably better than what I did
I modified rc.inet1 and added a -R option to the dhcp line so that it doesn't override resolv.conf (talk about inelegant)
 
Old 07-04-2004, 08:30 AM   #6
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Quote:
Originally posted by Ninaw
thanks, this is probably better than what I did
I modified rc.inet1 and added a -R option to the dhcp line so that it doesn't override resolv.conf (talk about inelegant)
Well so long as you're sorted - I needed to sort out a fight between onboard ethernet and unsupported PCMCIA wireless card both using DHCP and didn't really want to muck about with system scripts as the wireless card isn't usually in the machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Browsing Internet Problem drake_101 Slackware 5 02-28-2005 10:04 PM
strange, strange alsa problem: sound is grainy/pixellated? fenderman11111 Linux - Software 1 11-01-2004 06:16 PM
browsing problem with XP/samba kreilk Linux - Networking 0 07-10-2004 06:29 PM
browsing problem linux 7.2 jolly Linux - Networking 5 01-02-2003 10:40 PM
Problem in LAN Browsing puru_09 Linux - Networking 2 11-14-2002 01:57 PM


All times are GMT -5. The time now is 09:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration