LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-15-2003, 01:49 PM   #1
fatboysmith
LQ Newbie
 
Registered: May 2003
Location: Silver Creek, GA
Distribution: Ubuntu
Posts: 10

Rep: Reputation: 0
Ran netconfig and nuked my dial-up


I installed Slack9 and setup a dial-up using pppsetup and kppp only, (no /etc/ppp file editing). Dial-up was working ok. I was preparing to setup my eth0 to smb into a win2k box, so I ran netconfig. I was using autodns to access my ISP's nameserver. Now I can't open any webpages etc due to my nameserver/routing being broken. How do I fix this? I've tried re-running netconfig and using "loopback" to no avail. I even retrieved the DNS addresses from my ISP and tried entering them manually in KPPP and pppsetup, but that doesn't work either. Please explain what I did, how I fix it and if possible a link to a good how-to on setting up an external dial-up and internal network. I've read most of the how-to's on this subject but I find that the HOW-TO's do not keep pace with the newest tools/kernels/methods.

Thanks,

FatBoy
 
Old 05-16-2003, 11:35 AM   #2
fatboysmith
LQ Newbie
 
Registered: May 2003
Location: Silver Creek, GA
Distribution: Ubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
Ok, I've done some more with this problem. I can log on to ISP with no problem. I obviously have a routing problem. I've edited /etc/resolv.conf with the domain and nameserver addresses of my ISP (aaahawk.com). The output of route -n is as follows:

Destination Gateway Genmask Flags Metric Ref Use Iface
170.147.97.14 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
127.0.0.0 0.0.0.0 255.0.0.0.0 U 0 0 0 lo
0.0.0.0 170.147.97.14 0.0.0.0 UG 0 0 0 ppp0

My /etc/ppp/options files contain the following lines
lock
defaultroute
noipdefault
modem
/dev/modem
57600
crtcts

I think my default route is pointing to the wrong interface or is setup up improperly. As I already said logging on and staying connected is no problem. I cannot ping any addresses except my ISP's remote IP address and Gateway. How do I fix this. I've tried setting "route add -net" etc. Can any one help?

Fatboysmith
 
Old 05-16-2003, 03:06 PM   #3
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
Your route looks fine to me. You say you can't ping any addresses except 170.147.97.14? If that's true, you can forget about DNS and /etc/resolv.conf, you've got a deeper problem. Are you running any firewall, such as iptables or ipchains? Do you have a /etc/sysconfig/network-scripts/ifcfg-ppp0, and if so, what does it contain?
 
Old 05-16-2003, 03:23 PM   #4
fatboysmith
LQ Newbie
 
Registered: May 2003
Location: Silver Creek, GA
Distribution: Ubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
I figured it out! I had everything setup ok. My ISP's DNS information listed on their website was outdated. I used dnsquery to verify their dns address from another working linux box.

Thanks

DJ
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nuked HDD - Can I get the files back? Nige Linux - General 2 09-11-2005 10:43 PM
Debian NUKED my Slackware partition UltimaGuy Debian 8 12-05-2004 12:59 PM
Upgrading to 2.6.6 seems to have nuked my machine HawkeyeCoug Mandriva 4 05-18-2004 01:46 PM
I just nuked /etc cpeppler Linux - Software 28 03-18-2004 09:27 AM
Accidentally nuked anything libgd* - where to begin the restoration? mrodrigo Linux - General 2 09-15-2003 12:30 PM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration