LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 10-10-2011, 06:42 AM   #1
Poseidon
LQ Newbie
 
Registered: May 2011
Posts: 7

Rep: Reputation: 6
Ralink RT61 wireless pci ubuntu 10.04 compatibility


Hi,

I am having little luck geting my RaLink RT61 wireless PCI card to work on my Ubuntu 10.04 server LTS (latest kernel) i386 box. I have read the endless "how to's", ralink's and serialmonkey, but seem to be going round in circles. If any of you gurus can put me out of my misery that would be fantastic!

So to recap I just re-built my ubuntu 10.04 LTS server from scratch (the box is going remote so need wireless) and then dist-urgraded. Serialmonkeys site states that the rt2x00 driver is now included in the linux main code branch, sure enough the lib's, o's, bin's and ko's all appear in the kernel directory out of the box. So an obvious question here is do I need any other driver's/firmware on top of the ubuntu ISO image - it's unclear to me.

I then ran the following to check the card:
lspci -n
01:07.0 0280: 1814:0301

lspci (I notice here there is no "rev")
01:07.0 Network controller: RaLink RT2561/RT61 802.11g PCI

ifconfig -a
wlan0 Link encap:Ethernet HWaddr 00:a1:b0:26:10:f2
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

iwconfig
wlan0 IEEE 802.11bg ESSID: off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr: off Fragment thr: off
Power Management: off

iwconfig wlan0 mode ad-hoc
iwconfig wlan0 ESSID netname

iwconfig
wlan0 IEEE 802.11bg ESSID:"netname"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: Not-Associated
Tx-Power=0 dBm
Retry long limit:7 RTS thr: off Fragment thr: off
Encryption key: off
Power Management: off


ifconfig wlan0 up
SIOCSIFFLAGS: Device or resource busy

dmesg | tail
[14092.436013] phy0 -> rt61pci_load_firmware: Error - MCU Control register not ready.
[14092.436560] phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x00002100, value=0x23308d4c

So if this is the only problem I am getting some sort of firmware load failure owing to the MCU not being ready, has anyone got any ideas on this? Perhaps I am just missing some really simply steps earlier on? I found one other hit on google on this "MCU" but no one ever got back to the guy... I hope I will be more lucky on this forum!

Many thanks...
 
Old 10-10-2011, 08:16 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Have a look at this link

-->http://forums.opensuse.org/archives/...x-drivers.html

This user downloaded a firmware file called
Quote:
RT61_Firmware_V1.2.zip
from here -->http://www.ralinktech.com/en/04_supp...se.php?sn=5024

So it appears you need firmware. What I don't know is if the firmware is included in 10.04 or not.
It appears the end result is you wind up with a file called
Quote:
rt61sta.dat
. You could search your system to see if you already have it. You could also look at Synaptics pkg man to see if there is/are any firmware packages for this card not installed.

If not, download the firmware, and see if you can run make to produce it.
 
Old 10-10-2011, 11:12 AM   #3
Poseidon
LQ Newbie
 
Registered: May 2011
Posts: 7

Original Poster
Rep: Reputation: 6
Hi camorri,

Thank you for your reply.

This is mostly a path I have already taken, the ralink bz2 (zip) source pack doesn't compile and needs some tweaking .. I didn't get all the way. Half way through (pulling teeth) I thought it can't be this hard and became confused because most of the files are already there in the kernel branch from serialmonkey which, they say, supersede those from ralink. 6 of one half a dozen of the other...it's all very confusing, I have looked for a "how to" on serialmonkey's site but it seems not to be .. a real oversight. Maybe it's the case that serialmonkey's drivers are not fit for purpose for RT61 and the ralink ones are the ones to persevere with... frankly I'm clutching at straws! I'll try and compile the ralink source pack again... I've already wasted two days on this.. I guess I'll give it another 2 then go and buy a different card!

Cheers...
 
Old 10-11-2011, 04:26 AM   #4
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,899

Rep: Reputation: 623Reputation: 623Reputation: 623Reputation: 623Reputation: 623Reputation: 623
Ubuntu 10.04 should support your card out of the box. I can say this with absolute certainty because it supported the same card in my machine. I would suggest you download the driver package, it is called firmware-ralink in Debian, and install it using Gdebi, reboot the machine and see how it is.
 
Old 10-11-2011, 05:24 AM   #5
Poseidon
LQ Newbie
 
Registered: May 2011
Posts: 7

Original Poster
Rep: Reputation: 6
Hi,

Well I have got a lot further, thank you for your help; the wirless card can now see my AP but I can't actually connect yet which is probably down to my /etc/interfaces file perhaps.

In the end it turned out to be an address collision in the boot up sequence with my Adaptec 2110s scsi raid controller. It is bizare all the forums on this RAID controller tell you that you need to blacklist 'dtp_i2o' so that 'i2o_core' gets a chance to claim the resources first. This was even raised as a sporadic bug years ago. However, upon closer inspection of the /boot/initrd.img-2.6.33-34-generic-pae file

zcat /boot/initrd.img-2.6.33-34-generic-pae | cpio -ivdm

it turns out that it contains /etc/modprobe.d/blacklist.conf whereby it is actually blacklisting 'i2o_core' ... the very driver that you want to use. Once I had repacked initrd* with "blacklist dpt_i2o" (I omit the sudo...)

find . | cpio --quiet -o -H newc | gzip -9 > /boot/initrd.img-2.6.33-34-generic-pae

and rebooted the dmesg buffer ring looked much cleaner and behold rt61pci was now able to load the firmware ... out of the box!

So now when I "iwlist scan" I see my wireless access point. @K3lt01, in what mode are you running yours, ad-hoc or managed, also what revision is your card for interests sake...? Do you have a sample interfaces file you use? I tried the following without success....

auto eth0
iface wlan0 inet dhcp
wireless-essid APname
wireless-mode managed

I want to get the wireless working with WPA but initially I guess I should check sucess without any encryption...?

Many thanks ...
 
Old 10-13-2011, 01:39 PM   #6
hen770
Member
 
Registered: Oct 2010
Distribution: Arch
Posts: 136

Rep: Reputation: 7
if you are using the:
iwconfig wlan0 essid APname

you can check it even if your /etc/network/interfaces file isn't configure correctly, this file is for ifup command.

of course try first without any security.
 
Old 10-17-2011, 05:02 AM   #7
Poseidon
LQ Newbie
 
Registered: May 2011
Posts: 7

Original Poster
Rep: Reputation: 6
Well, I finally got the rt61 fully working with WPA2, AES encryption. I include the steps below for anyone that is interested, thank you for your replies..

1. Update "/etc/network/interfaces" file to include the wireless interface

# The primary network wireless interface
auto wlan0
iface wlan0 inet dhcp

2. Update the permissions on it, depends on your security outlook i guess!

sudo chmod 0600 /etc/network/interfaces

3. Create file "wpa_supplicant.conf" for the WPA wireless security implementation daemon wpa_supplicant which is installed by default on Ubuntu 10.04 LTS server

sudo touch /etc/wpa_supplicant/wpa_supplicant.conf

4. Update the permissions on it.

sudo chmod 0600 /etc/wpa_supplicant/wpa_supplicant.conf

5. Create the encrypted psk key based on the AP ssid key

wpa_passphrase B...blah...6 BD..blah..5C

-> the output will be a string of ascii which needs copying
into the psk=.... in the .conf file below without " ", if
you are going to use plain text and not encrypt the key
then it must be in " ", i.e. psk="DB..blah..5C", psk plain
text key must be between 8 - 63 characters

6. Update the wpa_supplicant.conf for the desired configuration

N.B. scan_ssid=1 needed for AP's that hide themselves ....
bssid ensures restriction to certain AP

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
eapol_version=1
ap_scan=1

network={
ssid="B...blah...6"
scan_ssid=1
bssid=78:..:blah:..:A5
# 802.11b
frequency=2412 # channel 1
#frequency=2437 # channel 6
#frequency=2462 # channel 11
#frequency=2484 # channel 14
# 802.11g/n
#frequency=2412 # channel 1
#frequency=2432 # channel 5
#frequency=2452 # channel 9
#frequency=2472 # channel 13
mode=0
proto=WPA2
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
#psk=psk="BD..blah..5C"
psk=0dcb8..blah..blah..cfec66
priority=0
}

7. Create file pre-up_wpa_supplicant into /etc/network/if-pre-up.d/

#!bin/bash
wap_supplicant -B -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf -Dwext\
-f/var/log/wpa_supplicant.log
exit 0

8. Update the permissions on it.

sudo chmod 0500 /etc/network/if-pre-up.d/pre-up_wpa_supplicant

9. Create file post-down_wpa_supplicant into /etc/network/if-post-down.d/

#!bin/bash
killall -q wpa_supplicant
exit 0

10. Update the permissions on it.

sudo chmod 0500 /etc/network/if-post-down.d/post-down_wpa_supplicant


Steps 7-10 enable the service to start when the server is booted.

That's about it (hope I haven't made any typos), the above worked for me on Ubuntu 10.04 LTS server.

Hope it helps ....!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Digisol DG-WN1150N (ralink 3060 chip) PCI wireless card on Ubuntu linuxlover.chaitanya Linux - Hardware 1 02-26-2011 07:44 AM
Fedora 12, Linksys WMP54G (RaLink RT2561/RT61 802.11g PCI) tpkatsa Linux - Hardware 1 06-16-2010 10:07 AM
EDIMAX Lan PCI Adapter chipset Ralink RT2561/RT61 802.11g xcristi Linux - Wireless Networking 1 02-21-2009 10:30 AM
Unable to work RaLink RT2561/RT61 and Ubuntu 7.1 Felipe Linux - Wireless Networking 5 03-24-2008 03:19 PM
RaLink RT61 Based Wireless Card and FC6; pointing "make" in the right direction. Linux>Me Fedora 2 02-28-2007 07:39 PM


All times are GMT -5. The time now is 01:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration