LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-08-2004, 03:44 PM   #1
david.skinner
Member
 
Registered: Dec 2003
Location: New Zealand
Distribution: Mandriva 2006 64
Posts: 45

Rep: Reputation: 15
R8169 intermittantly hangs on boot


I have two machines both based on the Gigabyte 7N-400-Pro2 motherboard with onboard Realtek 8169 ethernet chips. One runs as a fileserver and the other as my desktop. Both systems run Mandrake 10 (2.6.3 kernel) with custom kernel builds.

Both machines exhibit the following symptoms intermittantly on boot up.

About one in three times on booting the system appears to hang when starting eth0. it will eventually continue past this point after giving a [FAILED] startup notification but there will be no network access (which sort of completely stuffs the use of the file server). If I CTL/ALT/DEL and reboot while during this startup it will likely succeed the second time. Once up, the network is perfectly stable.

I was wondering (rather randomly) if the auto-negotiation was failing with the Gigabyte switch that both are connected to so I tried inserting the r8169 module with the parameters media = 0x10 to force 1Gb connection but my syntax must be wrong cause it just throws it out. Any help appreciated.
D.
 
Old 11-24-2004, 04:30 PM   #2
Ueimor
LQ Newbie
 
Registered: Nov 2004
Location: Paris
Distribution: Fedora Core
Posts: 11

Rep: Reputation: 0
The r8169 driver handling of link settings has been changed a bit since 2.6.3 and ethtool
is supported. I'd strongly suggest upgrading your kernel. If you are stick with a kernel
issued by Mdk, you can try upgrading the r8169 driver alone to:
http://www.fr.zoreil.com/people/fran...9.c-test.patch

Is there a correlation between the issue and a sudden reboot or a reboot after a crash ?

--
Ueimor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen goes blank intermittantly while I'm trying to work DaneM Linux - Hardware 4 08-23-2005 10:29 PM
Dual Boot = No Boot (hangs at bios splash screen) nedwardss Debian 4 12-03-2004 04:09 AM
r8169, amd64, 2.6.x kernel - networking does not work Sulu Linux - Hardware 0 11-30-2004 01:14 PM
r8169 puking oogle Linux - Hardware 4 11-24-2004 05:57 PM
R8169 and fedora Xela Linux - Networking 2 05-01-2004 07:13 PM


All times are GMT -5. The time now is 06:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration