LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-18-2004, 09:39 AM   #1
ysg08
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9.0
Posts: 21

Rep: Reputation: 15
Question qmail sends but doesn't receive mail


OS: Red Hat 9.0
qMail/ Courier-IMAP server / Squirrelmail as client

I am having problems receiving mail on my system. Sending email to yahoo/hotmail works fine, but inbound email never seems to make it to my mailbox. Is there any sort of configuration changes I might need to make or does the problem lie in my ISP not allowing inbound traffic? If its an ISP problem (ISP: SBC DSL @ Home), I would think that ALL email services would be blocked (inbound/outbound) for they would block port 25. correct?

can someone help with my inbound mail problem?
Thanks in advance
 
Old 04-18-2004, 10:03 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Your ISP maybe blocking port 25 but first check:
Firewall rules:
iptables -nL

That services are listening on the right ports/IPs:
netstat -nlp

It would also be worth checking your qmail log to see if there are any attempts at delivery.

Post the output of the above commands and your log if you are unsure.
 
Old 04-19-2004, 01:29 PM   #3
ysg08
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9.0
Posts: 21

Original Poster
Rep: Reputation: 15
It was a problem with the router. It was only configured to allow 80. I had to open 25 as well.

I know, I feel pretty dumb. But I'm posting my results here in case someone else might run into a similar problem.

thank you for your help
 
Old 04-20-2004, 12:57 AM   #4
prpsarathy435
LQ Newbie
 
Registered: Dec 2001
Location: Mumbai, India
Distribution: net
Posts: 18

Rep: Reputation: 0
qmail/squirrel mail / apache/mysql

Hi

I am a student and i am doing a project on email on web browser. I am getting stuck in coordinating between all these components to make it work. can some body help me.

Thank you guys in anticipation

Regards
 
Old 04-20-2004, 01:07 AM   #5
ysg08
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9.0
Posts: 21

Original Poster
Rep: Reputation: 15
Cool

As far as apache/php/mySQL installation is concerned, if you have no linux experience, the best advice I can say is to either:

install each of them from an RPM
(download each rpm and install by rpm -i apache.2.x.x.x etc,

or:

download and install RedHat and use their easy to use checklist to install each of these (and many other) critical components.

as far as setting up an email server....by far the best advice I can give you is to go to www.qmailrocks.org and follow his step-by-step setup.

If you do all this, you should have a fully functioning web server with email and mySQL/PHP support.

IMPORTANT Make sure you have apache/php/perl installed (mySQL optional) if you want to use qMail/squirrelmail as your email.
 
Old 01-14-2005, 03:01 PM   #6
ysg08
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9.0
Posts: 21

Original Poster
Rep: Reputation: 15
Unhappy Problem RECEIVING email (again)

I recently have been having problems Receiving email on my email server at home...

========================
Relevant Info:

OS: RED HAT 9.0
Email: Qmail
Domain Registrar: godaddy.com
Router: Netgear
========================


Everything used to work beautifully for many months but for some reason, inbound mail just stopped working.

As far as I can tell, my router is working fine and all the settings are correct (email start port: 25.....end port: 25)

This is what the error message says when I try to email myself from a yahoo email:

Message from MAILER-DAEMON@yahoo.com on 2 Dec 2004 19:34:15 -0000

Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following
addresses.

This is a permanent error; I've given up. Sorry it didn't work out

Sorry, I couldn't find a mail exchanger or IP address. (#5.4.4)
------------------------------------------------------------------------------------------------

After checking my DNS settings on GoDaddy.com, this is what my MX record says

Priority Host Goes To: TTL
============================
0 @ xx.xxx.xx.xx 3600
10 mail xx.xxx.xx.xx 3600
============================

Of course the I have my real IP address in place of the xx.xxx.xx.xx's.

I have absolutely no idea what is wrong. Can somebody please help?


Last edited by ysg08; 01-14-2005 at 03:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mail after setting up qmail server dimsh Linux - Networking 2 09-07-2005 02:26 AM
qmail generating mail that sends to the wrong domain? shadoxity Linux - Software 5 04-16-2005 12:56 AM
FC3 and new QMail install - sends ok, can't receive ericcarlson Fedora 2 02-27-2005 03:02 PM
Qmail preblem, can't receive mail in Outlook... setactive Linux - Software 1 12-20-2003 01:15 AM
qmail fails to receive Outlook RTF mail smukec Linux - General 0 12-02-2003 11:24 AM


All times are GMT -5. The time now is 04:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration