LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Qmail Problem....? (Receiving mail) (http://www.linuxquestions.org/questions/linux-networking-3/qmail-problem-receiving-mail-278710/)

ysg08 01-17-2005 12:58 AM

Qmail Problem....? (Receiving mail)
 
I recently have been having problems Receiving email on my email server at home...

========================
Relevant Info:

OS: RED HAT 9.0
Email: Qmail
Domain Registrar: godaddy.com
Router: Netgear
========================


Everything used to work beautifully for many months but for some reason, inbound mail just stopped working.

As far as I can tell, my router is working fine and all the settings are correct (email start port: 25.....end port: 25)

This is what the error message says when I try to email myself from a yahoo email:

Message from MAILER-DAEMON@yahoo.com on 2 Dec 2004 19:34:15 -0000

Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following
addresses.

This is a permanent error; I've given up. Sorry it didn't work out

Sorry, I couldn't find a mail exchanger or IP address. (#5.4.4)
------------------------------------------------------------------------------------------------

After checking my DNS settings on GoDaddy.com, this is what my MX record says

===========================================
1) Priority - 0....Host - @....Goes To - xx.xxx.xx.xx.....TTL 3600
2) Priority - 10...Host - mail...Goes To - xx.xxx.xx.xx..TTL 3600
===========================================

(*Of course the I have my real IP address in place of the xx.xxx.xx.xx's)

I have absolutely no idea what is wrong. Can somebody please help? Thanks in advance...

maxut 01-17-2005 03:22 AM

u may want to check your "mx record" with dig or nslookup.

$dig mx yourdomain.com

or

$nslookup
>set q=mx
>yourdomain.com

good luck.

ysg08 01-17-2005 02:19 PM

Dig Results
 
This is the results when I ran dig on my domain.

==============================================================
; <<>> DiG 9.2.1 <<>> mx mydomain.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52634
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 2, ADDITIONAL: 4

;; QUESTION SECTION:
;mydomain.com. IN MX

;; ANSWER SECTION:
mydomain.com. 3600 IN MX 0 smtp.secureserver.net.
mydomain.com. 3600 IN MX 10 mailstore1.secureserver.net.
mydomain.com. 3600 IN MX 0 mail.mydomain.com.

;; AUTHORITY SECTION:
mydomain.com. 3600 IN NS PARK10.secureserver.net.
mydomain.com. 3600 IN NS PARK9.secureserver.net.

;; ADDITIONAL SECTION:
smtp.secureserver.net. 2146 IN A 64.202.166.12
mailstore1.secureserver.net. 2146 IN A 64.202.166.11
PARK9.secureserver.net. 1534 IN A 64.202.165.114
PARK10.secureserver.net. 1534 IN A 64.202.167.153

;; Query time: 140 msec
;; SERVER: 63.203.35.55#53(63.203.35.55)
;; WHEN: Mon Jan 17 08:40:18 2005
;; MSG SIZE rcvd: 217
===============================================================

I noticed in the ANSWER Section that it doesn't contian a response for @ or simply "mydomain.com".
I am going to try to make it do that but does anyone else have a clue to why my email wont accept incoming messages, yet deliver's outbound mail flawlessly? (most of the time in less than 10 seconds when I mail myself to yahoo and hotmail):Pengy:

ysg08 01-17-2005 02:30 PM

PROBLEM FIXED
 
I have fixed the problem. It turned out that I had answered my own question in my last post, but just for future reference for anyone else who may encounter a similar problem, I am posting how I got it working.

The problem lay in my MX record at my registrar's DNS record. My MX record setup was like this initially:

==========================================
Priority - 0, Host - @, GoesTo - xxx.xxx.xx.xx (my IP address)
==========================================

The last part (Goes To) was the problem. After I changed it to "mydomain.com", the @ host pointed straight to mydomain and now my inbound mail works again!

Hopefully This will help anyone else and help prevent the frustrations I went through (Sharing is caring!)

:twocents:


All times are GMT -5. The time now is 09:33 AM.