LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-02-2003, 12:36 PM   #1
Madrinator
Member
 
Registered: May 2003
Location: Guadalajara, Mexico
Distribution: Mandrake
Posts: 46

Rep: Reputation: 15
Question qmail's strange behavior


Hi out there!

I installed qmail and courier imap following the instructions in "Life with qmail" and now I'm testing them using Kmail sending mails to friends and relatives but I can't cause qmail is behavoring strangely.

When I try to send a mail I get this message from Kmail:

Sending failed:
The server didn't accept one of the recipients.
It said: sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
Note: Other messages will also be blocked by this message, as long as it is in the 'outbox' folder

If I add the domain I'm trying sending mail to, to my rcpthosts file, I'm able to send messages but, this is completely weird!!
What's going on? What did I do wrong?

My rcpthosts file only has my domain as it should be as well as my locals file.

Thank you very much!!
 
Old 10-02-2003, 01:31 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
You will need to allow qmail to act as a relay for your IP address or use some sort of pop before smtp. This allows you to send to any host not just to local mail boxes.
 
Old 10-03-2003, 05:30 PM   #3
Madrinator
Member
 
Registered: May 2003
Location: Guadalajara, Mexico
Distribution: Mandrake
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks!!!!!!

It worked. Now I can send e-mail anywhere.

I don't remember that step in the install instructions or maybe I skipped it.

Anyway, thank you again.
Muchas gracias!!

Thanks to this forum I'm not only learning Linux, I'm improving my english too!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gaim: strange behavior Oliv' Linux - Software 2 03-28-2005 12:14 PM
Very Strange Behavior raysr Mandriva 4 08-31-2004 02:06 PM
Strange Behavior andrewb758 Linux - Hardware 5 08-31-2003 02:42 PM
strange behavior abhijit Linux - General 3 07-09-2003 11:25 PM
Strange DHCPcd behavior padukes Linux - Networking 0 03-17-2002 09:55 AM


All times are GMT -5. The time now is 09:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration