LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-13-2006, 05:01 PM   #16
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15

So much for my theory that the smb/cifs version just wasn't authenticating properly. I set up a share on a machine outside the domain (in a workgroup) but the intrid system won't pick that up ether. Inside the limited shell I'm still getting the return code -22 error, and I can still mount it without dificulty if I boot from CD.
I have now decided to try downloading and burning Knoppix 3.9 and 5.0 to see if this problem is a bug in this particular version.
 
Old 12-14-2006, 04:58 PM   #17
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15
Right, downloaded knoppix 5 ISO. Built kernel, intrid, and PXE config files with all of the network probes. Copied them all to NFS server, along with all the files from new ISO which the NFS server shares as 10.1.1.1:/cdrom . Updated PXE server config to match the config from KNOPPIX server as closly as posible. Booted to PXE.


...


The machine still won't automaticaly mount the NFS share, nor the SMB/CIFS share using the smb intrid for knoppix 5.0 . I did try doing it manualy and I thought I had something, becuse there where no errors! But it haddn't actualy done anything, and "mount -t nfs wibble wibble" didn't throw any errors either.

Honestly, this should be a no brainer. Its starting to piss me off.
 
Old 12-15-2006, 12:50 AM   #18
eendoe
LQ Newbie
 
Registered: Sep 2003
Location: Australia
Distribution: Smooth, Deb, Ubu, KNX, RH mainly
Posts: 25

Rep: Reputation: 15
Lightbulb More help

Your a persistent bugger aren't you.

Here is a little bit more info on my process.

1. Boot Knoppix CD
2. Run the PXE configurator
3. Make sure you select the correct nic drivers for etherboot.nbi boot image
4. mkdir /cdrom (on your permanent NFS server)
5. cp -rf /mnt/cdrom NFSSERVER:/cdrom (only really need KNOPPIX/KNOPPIX)
6. move /tftpboot files to alternate server (TFTP server) if neccissary
7. change any ip's in /tftpboot/pxelinux.cfg/default if neccissary


That's all I needed to get this baby running.

Reasons for Cant moun't NFS server error;

1. client did not recieve ip / has incorrect ip
2. nfs mount are not exported (exportfs -a)
3. paths are wrong
4. permissions are wrong (unlikely)
5. remote chance you NIC is buggy because that tulip module has been around for eternity.


Again,


Good Luck


You persistent sod you . . . . . . . .
 
Old 12-17-2006, 02:04 PM   #19
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15
1. Boot Knoppix CD
check
2. Run the PXE configurator
check, repeatedly
3. Make sure you select the correct nic drivers for etherboot.nbi boot image
check, cross out, check again, black out with vivid
4. mkdir /cdrom (on your permanent NFS server)
check (although I did this from the server)
5. cp -rf /mnt/cdrom NFSSERVER:/cdrom (only really need KNOPPIX/KNOPPIX)
check (as above)
6. move /tftpboot files to alternate server (TFTP server) if neccissary
Is it necasary that the TFTP server be a different machine? I have one server that does every thing. Oh, check
7. change any ip's in /tftpboot/pxelinux.cfg/default if neccissary
check, check again, and again ....

Reasons for Cant moun't NFS server error;

1. client did not recieve ip / has incorrect ip
This is a distinct possibility that I hadn't thought of.
2. nfs mount are not exported (exportfs -a)
check, repeatedly
3. paths are wrong
check, if they where wrong I wouldn't be able to mount after KDE starts either.
4. permissions are wrong (unlikely)
This is the last thing I want to check considering it's running on Cygwin.
5. remote chance you NIC is buggy because that tulip module has been around for eternity.
Check, runs super smooth once KDE is up, or through DSL server straight from PXE. Also the same problem happens with another laptop.

I will look into the possibility of no IP (dam windows DHCP server) but I seem to vaguely remember passing a static IP to it early in this drama. And also permisions, which is not something I relish: windows permisions, two sets of linux permisions, all saying different things, yay!

And yes, I am a persistent bugger. It's a suvival trait in heterogeneous networks, along with resistance to insanity, having a high mental pain theshhold, and speaking the same language as the rabid monkey gods that appear when you haven't had enough sleep.

Last edited by royceH; 12-17-2006 at 02:06 PM.
 
Old 12-17-2006, 03:28 PM   #20
eendoe
LQ Newbie
 
Registered: Sep 2003
Location: Australia
Distribution: Smooth, Deb, Ubu, KNX, RH mainly
Posts: 25

Rep: Reputation: 15
Exclamation ip issues

Yes, if your pxe client has two nics I have seen them load PXE from nic 1 then when knoppix boots it runs off nic 2 etc.

This can be a bitch if client has two nics and want dhcp.


Props
 
Old 12-18-2006, 02:42 PM   #21
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15
I haven't had a chance to try this yet, but unless wireless, bluetooth or firewire count as "NICs" it's only got the one.

Also, NFS server is quite slow. Is it posible that this is timing out?
 
Old 12-18-2006, 04:52 PM   #22
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15
I have now tryed it with the "IPAPPEND 1" pxelinux option that is supposed to pass on the IP address to its booted linux. Nothing. The DHCP server is acnologing its request for an IP, and is giving it 10.1.1.35 if I ping this while knoppix is in its limited shell then it dosen't respond.

The samba variant, I discovered has the "ifconfig" command avalible (thanks to the cif pakage I think). It reports that the only IP address the the machine has is 127.0.0.1 on the loopback device, and there is no mention of eth0. It may be posible to bring up eth0 from the limited shell, but I'm having difcultys so far.

So, finaly the problem is identifyed: the PXE client has no IP. Now all I need is a solution.
 
Old 12-19-2006, 04:33 AM   #23
eendoe
LQ Newbie
 
Registered: Sep 2003
Location: Australia
Distribution: Smooth, Deb, Ubu, KNX, RH mainly
Posts: 25

Rep: Reputation: 15
Talking ip issues

allright your almost home and hosed.


don't think bluetooth will be treated as an interface but many distro's treat firewall as an interface.


anyways you are right to sniff around the append options for vmlinuz, try here;

http://www.linux.com/howtos/NFS-Root-4.shtml

something like this should let you manually latch onto device names and try some others (eth0, eth1 etc.)
 
Old 12-19-2006, 02:20 PM   #24
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15
I seem to remember doing somthing verry similar to this
Code:
ip=<client-IP-number>::<gateway-IP-number>:<netmask>:<client-hostname>:eth0:off
But without the hostname or network device

Also, inside the limited shell brining eth0 into existance is so dam dificult becuse modprobe is missing, so I can't just type "modprobe tulip"

Have added
Code:
ip=10.1.1.35::10.1.1.250:255.255.255.0:KNOP_35:eth0:off
to the append line and will post back with what it does.

Last edited by royceH; 12-19-2006 at 02:21 PM.
 
Old 12-19-2006, 02:59 PM   #25
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15
this IP force does nothing.
I'm now running with the device driver not working as when I issue the command :
"ifconfig eth0 up"
I get the error:
"eth0: ERROR while getting Interface flags: no such device"
most of the stuff I've found on google suggests using "modprobe <driver>" to bring the eth0 device into existance, but I don't have the modprobe command. Is ther any other way of doing this?
 
Old 12-21-2006, 01:28 PM   #26
royceH
Member
 
Registered: Nov 2006
Distribution: Debian and variants
Posts: 45

Original Poster
Rep: Reputation: 15
I suppose I could remaster the intrid file so that it has the modprobe command. is it a straght binary or shell script? or would this be a bit more involved?
 
  


Reply

Tags
knoppix, nfs, pxe


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting from PXE veeruk101 Linux - Networking 5 11-23-2006 09:53 PM
NFS Error during PXE Boot from NFS server JatMan Linux - Enterprise 0 10-16-2006 05:48 PM
PXE booting problem with DHCP amagi Linux - Networking 4 08-15-2006 02:38 AM
NFS Problem with Knoppix pengzy Linux - Networking 2 10-09-2005 09:35 PM
nfs client on knoppix 3.9 - problem mounting nfs drive Rod Butcher Linux - Networking 1 09-21-2005 04:18 AM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration