LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-21-2009, 05:24 AM   #1
xtothat
Member
 
Registered: Sep 2008
Location: Middle of Nowhere, England
Distribution: Slackware 14.1, Ubuntu 13.10
Posts: 39

Rep: Reputation: 15
PXE boot DHCP too slow.


Hi folks,

Basically the problem is as follows:

I have a couple of Slackware boxes, one PXE booting from the other, and the master connected to the internet via a Draytek Vigor modem/router. During the PXE section of the boot, the DHCP server on the master responds correctly, giving the slave machine it's IP on the correct subnet, and therefore allowing the slave to boot the kernel. During the initial bootup process, however, the kernel issues another DHCP request and the answer it gets is from the Draytek router rather than the master, giving it an IP on a subnet which cannot communicate with the master.

Any ideas would be more than welcome, as I'm totally stumped!

Thanks any and everyone in advance!

X-T
 
Old 09-30-2009, 08:06 PM   #2
babel17
LQ Newbie
 
Registered: Nov 2007
Posts: 9

Rep: Reputation: 1
It's not legal to have two DHCP servers on the same physical/virtual subnet unless they are synchronized. need to make sure PXE client is not on the physical subnet that the router is on. Either that, or configure router so it points to master as bootparam server. If router has that capability. PXE client will set option 60 (vendor code) to PXEClient. If you have a sophisticated DHCP server on the Draytek you can switch on that.

If the Draydek has a primitive DHCP server, the you are SOL, you're only choice is to isolate the PXE network from the router.
 
Old 12-19-2010, 12:16 AM   #3
xtothat
Member
 
Registered: Sep 2008
Location: Middle of Nowhere, England
Distribution: Slackware 14.1, Ubuntu 13.10
Posts: 39

Original Poster
Rep: Reputation: 15
Hi!

Didn't even realise this had been answered! I eventually got it by setting the IP address on the kernel command line, rather than relying on DHCP. Given that the server will only ever have one client booting from it, I don't know why my predecessor didn't design it this way in the first place! Suffice it to say, that has been changed!

Thanks for your reply, and I apologise for not thanking you for your input sooner!
 
  


Reply

Tags
dhcp, dhcpd, pxe, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcp - PXE booting icedude Linux - Enterprise 10 09-28-2010 05:36 AM
DHCP not handing IP to KVM in PXE boot drschloss Linux - Networking 2 09-03-2010 05:31 PM
DHCP, OSCAR cluster installation, VMware server and PXE-boot problem. Azazwa Linux - Newbie 3 03-31-2009 10:52 AM
DHCP server / PXE boot freeindy Linux - Networking 2 03-04-2008 02:31 AM
DHCP vs PXE woes :S kevingpo Linux - Networking 2 11-05-2005 01:02 PM


All times are GMT -5. The time now is 09:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration