LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   PXE boot DHCP too slow. (http://www.linuxquestions.org/questions/linux-networking-3/pxe-boot-dhcp-too-slow-756723/)

xtothat 09-21-2009 05:24 AM

PXE boot DHCP too slow.
 
Hi folks,

Basically the problem is as follows:

I have a couple of Slackware boxes, one PXE booting from the other, and the master connected to the internet via a Draytek Vigor modem/router. During the PXE section of the boot, the DHCP server on the master responds correctly, giving the slave machine it's IP on the correct subnet, and therefore allowing the slave to boot the kernel. During the initial bootup process, however, the kernel issues another DHCP request and the answer it gets is from the Draytek router rather than the master, giving it an IP on a subnet which cannot communicate with the master.

Any ideas would be more than welcome, as I'm totally stumped!

Thanks any and everyone in advance!

X-T

babel17 09-30-2009 08:06 PM

It's not legal to have two DHCP servers on the same physical/virtual subnet unless they are synchronized. need to make sure PXE client is not on the physical subnet that the router is on. Either that, or configure router so it points to master as bootparam server. If router has that capability. PXE client will set option 60 (vendor code) to PXEClient. If you have a sophisticated DHCP server on the Draytek you can switch on that.

If the Draydek has a primitive DHCP server, the you are SOL, you're only choice is to isolate the PXE network from the router.

xtothat 12-19-2010 12:16 AM

Hi!

Didn't even realise this had been answered! I eventually got it by setting the IP address on the kernel command line, rather than relying on DHCP. Given that the server will only ever have one client booting from it, I don't know why my predecessor didn't design it this way in the first place! Suffice it to say, that has been changed!

Thanks for your reply, and I apologise for not thanking you for your input sooner!


All times are GMT -5. The time now is 04:17 PM.