LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 05-05-2004, 08:30 PM   #1
SwiftDeath
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
ProFtpd Server Ports


I cannot get FtpD server to work... I need to switch the port to 8345 (or something other than 21) so I do that in the config file. I also open up that port on my router. I also read a guide saying that linux doesn't work properly on a LAN, and if you add this to your config file it'll work.

Quote:
MasqueradeAddress 68.229.11.108
PassivePorts 60000 65535
I did that and opened the ports on my router and it didn't work.

I get this error from IE when trying to connect.
Quote:
Details:
200 Type set to A
500 Illegal Port Command
500 LPRT not understood
When I use WS_FTP PRO, I get this error

Quote:
Connecting to 68.229.11.108:8345
Connected to 68.229.11.108:8345 in 0.000000 seconds, Waiting for Server Response
220 ProFTPD 1.2.9 Server (ProFTPD Default Installation) [68.229.11.108]
Host type (1): Automatic detect
USER andrew
331 Password required for andrew.
PASS (hidden)
230 User andrew logged in.
SYST
215 UNIX Type: L8
Host type (2): UNIX (standard)
PWD
257 "/var/www/html" is current directory.
TYPE A
200 Type set to A
PASV
227 Entering Passive Mode (68,229,11,108,248,219).
connecting data channel to 68.229.11.108:248,219(63707)
PORT 192,168,0,104,12,4
500 Illegal PORT command
Port failed 500 Illegal PORT command
Could someone please help me my problem? I have a DI-614+ router and I'm running Mandrake 10.0 CE.

Thanks,
SwiftDeath
 
Old 05-05-2004, 08:36 PM   #2
SwiftDeath
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Also, when I open the DMZ I still can't acess the webserver in IE, but when I use WS_FTP Pro it works... Heres the entry I get

Quote:
WINSOCK.DLL: WinSock 2.0
WS_FTP Pro, Version 8.03T, 2003.12.16
Connecting to 68.229.11.108:8345
Connected to 68.229.11.108:8345 in 0.000000 seconds, Waiting for Server Response
220 ProFTPD 1.2.9 Server (ProFTPD Default Installation) [68.229.11.108]
Host type (1): Automatic detect
USER andrew
331 Password required for andrew.
PASS (hidden)
230 User andrew logged in.
SYST
215 UNIX Type: L8
Host type (2): UNIX (standard)
Sending "FEAT" command to determine what features this server supports.
FEAT
211-Features:
MDTM
REST STREAM
SIZE
211 End
Finished interpreting "FEAT" response.
Sending the FEAT command is optional. You can disable it in the site options of the profile.
PWD
257 "/var/www/html" is current directory.
CWD /var/www/html
250 CWD command successful.
PWD
257 "/var/www/html" is current directory.
TYPE A
200 Type set to A
PASV
227 Entering Passive Mode (68,229,11,108,237,71).
connecting data channel to 68.229.11.108:237,71(60743)
data channel connected to 68.229.11.108:237,71(60743)
LIST
150 Opening ASCII mode data connection for file list
transferred 136 bytes in < 0.001 seconds, 1062.500 Kbps ( 132.813 Kbps), transfer succeeded.
226 Transfer complete.
I also thought showing my config file too might help. So here it is
Quote:
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "ProFTPD Default Installation"
ServerType standalone
DefaultServer on

# Allow FTP resuming.
# Remember to set to off if you have an incoming ftp for upload.
AllowStoreRestart on

# Port 21 is the standard FTP port.
Port 8345

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances 30

# Set the user and group under which the server will run.
User nobody
Group nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~

# Normally, we want files to be overwriteable.
<Directory />
AllowOverwrite on
</Directory>

# Needed for NIS.

PersistentPasswd off

# Default root can be used to put users in a chroot environment.
# As an example if you have a user foo and you want to put foo in /home/foo
# chroot environment you would do this:
#
# DefaultRoot /home/foo foo
<Global>
DefaultChdir /var/www/html/
</Global>

#MODDED BY ANDREW
MasqueradeAddress 68.229.11.108
PassivePorts 60000 65535
#MODDED BY ANDREW
 
Old 05-07-2004, 08:19 PM   #3
SwiftDeath
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
*BUMP*
 
Old 05-08-2004, 01:38 PM   #4
jokerls240
LQ Newbie
 
Registered: Feb 2004
Location: Nashville, TN
Distribution: Slack 10.0 - 2.6.7
Posts: 17

Rep: Reputation: 0
Try disabling Passive Mode in WS_FTP PRO. If you can log on to the FTPd when the computer is in the DMZ, then this will prove that your router isn't supporting passive connections.

When you use IE, how are you trying to connect to the webserver? Using port 80? Also make sure port 80 is open on the router.

I gotta run, but give me some more details. It sounds like the FTPd is setup right. But you're just having some troubles with the router. I have a DI-624, so I may be able to help out with the config.
 
Old 05-08-2004, 10:10 PM   #5
SwiftDeath
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Hmm sorry... I can't try that right now... but I'll try it once I reinstall it.

Apache broke for some weird reasons and my router is acting very strange. But thanks.... Hopefully this problem will be gone when I reinstall mandrake linux.
 
Old 05-10-2004, 11:33 PM   #6
SwiftDeath
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
You were right.

I opened the DMZ and connected successfully using WS_FTP and so did my friend. Much thanks, but how do I make it without the DMZ open, because thats a tad dangerous.

Also, how can I make it work in IE. I still get the same error I stated before.
 
Old 05-11-2004, 12:56 AM   #7
jokerls240
LQ Newbie
 
Registered: Feb 2004
Location: Nashville, TN
Distribution: Slack 10.0 - 2.6.7
Posts: 17

Rep: Reputation: 0
First turn on VirtualServer FTP on the router, or just open port 21. If you're also serving a website enable VirtualServer HTTP or open port 80.

That should be good enough for the HTTPd. When trying to connect to FTP in IE and can't, go to Tools > Internet Options > Advanced and enable Passive FTP transfers (PASV). Actually, just do the opposite of whatever's there - if it's disabled, enable it and vice versa. You can try the same in any FTP client if you're not connecting.

Looking back on the whole post, I found this:

Quote:
PASV
227 Entering Passive Mode (68,229,xxx,xxx,237,71).
connecting data channel to 68.229.xxx.xxx:237,71(60743)
data channel connected to 68.229.xxx.xxx:237,71(60743)
That tells me that WS_FTP is connecting to ports 237 and 71. So try enabling passive mode in IE and turn the DMZ off.

Last edited by jokerls240; 05-11-2004 at 12:58 AM.
 
Old 05-11-2004, 11:10 PM   #8
SwiftDeath
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Hmm.. I have to replace the ports 80 and 21 because my ISP blocks them. Also... it seems that when connecting in Passive mode, that those ports use mentioned are changed everytime you do it. So I have to leave the DMZ open.

Maybe theirs a different mode that only uses one direct port?

Also, enabling the Passive Mode in IE seemed to delay the error message because I never get a error message, and it just sits their forever trying to find it, But I think its the router because I can connect to the FTP inside the LAN.


Thanks for the help btw,
I am finding it useful.
 
Old 05-12-2004, 01:04 AM   #9
jokerls240
LQ Newbie
 
Registered: Feb 2004
Location: Nashville, TN
Distribution: Slack 10.0 - 2.6.7
Posts: 17

Rep: Reputation: 0
That's odd. Even using different ports w/ the servers, the router should still work in passive mode. That's basically how you use chat clients. I'm using passive on my FTP. And I have a friend that accesses mine w/ IE and passive.

The only way to use one port, that I know of, is to turn off passive connections. When accessing your server through the LAN, are you using passive?

I'm boggled, dude. It's usually that easy. But I'm used to running FTP in Windoze. Now mine is down. LOL. I guess Slack doesn't like me installing all these packages.

Buy a new router? :P Linksys is good, but I don't like their wireless routers.

Do you know if your ISP is blocking the protocols and not the ports? I really don't know if that's possible, but it's a thought. I'm prolly just too tired right now.

I don't mind helping -- it's what I do all day. Gimme some more info or connection logs.
 
Old 05-12-2004, 02:16 AM   #10
onnyloh
Member
 
Registered: Nov 2002
Posts: 57

Rep: Reputation: 15
if u r using 21 port.
proftpd use 21 - 1 port to connect your client(port mode)
try to use pasv mode to if it is working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Open Mail Server Ports 25, 110, and 220. Other Ports will open. Binxter Linux - Newbie 9 11-29-2007 03:03 AM
ProFtpd, ports and internal/external IP gbj Linux - Networking 6 03-11-2005 06:00 PM
proftpd (ftp server) Adrian13 Linux - Software 3 10-18-2004 05:22 PM
I can't login to my proFTPd server :( gnomes Linux - Software 7 08-02-2004 01:55 AM
Very Very slow ProFTPd server ..:eMa:.. Debian 2 04-17-2004 04:16 AM


All times are GMT -5. The time now is 05:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration