LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-05-2004, 02:50 PM   #1
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Rep: Reputation: 30
Problems with SSH and connecting remotely


Hello,
I has SSHD running on my Slackware 10 box, I am @ work now connected remotly via PuTTY.
When I run any program that needs to capture the screen (top, vi, etc..) nothing responds.
PuTTY does not lock up, because I can still load the menu in PuTTY.
I can issue other commands, I wanted to look @ a config file, so I just cat'd it.

I am running PuTTY 0.55.
I looked @ /etc/ssh/ssd_config, it says it is version 1.68.
I'm not sure if that is the version of sshd, I honestly don't know how to check the version.
I tried sshd --version, but it wasn't that simple.

Anyway, if I cat a long file, all I see is the command to cat and nothing happens. If I cat filename | more, then it works fine.
I was thinking maybe the PuTTY window was locked to where it would not scroll, but I just hit ls several times, and the window will scroll.

Any thoughts?
-Jason
 
Old 08-05-2004, 03:01 PM   #2
BrianWGray
Member
 
Registered: Oct 2003
Posts: 54

Rep: Reputation: 15
Cool Buffer size

I wonder if putty's buffer size setting is causing a problem.

Have you checked to see if you can ssh to the box without issue from any other machines?
 
Old 08-05-2004, 03:03 PM   #3
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
I only have windows machines here, so it would be using PuTTY.
Just had a thought though, I'm running the program off of my pendrive.
I doubt it, but it might cause the problem.

Gonna try that in a min
-Jason
 
Old 08-05-2004, 03:10 PM   #4
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
I think it is the buffer.
I just pressed enter and held it down @ the terminal, basically to scroll the screen down.
Once the scroll bar on the right appears, I have a few more lines of PuTTY before the program locks up.
How can I change the buffer size in PuTTY?
If this is a PuTTY issue, I know this isn't related to the forums, but I'd appreciate any help.
-jason
 
Old 08-05-2004, 03:50 PM   #5
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Have you tried changing the TERM value to something like vt100 or vt220?
 
Old 08-05-2004, 04:29 PM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
If you press "ctrl-L" in vi, does it refresh the screen. I have used a different ssh client called 'ssh32' which I had better luck with.

There is a command line option -T <Terminal>, that you can use when starting vim. Perhaps trying a couple different terminal modes in PuTTy and matching the terminal type in the -t option you may have better results.
 
Old 08-05-2004, 04:33 PM   #7
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
TERM in PuTTY or TERM on my linux box?

I just through the config for PuTTY and I didn't see an option to set the term.
I saw VT100+ Listed under the keyboard options for 'Function Keys and keypad'.

Where should I look on my linux box, if it's local to the server not the client?
-Jason
 
Old 08-05-2004, 06:59 PM   #8
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
If I have output sent to the screen slowly, it is no problem.
If I cat a file, open vi, or top, nothing responds in PuTTY.
PuTTY does not lock up, I can still access the settings.

Any thoughts?
-Jason
 
Old 08-05-2004, 07:05 PM   #9
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by jschiwal
If you press "ctrl-L" in vi, does it refresh the screen. I have used a different ssh client called 'ssh32' which I had better luck with.

There is a command line option -T <Terminal>, that you can use when starting vim. Perhaps trying a couple different terminal modes in PuTTy and matching the terminal type in the -t option you may have better results.
Ctrl+L does nothing in PuTTY.
vi -t only makes the screen black and puts the command prompt at the bottom.
-Jason
 
Old 08-06-2004, 12:13 PM   #10
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
Shameless BUMP!

/bump

Anyone have an idea, any other Win32 FREE SSH Clients I should try?
I need a SSH client that does not install, just runs.
Help....
-Jason
 
Old 08-06-2004, 03:13 PM   #11
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Maybe you misunderstood my message. CTRL-L is supposed to refresh the screen when using vim. The -T <terminal> option I mentioned (capital T) is followed by the type of terminal that you are using. I thought that if you explicitly indicated the terminal type when starting vim it might behave better, in case vim didn't recognize the terminal type properly when starting up.
 
Old 08-06-2004, 04:05 PM   #12
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by jschiwal
Maybe you misunderstood my message. CTRL-L is supposed to refresh the screen when using vim. The -T <terminal> option I mentioned (capital T) is followed by the type of terminal that you are using. I thought that if you explicitly indicated the terminal type when starting vim it might behave better, in case vim didn't recognize the terminal type properly when starting up.
Yah.. mybad.

vim -T vt220

That works great, so this seems to be an issue with the terminal set.
Is there any way to set the terminal for when I login, that way I don't have to specify the terminal type when opening every window.

vi isn't the only program that locks it up, I just issued the command 'ls -a' in ~/.
I see the first few lines and then the screen locks up.
Any thoughts?
-Jason
 
Old 08-06-2004, 04:28 PM   #13
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
I hate to spam, just wanted to post updates.
If I try vim -T linux, the terminal locks up, so it is a problem with the term type.

I decided to risk it and set TERM=vt220 in /etc/profile (there is no .profile file in ~/).
Now when I type 'echo $TERM' it says vt220, but most commands still lock up the terminal.

Any other terminals I should try, we're making progress and I thank you, but any thoughts?
-Jason
 
Old 08-06-2004, 06:57 PM   #14
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Original Poster
Rep: Reputation: 30
Ok, I found in PuTTY where to send the terminal string, I have matched the TERM type on my linux box to the string in PuTTY, still having problems.

I have tried the following TERM types (set in both PuTTY and /etc/profile)
vt220
vt100
linux


xterm was the default set in PuTTY and linux was the default set on my linux box @ home.
no matter what term type I set vim -T vt220 still works.
I 'm at a loss, matching the TERM types should fix it.
-Jason
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remotely connecting to MySQL using SSH Teleute Linux - Security 19 03-25-2005 10:51 PM
Connecting remotely to GUI deWin Linux - Networking 0 03-03-2004 01:15 PM
Connecting remotely from internet pyre Linux - Newbie 2 01-29-2004 11:10 AM
Connecting to Computer Remotely macaddict Linux - Networking 1 10-08-2003 07:51 PM
connecting remotely to unix djappelsap Linux - Networking 6 10-27-2001 12:20 PM


All times are GMT -5. The time now is 11:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration