LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 06-29-2005, 06:49 AM   #1
lagu2653
Member
 
Registered: Jun 2005
Distribution: Mint 12 "Lisa"
Posts: 103

Rep: Reputation: 15
Problems with Samba: http://localhost:901 doesn't work


During the installation of SuSE 9.3 I opted to install as little as possible. My book (ISBN 1590594584) told me so. Attempting to set up my home network I followed this guide. The problems came when he opened the runlevel editor and enabled the services nmb, smb and smbfs. I had asterixes (stars) next to half of all my services in the runlevel editor. smbfs was one of those. I got the same error message that he got though "returned 6 (program is not configured)". In the next step when he opens up Konqueror and goes to "http://localhost:901/" I get an error. It says that a connection to the host (localhost) could not be established on port 901.

I also tried this other guide. Everything went fine until you were supposed to examine the YaST2 configuration changes had done to the file /etc/samba/smb.conf their contents did not match mine at all. I had:
Code:
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2005-04-04
[global]
	workgroup = Hemma
	printing = cups
	printcap name = cups
	printcap cache time = 750
	cups options = raw
	printer admin = @ntadmin, root, administrator
	username map = /etc/samba/smbusers
	map to guest = Bad User
	include = /etc/samba/dhcp.conf
	logon path = \\%L\profiles\.msprofile
	logon home = \\%L\%U\.9xprofile
	logon drive = P:
	idmap gid = 10000-20000
	idmap uid = 10000-20000
	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
	domain logons = No
	domain master = No
	netbios name = SuSEBurken
	security = user

[homes]
	comment = Home Directories
	valid users = %S
	browseable = No
	read only = No
	inherit acls = Yes

[profiles]
	comment = Network Profiles Service
	path = %H
	read only = No
	store dos attributes = Yes
	create mask = 0600
	directory mask = 0700

[users]
	comment = All users
	path = /home
	read only = No
	inherit acls = Yes
	veto files = /aquota.user/groups/shares/

[groups]
	comment = All groups
	path = /home/groups
	read only = No
	inherit acls = Yes

[printers]
	comment = All Printers
	path = /var/tmp
	printable = Yes
	create mask = 0600
	browseable = No

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin root
	force group = ntadmin
	create mask = 0664
	directory mask = 0775

[fran_xpburken]
	comment = Fran_XPBurken
	inherit acls = Yes
	path = /home/lagu2653/Fran_XPBurken
	read only = No
	browseable = Yes
and they had:
Code:
[global]
workgroup = network
username map = /etc/samba/smbusers
guest ok = yes
netbios name = samba
encrypt passwords = yes
comment = Linux PC

[ives data]
comment = ives home folder
path = /home/ives
writeable = yes
browseable = yes
read only = no
abbreviated though.

What sould i do to get my network working. I can Ping both ways, but when I try this:
Code:
lagu2653@SuSEBurken:~> smbclient -W 'Hemma' //192.168.1.2/
Password:
Domain=[J48960J] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME
lagu2653@SuSEBurken:~>
The name of the working group is 'Hemma'.

/Lars
 
Old 06-29-2005, 08:50 AM   #2
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
I thing that you have to install SWAT if you want to configure samba through port 901
your config file is too complicated
that's my

[global]
workgroup = BLOCK10
security = share
encrypt passwords = false
socket options = TCP_NODELAY
dns proxy = no
guest account = nobody
server string = Samba 3 running on Morphix
wins support = no
[video]

comment = MyShare
path = /mnt/hd2/video
guest ok = yes
browseable = yes
read only = yes

and finaly that command is not correct I think
looks better this way

smbclient -W Hemma -L 192.168.1.2

and u can mount it with
smbmount //192.168.1.2/sharenane /mnt/mountpoint

if everything is OK u can install LinNeighbourhood or xfsamba4 and everything is automated.
when u make your smb.conf run testparm and it will tell u does everithing's going fine
 
Old 06-29-2005, 09:17 AM   #3
MikeAtVillage
Member
 
Registered: May 2005
Location: Mid Wales (UK)
Distribution: Slackware 8.0, Suse 10.0/1/2, CentOS (SMEServer7)
Posts: 38

Rep: Reputation: 15
You also might have to edit /etc/inetd.conf to allow swat to run (remove the preceeding #).

I use Slackware Linux, your inetd.conf may be located elsewhere.
 
Old 06-29-2005, 01:34 PM   #4
vimal
Red Hat India
 
Registered: Nov 2004
Location: Kerala/Pune,india
Distribution: RedHat, Fedora
Posts: 260

Rep: Reputation: 34
i think u must check whether u have installed the "swat" package. ie... samba-swat. after that check if ur firewall is configured to stop all services . flush ur current firewall settings and restart samba. this must work fine.
 
Old 06-29-2005, 02:41 PM   #5
gnukish
Member
 
Registered: Apr 2005
Location: Neverland
Distribution: Slackware / Ubuntu
Posts: 171

Rep: Reputation: 30
Configuring Samba ==>
Code:
http://rapidshare.de/files/2631299/Samba_configuration.pdf.html
 
Old 06-29-2005, 04:13 PM   #6
lagu2653
Member
 
Registered: Jun 2005
Distribution: Mint 12 "Lisa"
Posts: 103

Original Poster
Rep: Reputation: 15
Almost there

Thanks for the tip about enabling 'xinetd'. I already had swat enabled. I've almost got it working now . I can browse some directories in the SUSE box from the Win XP box. I want to make my 'homes' directory writeable. It's linked to a special directory /home/.../From_the_XPBOX/. When I try to add the property 'writeable', or 'writable' for that matter, a pop-up window pops up and promts me to enter something in a textfield. What should I write in that textfield? I've tried yes, the path, no, read only, but nothing seems to work. Can I write it directly into /etc/samba/smb.conf?
Code:
writeable=yes
/Lars

P.S. Is it possible to browse directories in the XP Box without uninstalling Norton Internet Security 2004 D.S.

Edit: Now it's working, but I still always have to sit at the XP machine when transferring files. I tried the tip:
Code:
lagu2653@SuSEBurken:~> smbclient -W Hemma -L 192.168.1.2
Password:
Domain=[J48960J] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

        Sharename       Type      Comment
        ---------       ----      -------
Error returning browse list: NT_STATUS_OK
session request to 192.168.1.2 failed (Called name not present)
session request to 192 failed (Called name not present)
Domain=[J48960J] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

        Server               Comment
        ---------            -------

        Workgroup            Master
        ---------            -------
lagu2653@SuSEBurken:~>
What's the problem this time? Norton Internet Security 2004? The firewall is disabled. I don't want to uninstall it.

Last edited by lagu2653; 06-29-2005 at 05:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba problem with accessing localhost:901 rcj2 Linux - Networking 27 11-28-2005 08:50 PM
Samba - Swat: Cannot Connect to Localhost:901 Sloppyunderfoot Linux - Networking 3 02-10-2005 01:26 PM
SAMBA & SWAT - Connection refused when attempting to connect Localhost:901 ScooterB Linux - Networking 3 12-24-2003 05:15 PM
Errors on accessing Swat SAMBA http://localhost:901 @ Mandrake 9.0. Zepiroth Linux - Networking 2 06-03-2003 10:51 PM
SWAT does not work when calling localhost:901 themorph Linux - Networking 2 03-07-2002 12:04 AM


All times are GMT -5. The time now is 10:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration