LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 05-03-2012, 11:02 PM   #1
NuxIT
Member
 
Registered: Jul 2003
Location: Westminser, CO
Distribution: xUbuntu
Posts: 76

Rep: Reputation: 20
Problems Connecting to xrdp xfce desktop after Ubuntu Upgrade


Hi, I just upgraded my linux box from 11.10 to 12.04 last night. Everything went smooth except for one issue. I use xrdp over ssh to connect to the machine remotely. After the upgrade on the first boot I had an issue where it said failed to load gnome. Well, I found a rather hidden drop down menu in the default x-gui and managed to get back to my xfce desktop by choosing it. So, that's not an issue anymore when logged in locally.

The last time I did an upgrade I didn't have this remote issue with it trying to load gnome. It just stuck with the default xfce which is what I want because this is an old machine and xfce works great remotely.

So, now when I try to connect to my ubuntu machine remotely using Windows mstsc (remote desktop)I get the same failed to load gnome message I got on first boot up. However, I can't change anything on the remote session to choose xfce like I did locally. Here's my screen shots and my xrdp.ini file.

I can't determine what gui/session environment the xrdp specifies but I don't see gnome or xfce in the file. It used to just connect to xfce fine before the upgrade. It also didn't have this issue previous upgrade. Any ideas how I cant get xrdp to load xfce again?

Xrdp login (note I've always used the sesman-Xvnc to connect to desktop using xrpd. Their are other drop downs for just xrdp but that doesn't work and apparently requires very low resolution.

Xrdp login
http://home.comcast.net/~16v/linux/xrdplogin.png

Gnome error:
http://home.comcast.net/~16v/linux/gnomeerror.png

Sry couldn't figure out how to turn on html code and img tags. Thx for any/all help! I'd rather use xrdp but I'll try a vpn connection if necessary but this has always worked for my remote needs.

xrdp.ini
Code:
[globals]
bitmap_cache=yes
bitmap_compression=yes
port=3355
crypt_level=low
channel_code=1

[xrdp1]
name=sesman-Xvnc
lib=libvnc.so
username=ask
password=ask
ip=127.0.0.1
port=-1

[xrdp2]
name=console
lib=libvnc.so
ip=127.0.0.1
port=5900
username=na
password=ask

[xrdp3]
name=vnc-any
lib=libvnc.so
ip=ask
port=ask5900
username=na
password=ask

[xrdp4]
name=sesman-any
lib=libvnc.so
ip=ask
port=-1
username=ask
password=ask

[xrdp5]
name=rdp-any
lib=librdp.so
ip=ask
port=ask3389

[xrdp6]
name=sesman-X11rdp
lib=libxup.so
username=ask
password=ask
ip=127.0.0.1
port=-1
 
Old 05-04-2012, 12:06 AM   #2
NuxIT
Member
 
Registered: Jul 2003
Location: Westminser, CO
Distribution: xUbuntu
Posts: 76

Original Poster
Rep: Reputation: 20
Ok, I've done some searching and apparently I'll need to modify this file. At least it appears that way. Not sure what this file had in it previous to update to 12.04.

/etc/xrdp$ cat startwm.sh
#!/bin/sh

if [ -r /etc/default/locale ]; then
. /etc/default/locale
export LANG LANGUAGE
fi

. /etc/X11/Xsession


Any suggestions? Thx, tired and need some zzzzz's

Last edited by NuxIT; 05-04-2012 at 12:09 AM.
 
Old 05-04-2012, 08:08 AM   #3
NuxIT
Member
 
Registered: Jul 2003
Location: Westminser, CO
Distribution: xUbuntu
Posts: 76

Original Poster
Rep: Reputation: 20
Still diggin. I think it's between a few files. Any suggestions?

cat sesman.ini
[Globals]
ListenAddress=127.0.0.1
ListenPort=3350
EnableUserWindowManager=1
UserWindowManager=startwm.sh
DefaultWindowManager=startwm.sh

[Security]
AllowRootLogin=1
MaxLoginRetry=4
TerminalServerUsers=tsusers
TerminalServerAdmins=tsadmins

[Sessions]
MaxSessions=10
KillDisconnected=0
IdleTimeLimit=0
DisconnectedTimeLimit=0

[Logging]
LogFile=/var/log/xrdp-sesman.log
LogLevel=DEBUG
EnableSyslog=0
SyslogLevel=DEBUG

[X11rdp]
param1=-bs
param2=-ac
param3=-nolisten
param4=tcp

[Xvnc]
param1=-bs
param2=-ac
param3=-nolisten
param4=tcp
 
Old 05-04-2012, 09:45 AM   #4
NuxIT
Member
 
Registered: Jul 2003
Location: Westminser, CO
Distribution: xUbuntu
Posts: 76

Original Poster
Rep: Reputation: 20
Well, as a temporary work-around I deleted the startwm.sh and then did a remote desktop connection. It dropped me right to a shell and then I typed startxfce4 and it's in. But this isn't the fix I'm looking for. Any suggestions?

I supposed I'll wipe out xrdp and reinstall to see if that fixes it if no other suggestions.
 
Old 05-04-2012, 11:43 PM   #5
NuxIT
Member
 
Registered: Jul 2003
Location: Westminser, CO
Distribution: xUbuntu
Posts: 76

Original Poster
Rep: Reputation: 20
Thumbs up Fixed

Welp, guess I'll respond one more time to my own thread. LOL
I managed to fix this by adding this line to my startwm.sh file.

I changed the last line in this file
FROM:
. /etc/X11/Xsession
TO:
xfce4-session

BAM! xfce4 baby!
 
Old 09-29-2012, 01:26 AM   #6
cborn
LQ Newbie
 
Registered: Sep 2012
Posts: 1

Rep: Reputation: Disabled
Thumbs up

Thanks, same problem here and your solution worked for me.
 
Old 10-08-2012, 04:55 PM   #7
minty33
Member
 
Registered: Aug 2012
Location: earth
Distribution: Mint Xfce, Korora Gnome3, Ubuntu Server NoGui,
Posts: 136

Rep: Reputation: 1
thanx for all your work on your own thread. i was having same problem using rdp on my android device to access my mint box. i noticed as you did that the error was same as starting xsession instead of xfce locally. oddly when i fresh install as w/ your upgrade it wants to use xsession as default. i don't know what this is used for. soon as i install some programs i can no longer log in via xsession and must change default to xfce or mate etc...anyway thanx again good work.
 
Old 11-12-2012, 06:15 PM   #8
Thorium232
LQ Newbie
 
Registered: Nov 2012
Posts: 1

Rep: Reputation: Disabled
Thumbs up

NuxIT... tnx a lot.. not only you helped me solving the same issue.
I've also laughed my ass off. 1 man army ... lol ... tnx =)
 
Old 12-18-2012, 02:21 AM   #9
ggoscarl
LQ Newbie
 
Registered: Dec 2012
Posts: 1

Rep: Reputation: Disabled
Thumbs up worked on linux mint 13 mate

Changing to mate-session worked like a charm, thank you!
 
Old 05-04-2013, 10:45 PM   #10
grief
LQ Newbie
 
Registered: Nov 2003
Location: USA
Distribution: Slackware 11
Posts: 7

Rep: Reputation: 0
Had the same issue and this fixed it. thanks!
 
Old 05-04-2013, 11:50 PM   #11
NuxIT
Member
 
Registered: Jul 2003
Location: Westminser, CO
Distribution: xUbuntu
Posts: 76

Original Poster
Rep: Reputation: 20
Thumbs up

Very Cool! Glad to hear this worked for a lot of people. Didn't know I was solving something so many other people were going to have issues with as well. I was very close to reloading from scratch but kept at it and felt redeemed. LOL Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Xfce 4.8 Desktop for Ubuntu unist Linux - Newbie 6 04-14-2011 10:02 PM
xrdp windows Remote Desktop Error Skullsoldier Linux - Newbie 1 11-02-2010 07:36 AM
broken xfce desktop after upgrade to slackware-current Gustav 4 Slackware 9 08-06-2009 06:52 PM
xrdp upgrade problem manoj.maniraj Linux - Software 1 05-14-2009 12:43 AM
Problems with xfce, adduser, connecting to internet Randux Slackware 10 02-13-2006 09:51 AM


All times are GMT -5. The time now is 08:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration