LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-21-2003, 05:13 AM   #1
MadCactus
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1
Posts: 195

Rep: Reputation: 30
Problem setting up web proxy server


Hi,

I'm trying to set up a web proxy for a LAN on a static IP address.

I've set up an iptables script for filtering and NAT + all seems to be ok.

However I get "network unreachable" errors when I try to do anything on the external network from the proxy server (PS). Can ping the router ok, but nothing beyond that...

The name of the PS resolves to "no-dns-yet.ourisp.co.uk" from other machines on the LAN (we have another connection) and I can ping the PS external IP address from the LAN, but NOT the router...

I find this strange because I definitely allowed all traffic through the internal NIC and filtered traffic at the external NIC...

If anyone could shed any light on this, would be grateful.

MadCactus
 
Old 11-21-2003, 06:03 AM   #2
hakcenter
Member
 
Registered: Apr 2003
Location: Not to far from the computer screen
Distribution: RedHat 9.0
Posts: 324

Rep: Reputation: 30
check your proxy ACLs, make sure the machines are aloud connectivity.
Make sure that the proxy is not dns resolving itself, thats a pain option to find in squid.. heh

Make sure the proxy box's default route is setup properly.
 
Old 11-21-2003, 06:46 AM   #3
MadCactus
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1
Posts: 195

Original Poster
Rep: Reputation: 30
Well i'm using Knoppix for speeds sake, and i'm not sure how to set up the default routes... I edited /etc/network/interfaces with the route but when I try to do: "service network restart" I find theres no "service" command (in any of the sbin dirs).

Also ACL - means?

Cheers,

M
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora v3, problem setting up web server JoelK04 Linux - Newbie 2 02-24-2005 05:49 PM
setting up password protected web forms on an apache web server AZDAVE Linux - Security 3 07-07-2004 12:03 PM
Proxy web server RH9 deWin Linux - Software 4 04-26-2004 05:23 PM
setting up proxy in Konqueror web browser ako Linux - Networking 4 02-10-2004 07:07 PM
setting up proxy in Konqueror web browser ako Linux - Newbie 1 02-07-2004 09:11 AM


All times are GMT -5. The time now is 09:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration