LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-13-2002, 06:05 AM   #1
kenviro
LQ Newbie
 
Registered: May 2002
Posts: 3

Rep: Reputation: 0
problem seeing Samba server from Windows machines


Hello everyone.

I hope someone can help me with this. I am currently having problem getting my Windows machines (Windows 98 and 2000) to see my Samba server in Network Neighborhood or My Network Places. I have configured encrypted passwords on my Samba Server. I have configured my Samba server to be in the same workgroup as the Windows machines. The physical network connection is okay.

The name of the Samba server is linuxking and when I type "\\linuxking" on my Windows machines, I get the message "\\linuxking is not accessible
The account is not authorized to log in from this station". This should not be happening because I have the same account of "kingsley" on my Windows 2000 machine as well as in the Samba server, and the passwords are the same too.

I can use 'smbclient' to access shared folders on my Windows machines. On my Windows 2000 machine, I would type in 'smbclient //nb-kingsley/c -U kingsley' and then enter a password, I would able to access the C drive on my Windows 2000 machine.

So, if anyone can tell me or give me an idea why I can get my Windows machines to see my Samba server, I would appreciate that.


Kingsley Yong
 
Old 05-13-2002, 08:29 AM   #2
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
Are you sure the workgroup names are exactly the same? And if you made any changes to smb.conf did you restart smbd, nmbd?
 
Old 05-13-2002, 01:32 PM   #3
Sylhouette
Member
 
Registered: Oct 2001
Location: Beverwijk (Holland
Distribution: Red Hat 7.1
Posts: 132

Rep: Reputation: 15
Did you do:
smbpasswd -a username
on the linux machine
 
Old 05-13-2002, 11:20 PM   #4
kenviro
LQ Newbie
 
Registered: May 2002
Posts: 3

Original Poster
Rep: Reputation: 0
Thank you for the tips.I have made some progress, but not quite there yet.

By the way, my LAN of some 10 computers has the IP address of 192.168.10.

The workgroup names are exactly the same alright. The reason why my Samba server was not visible in 'My network places' was because I did not configure under the global settings, the "Configure remote browse list synchronisation here" and "Cause this host to announce itself to local subnets here". I have changed that and have restarted smbd and nmbd.

Okay, now I'm able to see the linuxking Samba server on 'My Network places'. However, I'm still not able to access the resources on the Samba server. I still get the message "\\Linuxking is not accessible. The account is not authorized to log in from this station".

And yes, I did use 'smbpasswd -a <username>' and made sure I added the same username that I used in my Windows machines.

And I did make sure that the hosts allow has 192.168.10.

This is how my /etc/smb.conf look like:


#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = asdionsg

# server string is the equivalent of the NT Description field
server string = Samba Server

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
; hosts allow = 192.168.1. 192.168.2. 192.168.10. 192.168.11. 127.


# Security mode. Most people will want user level security. See
# security_level.txt for details.
security = user
# Use password server option only with security = server
; password server = <NT-Server-Name>

# Password Level allows matching of _n_ characters of the password for
# all combinations of upper and lower case.
; password level = 8
; username level = 8

# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
; encrypt passwords = yes
; smb passwd file = /home/smbpasswd

# The following are needed to allow password changing from Windows to
# update the Linux sytsem password also.
# NOTE: Use these with 'encrypt passwords' and 'smb passwd file' above.
# NOTE2: You do NOT need these to allow workstations to change only
# the encrypted SMB passwords. They allow the Unix password
# to be kept in sync with the SMB password.
; unix password sync = Yes
; passwd program = /usr/bin/passwd %u
; passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*

# Unix users can map to different SMB User names
; username map = /etc/smbusers

# Configure remote browse list synchronisation here
# request announcement to, or browse list sync from:
# a specific host or from / to a whole subnet (see below)
; remote browse sync = 192.168.3.25 192.168.10.255
# Cause this host to announce itself to local subnets here
; remote announce = 192.168.10.255 192.168.2.44

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
; local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
; os level = 33
 
Old 05-14-2002, 03:07 AM   #5
jayakrishnan
Member
 
Registered: Feb 2002
Location: India
Distribution: Slacky 12.1, XP
Posts: 991

Rep: Reputation: 30
Uncoment the following line

; encrypt passwords = yes
; smb passwd file = /home/smbpasswd
 
Old 05-15-2002, 04:44 AM   #6
kenviro
LQ Newbie
 
Registered: May 2002
Posts: 3

Original Poster
Rep: Reputation: 0
Okay, I have more or less solved the puzzle, mostly from reading the book 'Samba Unleashed'.

You should make sure that the Samba server is in the same workgroup or same domain that your LAN is located in. In my case, I have a Windows 2000 domain called 'timblet.com' and my domain controller is timbletserver1. In Windows NT or 2000 Server, you need to add the Samba server into your domain. in Windows 2000, go to Active Directory Users and Computers and under your domain, go to 'Computers'. Right click and select "New, Computer" from pop-up menu. The New Object - Computer window will appear and you add the name of your Samba Server (linuxking in my case) to both "Computer name" and "Computer name (pre-Windows 2000)" and check the box for "Allow pre-Windows 2000 computers to use this account".
Then you got to join the Samba server to the domain. I typed "smbpasswd -j timblet.com -r timbletserver1" (you probably have to make sure that your /etc/hosts and /etc/lmhosts files contain the right address mappings. If you joined the domain successfully, which I did, you should get the message something like:

smbpasswd: Joined domain timblet.com

It wouldn't be a bad idea to specify the parameter 'netbios name = linuxking' in the Global settings, though I don't think it is truly necessary.

One of the most important settings to ensure that your client can access the Samba server successfully is the 'security' parameter.
For me, I used 'security = server' and then 'password server = timbletserver1'. The first parameter means that all the authentication is done by the domain controller server (in this case timbletserver1), probably rightly so because timbletserver1 is the domain controller for all the machines on the LAN. So, Samba will now not do any authentication. You will now not need to have an account in the Samba server at all. As long as your username is in the domain controller, you can access the resources on the Samba server.

Encrypt passwords for me will be set to yes. My remote announce is 192.168.10.255. By the way, I did not know that the semi colon means that the line is commented. I only thought that the pound sign means that the line is commented.

After all the changes to /etc/smb.conf, restart smb.

I am now able to browse the linuxking in "My Network places" and see all the shares available. However, there is still a slight problem. While I can access the shares, see the files and can copy files from the Samba server over to my Windows 2000 Pro computer by drag and drop, I am unable to copy files to the Samba server.

Let's say I want to copy a text file called simple.txt to the root directory of the Samba server by drag and drop. However, it will give me the message "Cannot copy simple.txt: Access is denied. The source file may be in use". I can assure you that the simple.txt file in not in use so it is not an issue here.

Can someone please enlighten me as how to solve this problem?


Kingsley
 
Old 05-15-2002, 08:39 AM   #7
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
you may need to change permissions on the share so that people can write to it.
do: man chmod

Last edited by hanzerik; 05-15-2002 at 08:41 AM.
 
Old 05-20-2002, 06:19 AM   #8
shamim
LQ Newbie
 
Registered: May 2002
Posts: 3

Rep: Reputation: 0
shamim
190, kathalbagan
dhaka,bangladesh
 
Old 08-17-2003, 02:54 PM   #9
DingleBerry420
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat 9
Posts: 5

Rep: Reputation: 0
Hi there,

I am having the same problem the guy above did, I can view the share from my win2k box, browse and copy from. But I cannot copy too, and I also cannot start a session from the linux box. from the linux box it says error connection to 192.168.0.100 (operation already in progress).

This is a small home network with no DNS, I have the samba set to be a WINS servers and my 2k box set to gets wins from the linuxbox IP. I did the smbpasswd -a deal and I modifed the folder security by right clicking on the folder that's shared and allowing all users to read/write. no luck, I'm thinking my main problem is that I cannot inniate a session from the linux box. I will post my smb.conf next.. Thanks
 
Old 08-17-2003, 02:59 PM   #10
DingleBerry420
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat 9
Posts: 5

Rep: Reputation: 0
smb.conf

[global]
log file = /var/log/samba.log
netbios name = linuxuser
server string = linuxbox
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
path = /dload
workgroup = PARTYHOUSE
os level = 20
encrypt passwords = yes
security = user
preferred master = no
wins support = true

[disks]
path = /dload
guest ok = yes
writeable = yes
browseable = yes
public = yes

[stuff]

*one last note, when I browse the share from win2k, it doesn't ask me for a username/pw?
 
Old 08-17-2003, 10:40 PM   #11
DingleBerry420
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat 9
Posts: 5

Rep: Reputation: 0
chmod?

Quote:
Originally posted by hanzerik
you may need to change permissions on the share so that people can write to it.
do: man chmod
I ran that and read the doc, is that for setting file permissions only? or will it work for folders too?
 
Old 08-18-2003, 01:04 AM   #12
daemon_14
Member
 
Registered: Jul 2003
Location: Mesa, AZ
Distribution: CentOS 5 (Cisco Apps), Ubuntu Server (8.10), Ubuntu Desktop (8.10)
Posts: 46

Rep: Reputation: 15
chmod will work for both folders and files. make sure that the user you are working with has access to an administrative or root account. if you are not worried about security over shares, you might just want a share-level share with the default user as root and no password authentication. its the easiest way to avoid having to enter all of the users and such.

daemon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba on fedora connects to linux machine but unseen on windows machines vyom Linux - Networking 5 07-04-2006 03:25 AM
Windows machines not seeing linux server from a new subnet nkeever Linux - Networking 3 04-29-2005 02:51 PM
Samba shares and windows machines lacitpo Linux - Software 2 02-26-2005 01:56 AM
Nautilus SAMBA and Windows Machines b3<k Linux - Networking 6 06-17-2004 03:16 AM
Connecting Windows Machines to Redhat 7.3 Server jwithers1 Linux - Networking 2 08-05-2002 03:16 PM


All times are GMT -5. The time now is 06:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration