LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-28-2012, 05:10 PM   #1
donalbane
LQ Newbie
 
Registered: Jan 2011
Location: Austin, TX
Posts: 29

Rep: Reputation: 2
Question problem assigning two default routes on separate routing tables in Debian


I have a computer with a single static ethernet interface and a single cellular modem point-to-point interface:

tcors01:~# ifconfig ppp0
ppp0 Link encap:Point-to-Point Protocol
inet addr:32.176.37.1 P-t-P:192.168.111.111 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1

tcors01:~# ifconfig eth2
eth2 Link encap:Ethernet
inet addr:129.116.XXX.27 Bcast:129.116.XXX.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

I attempted to follow a modified combination of these two procedures to create separate routing tables and default routes for each interface:

http://www.debian-administration.org...Policy_routing
http://kindlund.wordpress.com/2007/1...utes-in-linux/

However, when ppp0 is up, "ping -I ppp0 8.8.8.8" from the firewall gets a response, but "ping -I eth2 8.8.8.8" does not. If I bring ppp0 down, I do get a ping response from eth2. Can anyone see what I need to change to be able to ping out of either interface when both are up?

tcors01:~# ip route show
192.168.111.111 dev ppp0 proto kernel scope link src 32.176.37.1
129.116.XXX.0 dev eth2 scope link src 129.116.XXX.27
tcors01:~# ip route show table lan
129.116.XXX.0 dev eth2 scope link src 129.116.XXX.27
default via 129.116.XXX.254 dev eth2
tcors01:~# ip route show table cell
192.168.111.111 dev ppp0 scope link src 32.176.37.1
default via 192.168.111.111 dev ppp0

tcors01:~# ip rule show
0: from all lookup local
100: from all fwmark 0x1 lookup lan
200: from all fwmark 0x2 lookup cell
32764: from 32.176.37.1 lookup cell
32765: from 129.116.XXX.27 lookup lan
32766: from all lookup main
32767: from all lookup default

tcors01:~# iptables -t mangle -v -L
Chain OUTPUT (policy ACCEPT 169 packets, 15548 bytes)
pkts bytes target prot opt in out source destination

84 6924 MARK all -- any eth2 anywhere anywhere
MARK set 0x1
32 2688 MARK all -- any ppp0 anywhere anywhere
MARK set 0x2

Don
 
Old 03-29-2012, 02:48 AM   #2
nikmit
Member
 
Registered: May 2011
Location: Nottingham, UK
Distribution: Debian
Posts: 178

Rep: Reputation: 34
You are marking on the way out of the firewall, regardless of the source or other characteristics of the traffic.
So once the traffic is already at eth2 or ppp0, it gets marked. The routing decision has to happen before an outgoing interface is chosen so this is not a good solution.

As you don't have a default route in the main table, the first routing table that does have a default route is used, which is the cell table. (edit: this is not correct)
The ping -I command specifies the source address to be used for the ping rather than the outgoing interface - this is a bit misleading. (edit: it seems to do both actually) So when you do 'ping -I eth2' with ppp0 up you are most likely sending pings with eth2 source out the ppp0 interface, and the host at the other end doesn't know how to return the replies. When you bring the ppp0 interface down, the pings go out of the correct interface for the source IP specified and get replies.

Last edited by nikmit; 04-04-2012 at 06:13 AM. Reason: correcting mistakes for the benefit of any readers
 
1 members found this post helpful.
Old 03-29-2012, 02:01 PM   #3
donalbane
LQ Newbie
 
Registered: Jan 2011
Location: Austin, TX
Posts: 29

Original Poster
Rep: Reputation: 2
Thank you for your reply.

Quote:
Originally Posted by nikmit View Post
As you don't have a default route in the main table, the first routing table that does have a default route is used, which is the cell table.
I set up a single routing table for a single interface as follows:

tcors01:~# ip route show
129.116.XXX.0 dev eth2 scope link src 129.116.XXX.27
tcors01:~# ip route show table lan
129.116.XXX.0 dev eth2 scope link src 129.116.XXX.27
default via 129.116.XXX.254 dev eth2
tcors01:~# ip rule show
0: from all lookup local
32765: from 129.116.XXX.27 lookup lan
32766: from all lookup main
32767: from all lookup default

With this configuration, "ping 8.8.8.8" returns a "No route to host" error, while "ping -I eth2 8.8.8.8" works normally. This seems to show that if there is not a default route in the main table, then NO OTHER routing table will be used unless the source interface is specified. That is what I want. However, if I add similar routes/rules for ppp0, "ping -I eth2 8.8.8.8" no longer works (ping -I ppp0 8.8.8.8 does).

Quote:
Originally Posted by nikmit View Post
You are marking on the way out of the firewall, regardless of the source or other characteristics of the traffic. So once the traffic is already at eth2 or ppp0, it gets marked. The routing decision has to happen before an outgoing interface is chosen so this is not a good solution.
It was my understanding that in order to route traffic that originates in the firewall computer out through a particular interface, I would have to use firewall marks, but you are saying that the routing to the interface happens before the marking. This post http://kindlund.wordpress.com/2007/1...x/#comment-133 indicates that it is possible to ping out of each interface with the -I option without having a default route in the main table, but I tried the same setup and observed the above behavior. How does one route traffic from the firewall out a particular interface without specifying a default route in the main table?

Don
 
1 members found this post helpful.
Old 03-30-2012, 06:17 AM   #4
nikmit
Member
 
Registered: May 2011
Location: Nottingham, UK
Distribution: Debian
Posts: 178

Rep: Reputation: 34
I will try to set up a quick lab over the weekend and test this out.

Here is some info that you might find helpful, even if it seems to deal with through traffic rather than locally sourced.

Last edited by nikmit; 03-30-2012 at 08:38 AM.
 
Old 03-30-2012, 09:17 AM   #5
WizadNoNext
Member
 
Registered: Nov 2009
Posts: 125

Rep: Reputation: 9
You clearly misunderstood meaning of default route. Default route is route for anything else then stated explicitly. If you do not have any route to 8.8.8.8 on interface (lest say ppp0), then you box won't know, that 8.8.8.8 is reachable by such interface (ppp0).
I didn't do any load-balancing or multiple connections to same place (like internet connection on more then one interface), so I won't be any good help here, but I do understand problem, just don't know solution.
 
Old 04-02-2012, 11:45 AM   #6
donalbane
LQ Newbie
 
Registered: Jan 2011
Location: Austin, TX
Posts: 29

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by WizadNoNext View Post
You clearly misunderstood meaning of default route. Default route is route for anything else then stated explicitly. If you do not have any route to 8.8.8.8 on interface (lest say ppp0), then you box won't know, that 8.8.8.8 is reachable by such interface (ppp0).
I DO have default routes for each interface (to the their gateways, and therefore to 8.8.8.8) on their respective routing tables, just not the MAIN routing table.
 
Old 04-02-2012, 05:46 PM   #7
donalbane
LQ Newbie
 
Registered: Jan 2011
Location: Austin, TX
Posts: 29

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by nikmit View Post
I will try to set up a quick lab over the weekend and test this out.
Thanks. Any luck?

Quote:
Originally Posted by nikmit View Post
Here is some info that you might find helpful, even if it seems to deal with through traffic rather than locally sourced.
Yes. I've used that link. I'm essentially doing the exact same thing, except without the default route defined in the main table. However, even when I add the default route to the main table, if ppp0 is up and I put the default route to eth0, I can't ping out from the firewall doing either "ping 8.8.8.8" or "ping -I eth2 8.8.8.8".
 
Old 04-03-2012, 02:29 AM   #8
nikmit
Member
 
Registered: May 2011
Location: Nottingham, UK
Distribution: Debian
Posts: 178

Rep: Reputation: 34
What are you trying to do? Is it possible that the longer prefix on the ppp0 interface influences routing?

Could you dump arp and icmp during the pings? Anything interesting in /var/log/kern.log or /var/log/syslog?

Last edited by nikmit; 04-03-2012 at 03:24 AM.
 
Old 04-03-2012, 11:46 AM   #9
donalbane
LQ Newbie
 
Registered: Jan 2011
Location: Austin, TX
Posts: 29

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by nikmit View Post
What are you trying to do?
I am trying to set up two interfaces to separate ISPs as described in the Split Access section of http://lartc.org/howto/lartc.rpdb.multiple-links.html, only I am not supplying a default route on the main table, since traffic will be specifically routed out the desired interface. As mentioned above, however, I have the same problem, even if I add a default route on the main table. One of my interfaces is point-to-point, so I may be making a mistake in how that interface is set up since the $P2_NET and $P2 are the same in that case.

Quote:
Originally Posted by nikmit View Post
Is it possible that the longer prefix on the ppp0 interface influences routing?
I don't understand to what you are referring.

Quote:
Originally Posted by nikmit View Post
Could you dump arp and icmp during the pings? Anything interesting in /var/log/kern.log or /var/log/syslog?
The only things in /var/log/kern.log and /var/log/syslog were the messages about promiscuous mode turning on and off when I ran tcpdump. I dumped icmp and arp to separate files for each interface (replacing IP addresses with strings):

tcors01:~# ping -I eth2 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from ETH2_IP eth2: 56(84) bytes of data.
From ETH2_IP icmp_seq=1 Destination Host Unreachable
From ETH2_IP icmp_seq=2 Destination Host Unreachable
From ETH2_IP icmp_seq=3 Destination Host Unreachable

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3008ms, pipe 3

There was nothing for icmp on either interface:

tcors01:~# tcpdump -r /root/eth2_icmp.log
reading from file /root/eth2_icmp.log, link-type EN10MB (Ethernet)
tcors01:~# tcpdump -r /root/ppp0_icmp.log
reading from file /root/ppp0_icmp.log, link-type LINUX_SLL (Linux cooked)

For arp, there was nothing on the ppp0 interface (as expected), and the eth2 interface was not illuminating (to me, anyway):

tcors01:~# tcpdump -r /root/ppp0_arp.log
reading from file /root/ppp0_arp.log, link-type LINUX_SLL (Linux cooked)
tcors01:~# tcpdump -r /root/eth2_arp.log
reading from file /root/eth2_arp.log, link-type EN10MB (Ethernet)
16:20:12.813304 ARP, Request who-has 8.8.8.8 tell ETH2_IP, length 28
16:20:13.813191 ARP, Request who-has 8.8.8.8 tell ETH2_IP, length 28
16:20:14.812982 ARP, Request who-has 8.8.8.8 tell ETH2_IP, length 28

If I instead attempt to ping out ppp0, I see normal echo requests/replies from ppp0:

tcors01:~# ping -I ppp0 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from PPP0_IP ppp0: 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=46 time=712 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=46 time=429 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=47 time=329 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=47 time=329 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=46 time=329 ms

--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4001ms
rtt min/avg/max/mdev = 329.949/426.393/712.074/147.997 ms

tcors01:~# tcpdump -r /root/eth2_icmp.log
reading from file /root/eth2_icmp.log, link-type EN10MB (Ethernet)
tcors01:~# tcpdump -r /root/ppp0_icmp.log
reading from file /root/ppp0_icmp.log, link-type LINUX_SLL (Linux cooked)
16:27:35.631372 IP PPP0_IP > 8.8.8.8: ICMP echo request, id 25093, seq 1,length 64
16:27:36.343158 IP 8.8.8.8 > PPP0_IP: ICMP echo reply, id 25093, seq 1, length 64
16:27:36.633276 IP PPP0_IP > 8.8.8.8: ICMP echo request, id 25093, seq 2,length 64


I didn't want to dump a bunch of stuff and cause people's eyes to glaze over, but for the record, here is how I have things set up:

tcors01:~# ifconfig ppp0
ppp0 Link encap:Point-to-Point Protocol
inet addr:PPP0_IP P-t-P:PPP0_GW Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:64 (64.0 B) TX bytes:97 (97.0 B)
tcors01:~# ifconfig eth2
eth2 Link encap:Ethernet HWaddr 00:d0:69:45:19:95
inet addr:ETH2_IP Bcast:129.116.134.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2131 errors:0 dropped:0 overruns:0 frame:0
TX packets:562 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1607150 (1.5 MiB) TX bytes:68764 (67.1 KiB)
Interrupt:40 Base address:0x240

tcors01:~# netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
PPP0_GW * 255.255.255.255 UH 0 0 0 ppp0
ETH2_NET * 255.255.255.0 U 0 0 0 eth2

tcors01:~# ip route show
PPP0_GW dev ppp0 proto kernel scope link src PPP0_IP
ETH2_NET/24 dev eth2 proto kernel scope link src ETH2_IP

tcors01:~# ip route add ETH2_NET/24 dev eth2 src ETH2_IP table lan
tcors01:~# ip route add default via ETH2_GW table lan
tcors01:~# ip route add PPP0_GW dev ppp0 src PPP0_IP table cell
tcors01:~# ip route add default via PPP0_GW table cell

tcors01:~# ip route show table lan
ETH2_NET/24 dev eth2 scope link src ETH2_IP
default via ETH2_GW dev eth2

tcors01:~# ip route show table cell
PPP0_GW dev ppp0 scope link src PPP0_IP
default via PPP0_GW dev ppp0

tcors01:~# ip rule add from ETH2_IP table lan
tcors01:~# ip rule add from PPP0_IP table cell
tcors01:~# ip rule show
0: from all lookup local
32764: from PPP0_IP lookup cell
32765: from ETH2_IP lookup lan
32766: from all lookup main
32767: from all lookup default

Last edited by donalbane; 04-03-2012 at 11:53 AM. Reason: forgot to answer entire question
 
Old 04-04-2012, 02:49 AM   #10
nikmit
Member
 
Registered: May 2011
Location: Nottingham, UK
Distribution: Debian
Posts: 178

Rep: Reputation: 34
Quote:
Originally Posted by donalbane View Post
... traffic will be specifically routed out the desired interface. ...
This is what eludes me - is the traffic sourced entirely by the router or do you have external clients?

Quote:
Originally Posted by donalbane View Post
I don't understand to what you are referring.
I didn't put it right probably, if I give an example it should help: If you have two routes to host 192.168.0.2, one pointing to 192.168.0.0/24 and a second to 192.168.0.2/32 the second will be used as it is the one with the longest prefix.

Quote:
Originally Posted by donalbane View Post
0: from all lookup local
32764: from PPP0_IP lookup cell
32765: from ETH2_IP lookup lan
32766: from all lookup main
32767: from all lookup default
This brings me back to the first point above. If you have external clients, they should be sorted at the ingress interface not on the way out. If it is a server which doesn't have any other connections then I suspect some work with loopback interfaces might help, or application specific options might be available. In the rules above, traffic comming from ppp0 will be destined to the router or to clients on lets say eth0. In both cases it shouldn't need to look at the routes in table cell?

Edit: I mixed up interface names with interface IPs above and it gets confusing. Bottom line is, if you are handling traffic from local network clients, handle it with a rule on the inbound interface.
If the machine is a standalone server, the set up will depend on the applications running and what configuration opptions are available. Policy routing might not be needed at all - I am able to ping out both interfaces (one configured as /30 and the other as /24) with only a single basic default route for the /24 gateway.

Last edited by nikmit; 04-04-2012 at 06:09 AM. Reason: Clarify on the last point
 
Old 04-04-2012, 09:43 AM   #11
donalbane
LQ Newbie
 
Registered: Jan 2011
Location: Austin, TX
Posts: 29

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by nikmit View Post
This is what eludes me - is the traffic sourced entirely by the router or do you have external clients?
Eventually, there will be a local network coming off of the firewall computer that will have traffic routed from it out one of the external interfaces. However, for the moment, all traffic is sourced entirely by the firewall/router computer. This is because external interfaces will be periodically brought up and down and tested by the firewall/router for useability before traffic is routed from the local network.

Quote:
Originally Posted by nikmit View Post
This brings me back to the first point above. If you have external clients, they should be sorted at the ingress interface not on the way out.
Yes. My problem is that there is no ingress interface when the traffic originates on the firewall/router computer.

Quote:
Originally Posted by nikmit View Post
If it is a server which doesn't have any other connections then I suspect some work with loopback interfaces might help, or application specific options might be available.
At the end of the http://lartc.org/howto/lartc.rpdb.multiple-links.html section on Split Access it mentions a comment from a reader where adding loopback routes to the separate routing tables would be helpful. I don't have the configuration mentioned (yet) with a local network, so I couldn't duplicate the example verbatim, but I did try adding the loopback routes to my lan and cell routing tables. There was no change in behavior.

Quote:
Originally Posted by nikmit View Post
In the rules above, traffic comming from ppp0 will be destined to the router or to clients on lets say eth0. In both cases it shouldn't need to look at the routes in table cell?
That is my understanding as well. If traffic comes from ppp0, it should go to the firewall/router. That is what I want. The problem is how to make traffic FROM the firewall/router go TO ppp0 (or eth2). I thought that firewall marking was required for this originally (see http://www.debian-administration.org...Policy_routing), but that did not work either.

Quote:
Originally Posted by nikmit View Post
Policy routing might not be needed at all - I am able to ping out both interfaces (one configured as /30 and the other as /24) with only a single basic default route for the /24 gateway.
But, that sounds like both of your interfaces are on the same subnet. Can you ping out of either interface when they are on separate external networks?
 
Old 04-04-2012, 09:53 AM   #12
nikmit
Member
 
Registered: May 2011
Location: Nottingham, UK
Distribution: Debian
Posts: 178

Rep: Reputation: 34
Quote:
Originally Posted by donalbane View Post
But, that sounds like both of your interfaces are on the same subnet. Can you ping out of either interface when they are on separate external networks?
Yes.
Code:
root@fw2:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:30:05:8a:64:30  
          inet addr:192.168.8.101  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::230:5ff:fe8a:6430/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth1      Link encap:Ethernet  HWaddr 00:10:a7:0a:bb:1b  
          inet addr:192.168.4.6  Bcast:192.168.4.7  Mask:255.255.255.252
          inet6 addr: fe80::210:a7ff:fe0a:bb1b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

root@fw2:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.4.4     *               255.255.255.252 U     0      0        0 eth1
192.168.8.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.8.1     0.0.0.0         UG    0      0        0 eth0

root@fw2:~# ip rule show
0:      from all lookup local 
32766:  from all lookup main 
32767:  from all lookup default

root@fw2:~# ping -I eth0 4.2.2.2
PING 4.2.2.2 (4.2.2.2) from 192.168.8.101 eth0: 56(84) bytes of data.
64 bytes from 4.2.2.2: icmp_req=1 ttl=245 time=129 ms
64 bytes from 4.2.2.2: icmp_req=2 ttl=245 time=38.6 ms
^C
--- 4.2.2.2 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 38.649/84.054/129.459/45.405 ms
root@fw2:~# ping -I eth1 4.2.2.2
PING 4.2.2.2 (4.2.2.2) from 192.168.4.6 eth1: 56(84) bytes of data.
64 bytes from 4.2.2.2: icmp_req=1 ttl=244 time=85.9 ms
64 bytes from 4.2.2.2: icmp_req=2 ttl=244 time=216 ms
^C
--- 4.2.2.2 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 85.919/151.272/216.625/65.353 ms
And I did run tcpdump on the interfaces to make sure the packets are exiting where I think they are.
 
Old 04-09-2012, 10:06 AM   #13
donalbane
LQ Newbie
 
Registered: Jan 2011
Location: Austin, TX
Posts: 29

Original Poster
Rep: Reputation: 2
That's very interesting. I attempted the same setup, only using one point-to-point connection and one Ethernet connection, instead of 2 Ethernet connections:

tcors01:~# ifconfig eth2
eth2 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:XX
inet addr:129.116.134.27 Bcast:129.116.134.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
tcors01:~# netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
129.116.XXX.0 0.0.0.0 255.255.255.0 U 0 0 0 eth2
0.0.0.0 129.116.XXX.254 0.0.0.0 UG 0 0 0 eth2
tcors01:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=48 time=31.7 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=48 time=28.5 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=48 time=28.5 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=48 time=28.5 ms

Bring up the ppp0 interface:
tcors01:~# pon att
tcors01:~# ifconfig ppp0
ppp0 Link encap:Point-to-Point Protocol
inet addr:32.176.62.131 P-t-P:192.168.111.111 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
tcors01:~# netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.111.111 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
129.116.XXX.0 0.0.0.0 255.255.255.0 U 0 0 0 eth2
0.0.0.0 129.116.XXX.254 0.0.0.0 UG 0 0 0 eth2
tcors01:~# ip rule show
0: from all lookup local
32766: from all lookup main
32767: from all lookup default

tcors01:~# ping -I ppp0 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from 32.176.62.131 ppp0: 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=46 time=1701 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=47 time=719 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=46 time=319 ms
tcors01:~# ping -I eth2 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from 129.116.134.27 eth2: 56(84) bytes of data.
From 129.116.134.27 icmp_seq=1 Destination Host Unreachable
From 129.116.134.27 icmp_seq=2 Destination Host Unreachable
From 129.116.134.27 icmp_seq=3 Destination Host Unreachable

Traceroute on eth2 gives me nothing until I bring ppp0 down:
tcors01:~# traceroute -i eth2 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 40 byte packets
1 * * *
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *
tcors01:~# poff att
tcors01:~# traceroute -i eth2 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 40 byte packets
1 arl2-to-prc.arlut.utexas.edu (129.116.134.254) 0.621 ms 0.526 ms 0.516 ms
2 ser10-v758.gw.utexas.edu (128.83.10.29) 1.268 ms 1.257 ms 1.189 ms
3 ser2-gi1-9.gw.utexas.edu (128.83.10.2) 1.466 ms 1.228 ms 1.236 ms
4 aust-utnoc-core-ge-6-0-0-0.tx-bb.net (192.12.10.1) 1.266 ms 1.264 ms 1.53
8 ms
5 iah-edge-18.inet.qwest.net (67.132.154.153) 7.228 ms 7.251 ms 7.183 ms
6 atx-edge-03.inet.qwest.net (67.14.14.142) 94.690 ms 29.280 ms 29.286 ms
7 65.112.32.218 (65.112.32.218) 27.461 ms 27.500 ms 27.506 ms
8 72.14.233.56 (72.14.233.56) 27.797 ms 72.14.233.54 (72.14.233.54) 27.880 m
s 72.14.233.56 (72.14.233.56) 27.710 ms
9 66.249.94.6 (66.249.94.6) 28.291 ms 66.249.94.20 (66.249.94.20) 28.163 ms
66.249.94.6 (66.249.94.6) 28.281 ms
10 209.85.248.29 (209.85.248.29) 27.910 ms 28.075 ms 209.85.248.53 (209.85.24
8.53) 28.318 ms
11 209.85.253.133 (209.85.253.133) 30.210 ms 29.617 ms 209.85.253.141 (209.85
.253.141) 40.695 ms
12 google-public-dns-a.google.com (8.8.8.8) 28.424 ms 28.506 ms 28.419 ms

Is there some reason that having a direct-to-host route in the routing table would cause the default gateway to be ignored?

Don

Last edited by donalbane; 04-09-2012 at 10:07 AM. Reason: typo and clarification
 
  


Reply

Tags
debian, default route, multiple, routing, tables


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
quagga, bgp default routes not installed in linux routing table saiyen2002 Linux - Networking 0 12-08-2010 03:12 PM
2 routes to 2 WANs - separate applications how? salmonix Linux - Networking 4 12-03-2009 04:43 AM
Problem assigning default gateway to clients through dhcpd (ubuntu) milpoer Linux - Networking 2 04-16-2009 08:05 AM
Static routes using routes/ifroutes-eth-id.. files and default gateway disabled TimtheEagle Linux - Networking 0 05-31-2008 07:08 PM
How do I save my routes and routing tables? debloxie Linux - Networking 2 07-24-2006 02:25 AM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration