LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 05-25-2007, 10:41 AM   #1
Badfish
LQ Newbie
 
Registered: Aug 2002
Location: So-Cal
Distribution: RedHat 9.0
Posts: 27

Rep: Reputation: 15
Privoxy refusing connections


Hello all,
I am running Fedora Core 6 and I just installed Tor ( Tor v0.1.1.26. 'came with fedora install) and Privoxy (privoxy-3.0.6-0.fc6.i386.rpm). I then read the install information
on the TOR site (http://tor.eff.org/docs/tor-doc-unix.html.en)

I then edit the config file as per the instructions.
/etc/privoxy/config

I add the following line to the config file:
forward-socks4a / 127.0.0.1:9050 .

I then start both tor and privoxy.
they both start with no problem.

I then installed the firefox torbutton, installs correctly
and I am able to see it on the toolbar and I can enable tor.

However, when i go to the browser and try to surf I get the
following error message:

The proxy server is refusing connection:
Firefox is configured to use a proxy server that is refusing connection



thanks in advance.
 
Old 05-25-2007, 11:37 AM   #2
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Personally, I've never had any luck using any kind of gui for tor and privoxy. I usually just start everything from the command line. Then just edit the connections in whatever browser I'm using.
 
Old 05-25-2007, 12:02 PM   #3
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
FAQ from tor site

4.1. I installed Tor and Privoxy but it's not working.

[link]
Are you sure Tor and Privoxy are both running? If you're using Vidalia, you may have to click on the onion and select "Start" to launch Tor.
Did you configure your web browser to http proxy to port 8118? Most people should do this simply by installing Torbutton and making sure it says "Tor enabled" at the bottom.
Check your Tor logs. Do they give you any hints about what's going wrong?
Check your system clock. If it's more than a few hours off, Tor will refuse to build circuits. For XP users, synchronize your clock under the clock -> Internet time tab. In addition, correct the day and date under the 'Date & Time' Tab.
Is your Internet connection firewalled, or do you normally need to use a proxy? Are you running programs like Norton Internet Security that block certain connections, even though you don't realize they do?
If you installed Privoxy yourself (not from a bundle), did you edit the Privoxy config file as described? Did you remember to put the "." at the end of the Privoxy config line? Did you accidentally comment the config line out? Did you restart Privoxy after this change?
For Red Hat Linux and related systems, do you have SELinux enabled? If so, it might be preventing Privoxy from talking to Tor. We also run across BSD users periodically who have local firewall rules that prevent some connections to localhost.
When it's working, Tor should report that it 'has successfully opened a circuit. Looks like client functionality is working.'

Specifically, look at the part about RedHat and SELinux.
 
Old 05-25-2007, 01:07 PM   #4
Badfish
LQ Newbie
 
Registered: Aug 2002
Location: So-Cal
Distribution: RedHat 9.0
Posts: 27

Original Poster
Rep: Reputation: 15
Are you sure Tor and Privoxy are both running? If you're using Vidalia, you may have to click on the onion and select "Start" to launch Tor.

I installed and start both tor and privoxy from command line, and they are infact running.

Did you configure your web browser to http proxy to port 8118? Most people should do this simply by installing Torbutton and making sure it says "Tor enabled" at the bottom.

Yes, I did install the torbutton and when I check the http proxy it is set to 8118


(FireFox connection setting set my torbutton)
http proxy : 8118
ssl proxy : 8118
socks host : 9050
no proxy for : localhost, 127.0.0.1



Check your Tor logs. Do they give you any hints about what's going wrong?

There is nothing in the /var/log/tor directory.

Check your system clock. If it's more than a few hours off, Tor will refuse to build circuits. For XP users, synchronize your clock under the clock -> Internet time tab. In addition, correct the day and date under the 'Date & Time' Tab.

Yes the time is correct, no I am not running XP. I am using fedora core 6

Is your Internet connection firewalled, or do you normally need to use a proxy? Are you running programs like Norton Internet Security that block certain connections, even though you don't realize they do?

I am using iptables as a firewall, do I need to add 8118 9050 tcp to the rules??

If you installed Privoxy yourself (not from a bundle), did you edit the Privoxy config file as described? Did you remember to put the "." at the end of the Privoxy config line? Did you accidentally comment the config line out? Did you restart Privoxy after this change?

No I configured the /etc/privoxy/config file as per the directions.

For Red Hat Linux and related systems, do you have SELinux enabled? If so, it might be preventing Privoxy from talking to Tor.

No, SElinux is disabled

We also run across BSD users periodically who have local firewall rules that prevent some connections to localhost.
When it's working, Tor should report that it 'has successfully opened a circuit. Looks like client functionality is working.'


# service tor start
Starting /usr/bin/tor: May 25 09:53:37.068 [notice] Tor v0.1.1.26. This is experimental software. Do not rely on it for strong anonymity.
May 25 09:53:37.095 [notice] Initialized libevent version 1.1a using method epoll. Good.
May 25 09:53:37.122 [notice] connection_create_listener(): Opening Socks listener on 127.0.0.1:9050

# service privoxy start
Starting privoxy: May 25 09:54:12 Privoxy(b7ee7ac0) Info: loading configuration file '/etc/privoxy/config':
May 25 09:54:12 Privoxy(b7ee7ac0) Info: Privoxy version 3.0.6
May 25 09:54:12 Privoxy(b7ee7ac0) Info: Program name: /usr/sbin/privoxy
May 25 09:54:12 Privoxy(b7ee7ac0) Info: Listening on port 8118 on IP address 71.xxx.xxx.xxx
 
Old 05-25-2007, 01:09 PM   #5
Badfish
LQ Newbie
 
Registered: Aug 2002
Location: So-Cal
Distribution: RedHat 9.0
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by manwichmakesameal
Personally, I've never had any luck using any kind of gui for tor and privoxy. I usually just start everything from the command line. Then just edit the connections in whatever browser I'm using.


By "Then just edit the connections in whatever browser I'm using."
Do you mean the proxy settings in the browser??
 
Old 05-25-2007, 04:13 PM   #6
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Yes, just edit the proxy connections. AFAIK, the firefox torbutton just changes you from a direct connection to the internet to using the proxy settings for tor and privoxy.

Last edited by manwichmakesameal; 05-25-2007 at 04:14 PM.
 
Old 05-29-2007, 12:26 PM   #7
Badfish
LQ Newbie
 
Registered: Aug 2002
Location: So-Cal
Distribution: RedHat 9.0
Posts: 27

Original Poster
Rep: Reputation: 15
what settings should I use?
 
Old 05-29-2007, 11:29 PM   #8
fair_is_fair
Member
 
Registered: May 2005
Posts: 511

Rep: Reputation: 51
Did you make sure to remove the "#" in front of the "forward-socks4a ..." when you edited the config file?

Did you make a space between 9050 and the period?

I always use localhost instead of 127.0.0.1 , not that it should make a difference.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Refusing connections? linker1981 Linux - Networking 4 07-19-2006 10:16 AM
Set Privoxy to allow remote connections 1veedo Linux - Software 1 01-28-2006 03:53 PM
keep refusing connections tpark Linux - Networking 1 03-04-2004 03:24 AM
Refusing Connections goldfish Linux - Newbie 16 10-09-2003 07:13 PM
Telnet yet again. (refusing connections) hornokplease Linux - Networking 2 07-21-2003 04:30 AM


All times are GMT -5. The time now is 06:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration