LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-12-2007, 11:39 AM   #1
slimjim
Member
 
Registered: Apr 2004
Location: east midlands, england
Distribution: Ubuntu 9.04
Posts: 56

Rep: Reputation: 15
Privoxy - "Privoxy is not being used" from http://www.privoxy.org/config/


Hiya,

I installed Privoxy and Tor this morning; hoping to do a bit of discreet anonymous surfing.

The only change I made to the config was to add

forward-socks4a / localhost:9050 .

.. to /etc/privoxy/config, per installation instructions I found somewhere.

I then started the privoxy and tor services, installed the Firefox extension to switch Tor on and off, switched it on and bingo, it seems to work - at least, I get an alien IP address if I go to whatismyip.com.

http://config.privoxy.org/ tells me:

This is Privoxy 3.0.3 on sauce (127.0.0.1), port 8118, enabled

('sauce' being the hostname in question). But there's a link to "View & change the current configuration", which takes me to

http://www.privoxy.org/config/

.. and this page tells me

"Privoxy is not being used

The fact that you are reading this page shows that Privoxy was not used in the process of accessing it. Had the request been made through Privoxy, it would have been intercepted and you would be looking at Privoxy's web-based user interface now."


Have I made a misconfiguration somewhere?

Thanks ..
James
 
Old 03-12-2007, 12:07 PM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
Double check your Firefox proxy settings. If you rae using the torbutton extension it "should" set things correctly, although if I remember the first time I had to change what it had from localhost to 127.0.0.1 in order for it to work properly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Privoxy config: Where is it?? BaltikaTroika Linux - General 3 04-16-2006 01:06 PM
Privoxy, editing config in web interface as user craigevil Linux - Networking 1 08-27-2005 11:51 PM
Where is the Embedded Linux "HOWTO" at http://www.tldp.org ? t3gah General 14 06-06-2005 07:35 AM
Privoxy Mortified Pengu Linux - Software 3 11-28-2004 01:11 PM
Privoxy? BajaNick Linux - General 2 07-06-2003 08:48 PM


All times are GMT -5. The time now is 10:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration