LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-10-2005, 01:04 PM   #1
Jared Lewis
LQ Newbie
 
Registered: Jun 2005
Location: Houston, TX
Posts: 8

Rep: Reputation: 0
Printing to a cups samba server on slackware from windows computers


I have a linux box called loki which works as a file and print server for windows by running samba. Last week I had this box on Mandrake 10.1 and I had samba cups printing set up, and everything worked fine. I could print from windows PCs to the server easily.

This week i wiped the server, installed slackware 10.1 on it again setup samba on the box. I used the exact same smb.conf file I did when the box ran on mandrake. I can print to the printer from the linux box. I can print to the printer from a Mac OS X computer which finds and uses the cups server. And on windows computers, I can add the printer, and the printer shows up as ready, however, it will not print. If you print, it acts likes its going to print, but nothing happens. No errors, just nothing comes out of the computer. The samba file sharing also works fine.

I even tried to print to a URL from windows, i.e.
note: id dont have enough posts to write the URL but here you know what I am talking about. ipaddress:631/printers/JaredPrinter only with you know what on the front.

That did not work either.

I am thinking there must be something in CUPs i forgot to set, because when I used Mandrake i used a kde tool to configure cups. I mean, i am using the exact same smb.conf file, so I dont *think* its samba.

I have pasted below the relvant portions of my smb.conf file.

Any help would be greatly appreciated. Thank you.

Code:
[global]
	workgroup = LEWISNET
	server string = Loki
	guest account = nobody
	log level = 2
	log file = /var/log/samba.log.%m
	max log size = 50
	ldap ssl = no
	load printers = yes
	printing = cups
	printcap name = cups
	veto files = .DS_Store/.AppleDB/Network Trash Folder/.AppleDouble/Temporary Items/.AppleDesktop/.volinfo/.TemporaryItems/_VUC69~7/
	delete veto files = YES

[Printers]
	path = /var/spool/samba
	browseable = no
	public = yes
	guest ok = yes
	guest only = yes
	writable = no
	printable = yes
	printer admin = @lewismember
	use client driver = yes
 
Old 06-10-2005, 03:55 PM   #2
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
edit your /etc/cups/mime.types and mime.conv files.

uncomment the following line it each one:

application/octet-stream
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS+SAMBA: slow printing from windows hamish Linux - Networking 2 07-06-2005 12:27 PM
Help with printing to Windows printer with cups and samba. Royle Linux - Networking 3 01-23-2005 01:16 PM
Printing from Windows to CUPS using SAMBA 2.2.7 nothing prints SOLVED ja_nch Linux - Networking 1 09-19-2003 06:19 AM
Windows printing to CUPS via Samba JahToasted Linux - General 0 08-22-2003 03:28 PM
Printing to Windows with Samba and CUPS, error questions messenjah Linux - Software 1 07-22-2003 08:15 PM


All times are GMT -5. The time now is 10:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration