LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-13-2006, 07:11 AM   #1
centos-new
LQ Newbie
 
Registered: Sep 2006
Posts: 4

Rep: Reputation: 0
pptpconfig error


hi everyone,I have centOS and want to connect to a windows vpn server through a LAN.for this a install pptpconfig(is there other solution???)and wen I run it and start connection,this appearimportant notes are bold).
--------
pptpconfig: debug information dump begins
WARNING: security sensitive information follows
pptpconfig 1.2 2004/06/19 08:57:15
# pppd --version
pppd version 2.4.3
# uname -a
Linux linux.rayaneh.com 2.6.17.11 #1 Fri Sep 8 17:35:26 IRDT 2006 i686 i686 i386 GNU/Linux
# grep mppe /proc/modules
# modinfo ppp_mppe
filename: /lib/modules/2.6.17.11/kernel/drivers/net/ppp_mppe.ko
author: Frank Cusack <fcusack@fcusack.com>
description: Point-to-Point Protocol Microsoft Point-to-Point Encryption support
license: Dual BSD/GPL
alias: ppp-compress-18
version: 1.0.2
vermagic: 2.6.17.11 mod_unload 686 REGPARM 4KSTACKS gcc-3.4
depends: ppp_generic
srcversion: 6B88E623CA7C4D7FE2F11FA
Array
(
[name] => golzari
[server] => 10.1.10.10
[domain] =>
[username] => golzari
[password] => (hidden by pptpconfig)
[pppd-options] => nopcomp noaccomp require-pap
[pptp-options] =>
[resolv] =>
[dns-options] =>
[routing] => routing_client_to_lan
[usepeerdns] => 1
[require-mppe] => 1
[nomppe-40] => 1
[nomppe-128] => 1
[refuse-eap] => 1
[mppe-stateful] => 1
[autostart] =>
[iconify] =>
[persist] =>
[debug] => 1
[client-to-lan] =>
)
# route -n (before pppd)
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
pptpconfig: debug information dump ends, starting pppd
pppd options in effect:
debug # (from /etc/ppp/peers/golzari)
updetach # (from command line)
logfd 1 # (from command line)
linkname golzari # (from /etc/ppp/peers/golzari)
dump # (from /etc/ppp/peers/golzari)
require-pap # (from /etc/ppp/peers/golzari)
refuse-chap # (from /etc/ppp/options.pptp)
refuse-mschap # (from /etc/ppp/options.pptp)
refuse-eap # (from /etc/ppp/options.pptp)
name golzari # (from /etc/ppp/peers/golzari)
remotename golzari # (from /etc/ppp/peers/golzari)
# (from /etc/ppp/options.pptp)
pty pptp 10.1.10.10 --nolaunchpppd # (from /etc/ppp/peers/golzari)
noaccomp # (from /etc/ppp/peers/golzari)
nopcomp # (from /etc/ppp/peers/golzari)
ipparam golzari # (from /etc/ppp/peers/golzari)
usepeerdns # (from /etc/ppp/peers/golzari)
nobsdcomp # (from /etc/ppp/options.pptp)
nodeflate # (from /etc/ppp/options.pptp)
# (from /etc/ppp/peers/golzari)
# (from /etc/ppp/peers/golzari)
require-mppe-128 # (from /etc/ppp/options.pptp)
nomppe-128 # (from /etc/ppp/peers/golzari)
mppe-stateful # (from /etc/ppp/peers/golzari)
using channel 1
Using interface ppp0pptpconfig: monitoring interface ppp0

Connect: ppp0 <--> /dev/pts/2
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xefcc3528>]
rcvd [LCP ConfReq id=0x0 <auth pap> <magic 0x71e118c7> <pcomp> <accomp> <callback CBCP> <mrru 1614> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13.9d.00.00.00.00]> < 17 04 08 73>]
sent [LCP ConfRej id=0x0 <pcomp> <accomp> <callback CBCP> <mrru 1614> < 17 04 08 73>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <auth pap> <magic 0xefcc3528>]
rcvd [LCP ConfReq id=0x1 <auth pap> <magic 0x71e118c7> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13.9d.00.00.00.00]>]
sent [LCP ConfAck id=0x1 <auth pap> <magic 0x71e118c7> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13.9d.00.00.00.00]>]
sent [PAP AuthReq id=0x1 user="golzari" password=<hidden>]
rcvd [PAP AuthAck id=0x1 ""]
PAP authentication succeeded
rcvd [LCP ConfReq id=0x3 <auth pap> <magic 0x13a65e4> <pcomp> <accomp> <callback CBCP> <mrru 1614> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13.9d.00.00.00.00]> < 17 04 08 73>]
sent [LCP ConfReq id=0x2 <asyncmap 0x0> <auth pap> <magic 0x8a8aae30>]
sent [LCP ConfRej id=0x3 <pcomp> <accomp> <callback CBCP> <mrru 1614> < 17 04 08 73>]
rcvd [LCP ConfRej id=0x2 <auth pap>]
sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x8a8aae30>]
rcvd [LCP ConfReq id=0x4 <auth pap> <magic 0x13a65e4> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13.9d.00.00.00.00]>]
sent [LCP ConfAck id=0x4 <auth pap> <magic 0x13a65e4> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13.9d.00.00.00.00]>]
rcvd [LCP ConfAck id=0x3 <asyncmap 0x0> <magic 0x8a8aae30>]
peer refused to authenticate: terminating link
sent [LCP TermReq id=0x4 "peer refused to authenticate"]
rcvd [LCP TermAck id=0x4 "peer refused to authenticate"]
Connection terminated.
Waiting for 1 child processes...
script pptp 10.1.10.10 --nolaunchpppd , pid 5460
sending SIGTERM to process 5460
Script pptp 10.1.10.10 --nolaunchpppd finished (pid 5460), status = 0x0
# route -n (after pppd exit)
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
pptpconfig: pppd process terminated by signal 11 (failed)
pptpconfig: SIGSEGV
# route -n (after completion)
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
------
can anyone solve it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse CUPS error: cups(File)DoRequest error:client-error-bad-request smdonelan Linux - Hardware 6 04-17-2007 06:46 PM
pptpconfig - php errors.. Golzari-Ali Linux - Software 3 09-10-2006 01:03 PM
DNS problem after installing and removing pptpconfig mldqj Linux - Networking 0 03-25-2006 02:32 AM
pptpconfig mfrangos79 Linux - General 6 12-28-2005 09:58 PM
updating new installation of 9.3 ERROR...ERROR...ERROR Morbid Suse/Novell 3 08-15-2005 11:22 PM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration