LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 06-02-2008, 02:11 AM   #1
nkataria
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Rep: Reputation: 0
Question pppoe connected. But no internet.


I am using UBUNTU operating system along with windows XP in my PC. I was using 'pppoeconf' in UBUNTU to connect to Internet through my ISP. But recently(2 months by now) Internet access through the same utility has stopped in Ubuntu. I am able to connect to my ISP, but not able to surf Internet. When I connect to net(using pon dsl-provider command), and give 'ifconfig' command, I see the following output ::
------------------------------------------------------------
ppp0 Link encap:Point-to-Point Protocol
inet addr:221.128.197.90 P-t-P:202.63.173.66 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:289 errors:0 dropped:0 overruns:0 frame:0
TX packets:397 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:222814 (217.5 KiB) TX bytes:38245 (37.3 KiB)
------------------------------------------------------------
I able to connect to my ISP website by giving its IP address (202.63.173.66). But when I give any other site's address (eg. www.yahoo.com), the browser status bar shows 'looking for ...', and no data is received. I also tried to ping DNS server(in /etc/resolve.conf file), and other sites's IP address (Google's IP address --> 64.233.167.99), but it fails.
I am able to connect to the internet successfully in Windows XP on the same PC.
Two of my friends having connection of the same ISP and using Linux OS is also facing the same problem.
Can you help us ?

The output of various commands on Ubuntu is appended as below ::

1. sudo ifconfig
---------------------------------------------------------------------
eth0 Link encap:Ethernet HWaddr 00:30:F1:4D:96:AC
inet addr:10.10.146.206 Bcast:10.10.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2906572 errors:0 dropped:0 overruns:0 frame:0
TX packets:129740 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:584754941 (557.6 MiB) TX bytes:19303851 (18.4 MiB)
Interrupt:209 Base address:0xcc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1156 (1.1 KiB) TX bytes:1156 (1.1 KiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:221.128.197.43 P-t-P:202.63.173.66 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:304 errors:0 dropped:0 overruns:0 frame:0
TX packets:362 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:254099 (248.1 KiB) TX bytes:34781 (33.9 KiB)
-----------------------------------------------------------------------------

2. sudo ip a
-----------------------------------------------------------------------------
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:30:f1:4d:96:ac brd ff:ff:ff:ff:ff:ff
inet 10.10.146.206/16 brd 10.10.255.255 scope global eth0
4: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP> mtu 1492 qdisc pfifo_fast qlen 3
link/ppp
inet 221.128.197.43 peer 202.63.173.66/32 scope global ppp0
-------------------------------------------------------------------------------

3. sudo ip route
--------------------------------------------------------------------------------
202.63.173.66 dev ppp0 proto kernel scope link src 221.128.197.43
10.10.0.0/16 dev eth0 proto kernel scope link src 10.10.146.206
default dev ppp0 scope link
---------------------------------------------------------------------------------

4. sudo plog
----------------------------------------------------------------------------------
Jun 1 18:49:54 nk pppd[4955]: CHAP authentication succeeded: Welcome to XXXX.
Jun 1 18:49:54 nk pppd[4955]: CHAP authentication succeeded
Jun 1 18:49:54 nk pppd[4955]: peer from calling number 00:11:11:7DF:31 authorized
Jun 1 18:49:54 nk pppd[4955]: Cannot determine ethernet address for proxy ARP
Jun 1 18:49:54 nk pppd[4955]: local IP address 221.128.197.43
Jun 1 18:49:54 nk pppd[4955]: remote IP address 202.63.173.66
Jun 1 18:49:54 nk pppd[4955]: primary DNS address 202.63.164.17
Jun 1 18:49:54 nk pppd[4955]: secondary DNS address 202.63.164.18
--------------------------------------------------------------------------------------

5. sudo route -n
-------------------------------------------------------------------------------------
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
202.63.173.66 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
10.10.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0
---------------------------------------------------------------------------------------

- Navneet Kataria
 
Old 06-02-2008, 02:49 AM   #2
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
1. Check what all the settings are in XP and find out what's changed.

2. Check that XP uses plain old 'PPPoE' and doesn't run some other spyware to ensure that you get a good connection only when WinDuhs runs.

3. A common problem is that for the "username" part of the authentication people put "username" rather than "username@isp"; check that all the credentials are set the same in Linux as XP.
 
Old 06-02-2008, 05:45 AM   #3
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
It's your gateway.
Remove it first and add it back:
ip route del default dev ppp0
ip route add default via ppp0IP dev ppp0

OR, it could be your DNS, as I see that when you input an IP it works, but when you try to contact a host name it fails.
do cat /etc/resolv.conf and check that the nameservers listed there are the ones provided by your ISP. Maybe they have changed.
 
Old 06-02-2008, 09:01 AM   #4
nkataria
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Exclamation

Thanks for the replies. But they didn't helped.

1. DNS addresses are there in /etc/resolv.conf. They are the same as i found them in windows.

2. No settings were changed in Windows XP.

3. I always use plain username and not username@isp.

4. I can't spot any spyware in windows running.

5. I tried some thing like "ip route add default". But it didn't worked.
Tux-Slack, Can you tell me the exact string i should put in place of "ip route add default via ppp0IP dev ppp0".

What is ppp0IP ? Is it ppp0 ip i got dynamically from my ISP ?

Thanks and Regards,
Navneet Kataria
 
Old 06-02-2008, 09:19 AM   #5
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
ppp0 Link encap:Point-to-Point Protocol
inet addr:221.128.197.43 P-t-P:202.63.173.66 Mask:255.255.255.255

inet addr is your ppp0IP.
Now if this works, this would mean you would have to do this everytime you got reconnected.
I've got a little script at home that automates this.

Oh and, try to ping the IPs of your nameservers
 
Old 06-03-2008, 04:51 AM   #6
nkataria
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Unhappy

1. Tried.
$ sudo route del default

$ sudo route add default gw ppp0IP dev ppp0

But the problem remains the same.

2. I tried to ping DNS addresses present in /etc/resolv.conf. But no output. On pressing Cntl+c, no packet received.

3. Tried to connect/ping some other web-site using their IP address, but no success.
 
Old 06-03-2008, 05:48 AM   #7
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
You did input the IP not ppp0IP right? :P
 
Old 06-03-2008, 08:44 AM   #8
nkataria
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Lightbulb Yes I did replaced ppp0IP with actual IP

Yes I did replaced ppp0IP with actual IP. :-)

The output of "ipconfig /all" command and "route PRINT" command in windows are also attached with this post. I can understand the output of ipconfig. But the routes in windows are out of my head. Can some body please check the output and tell me what settings more i had to make the net work on linux ?

---------------------------------------------
Microsoft Windows XP [Version X.X.YYYY]

C:\>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : <some-thing>
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Accton CheetahPower Enhanced 10/100
Adapter AC-EN3207
Physical Address. . . . . . . . . : 00-30-F1-4D-96-AC
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.64.91
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter xxxx:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 221.128.197.211
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 221.128.197.211
DNS Servers . . . . . . . . . . . : 202.63.164.17
202.63.164.18
NetBIOS over Tcpip. . . . . . . . : Disabled

C:\>route PRINT
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 30 f1 4d 96 ac ...... Accton CheetahPower Enhanced 10/100 Adapter AC-E
N3207 - Packet Scheduler Miniport
0x60004 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
===========================================================================
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 221.128.197.211 221.128.197.211 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
169.254.0.0 255.255.0.0 169.254.64.91 169.254.64.91 20
169.254.64.91 255.255.255.255 127.0.0.1 127.0.0.1 20
169.254.255.255 255.255.255.255 169.254.64.91 169.254.64.91 20
202.63.173.66 255.255.255.255 221.128.197.211 221.128.197.211 1
221.128.197.211 255.255.255.255 127.0.0.1 127.0.0.1 50
221.128.197.255 255.255.255.255 221.128.197.211 221.128.197.211 50
224.0.0.0 240.0.0.0 169.254.64.91 169.254.64.91 20
224.0.0.0 240.0.0.0 221.128.197.211 221.128.197.211 1
255.255.255.255 255.255.255.255 169.254.64.91 169.254.64.91 1
255.255.255.255 255.255.255.255 221.128.197.211 221.128.197.211 1
Default Gateway: 221.128.197.211
===========================================================================
Persistent Routes:
None
 
Old 06-03-2008, 09:03 AM   #9
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Ooo - wait a second. How did you configure 'eth0'? It should not be configured if you want PPPoE to work properly.

in /etc/network/interfaces:
auto eth0
iface eth0 inet manual

But before playing with that, you can try:
poff
ifconfig eth0 down
ifconfig eth0 up 0.0.0.0
pon dsl-provider
 
Old 06-06-2008, 03:54 AM   #10
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
pinniped, not true.
I have my eth0 manualy configured and all that and it worsk like a charm.

One thing I do find missing here and what I have is a default gateway on eth0.

My server is currently down due to hardware crash, so I'll put it down in my own words, not copy it over.

So, local network to the modem is on 192.168.1.0/24 and the server has an local IP of:
192.168.1.2 (modem is 192.168.1.1). So the default gateway on eth0 is also 192.168.1.1
And then I launch pppoe-start, which on connect calls a script /etc/ppp/ip-up script which sets my default gateway on ppp0 the same as my ppp0IP.
 
Old 06-07-2008, 05:26 AM   #11
nkataria
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Angry True!! Problem is the same

Correct Tux-Slack !!
pinniped I did made the settings you told but the problem remains the same.

Also earlier when I was able to connect to internet through same OS, eth0 was used to be active with valid IP. I was able to connect to local-net as well as internet at the same time.

But now, some settings might have changed by my ISP and i am still not able to surf even though after connecting to it.
 
Old 06-09-2008, 12:06 AM   #12
nkataria
LQ Newbie
 
Registered: Jun 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Question To Summarize

My (along with my friends) problem stands the same point.
Any other thing that I can try ?
 
  


Reply

Tags
dns, gateway, pppoe, pppoeconf, router


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connected but no internet merchtemeagle Ubuntu 30 07-19-2007 01:19 AM
Unplug Internet Cable and plugin aging, but could not connected to the internet DevlinX Linux - General 2 07-02-2006 11:36 AM
A probleam about wireless ethernet card used PPPOE protocol dial-up connected interne yjftwo Linux - Wireless Networking 5 11-25-2004 06:02 AM
rp-pppoe problem: it says im connected but can't ping anything johnnybezak Linux - Networking 1 05-07-2004 02:56 PM
internet is connected but cannot browse internet?!?!? myk3 Linux - Newbie 3 11-17-2003 06:57 AM


All times are GMT -5. The time now is 01:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration