LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   PPP dialup problem (http://www.linuxquestions.org/questions/linux-networking-3/ppp-dialup-problem-28725/)

Xreagan 08-24-2002 10:47 PM

PPP dialup problem
 
This problem is driving me nuts. I have installed Debian 3.0. However, I cannot get the get a browser to use the ppp connection.

I have used kpp to configure and establish the connection (this works) however when I pull up a browser, it just sits there and doesnt pull any data from the web.

I am logged in as user, have put DNS numbers in the ISP configuration, I get same problem when using PON.

Did I inavertaltly create a firewall?

any help would be appreciated.

thanks

DavidPhillips 08-25-2002 12:01 AM

do you have an ip address ( ifconfig )

ifconfig
ppp0 Link encap:Point-to-Point Protocol
inet addr:216.110.88.180 P-t-P:216.110.88.4 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1524 Metric:1
RX packets:1505 errors:0 dropped:0 overruns:0 frame:0
TX packets:1806 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:987677 (964.5 Kb) TX bytes:300059 (293.0 Kb)


is the default and other route set ( route )

route
Destination Gateway Genmask Flags Metric Ref Use Iface
216.110.88.4 * 255.255.255.255 UH 0 0 0 ppp0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 216.110.88.4 0.0.0.0 UG 0 0 0 ppp0


is networking on ( cat /etc/sysconfig/network )

cat /etc/sysconfig/network
NETWORKING=yes


can you reach the default gateway ( ping ipofdefaultgw )

ping 216.110.88.4
PING 216.110.88.4 (216.110.88.4) from 216.110.88.180 : 56(84) bytes of data.
64 bytes from 216.110.88.4: icmp_seq=0 ttl=255 time=203.316 msec
64 bytes from 216.110.88.4: icmp_seq=1 ttl=255 time=179.946 msec
64 bytes from 216.110.88.4: icmp_seq=2 ttl=255 time=179.955 msec
64 bytes from 216.110.88.4: icmp_seq=3 ttl=255 time=169.957 msec

can you reach nameserver ( traceroute nameserver ( from your /etc/resolv.conf ) )

cat /etc/resolv.conf
nameserver 216.110.88.2

traceroute 216.110.88.2
traceroute to 216.110.88.2 (216.110.88.2), 30 hops max, 38 byte packets
1 216.110.88.4 (216.110.88.4) 153.405 ms 139.369 ms 139.476 ms
2 216.110.88.2 (216.110.88.2) 147.712 ms 139.481 ms 139.498 ms

Xreagan 08-26-2002 08:36 AM

Thanks for your info. I may try this, however I did some more reading and found that the default debian kernel is not configured for more that two serial ports. I need to compile a new kernel.

I will try that first. I do see options for that in Xconfig.

DavidPhillips 08-26-2002 08:44 PM

well you said it is connecting, I can't imagine what in the world not having two com ports has to do with the browser not opening a web page.


But maybe someone can use this later.

Just the basic requirements required to be able to use a connection.

Xreagan 08-27-2002 08:36 AM

I too am confused about this...
I can log in, and get a connection. But when I open up my browser, it just stands still, trying to decode the dns.

I have followed the instructions in the installation docs closely. Cannot work around this problem...

DavidPhillips 08-28-2002 06:30 AM

what is it looking like on the commands I posted above in post#2

Xreagan 08-28-2002 08:23 AM

I did not do that. I went to Best buy and bought a external modem... (took me two trips as the cable wasnt in the box).

But the situation with the internal was strange... I could dial, get a connection, etc. But my browser would hang on looking up the dns...

I may need your post#2 info, as I will be trying that modem when I put linux on an older box..


thanks
dd

mayankjohri 02-20-2003 06:43 AM

try these commands after the internet connection is establishes
route del default
route add default ppp0
and inform me about the results

DavidPhillips 02-20-2003 01:47 PM

Even if you buy a new modem you still need to do the commands above if it's not working so we can see the problem. You diid not need a modem if it was already connecting, just needed to run a few commands to see what we need to do.


All times are GMT -5. The time now is 04:14 AM.