LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-19-2004, 08:37 PM   #1
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
ppp dialup dns problem (Slackware 9.1)


I posted this question on the Slackware forum
http://www.linuxquestions.org/questi...hreadid=171916
but had no luck. Perhaps someone here might help.

Copy-pasted from the other thread:

I'm just trying to get a simple desktop dialup setup working. I haven't set up any LAN. I'd like to be able to use ppp-on/off as a regular user, but for now I just want to get it working for root. I'm running a stock Slack 9.1 install with bare.i (the stock kernel).

I've run netconfig and told it I just want to setup a loopback connection (for "modem or no net").

I've run pppsetup and given it the usual input.

I can run ppp-on as root and get my external modem to dialup and connect. /var/log/messages tells me:
Code:
CONNECT
 -- got it
Serial connection established.
Using interface ppp0
Connect: ppp0 <--> /dev/modem
Once connected, If I try to ping the one dns IP in my /etc/resolv.conf, I get:
Code:
connect: Network is unreachable
If I try to ping something else
Code:
ping www.osnews.com
I get
Code:
ping: unknown host www.osnews.com
Trying to traceroute the IP of my DNS listed in /etc/resolv.conf
Code:
traceroute: findsaddr: Can't find interface
Running 'ifconfig -a' lists eth0, lo, and ppp0. In the ppp0 section, there's no "inet" or "UP" lines present like there are when I haven't run ppp-on.

----------------------------
Not from previous post, some more (maybe relevant) info from my config files:

/etc/resolv.conf:
search my_isp.net
nameserver xxx.xxx.xxx.xxx

/etc/host.conf:
order hosts, bind
multi on

/etc/hosts:
127.0.0.1 localhost
127.0.0.1 me.example.net me

/etc/networks:
loopback 127.0.0.0
localnet 127.0.0.0

/etc/nsswitch.conf:
# [snip] Everything says "files" except
hosts: files dns

Also, /etc/ppp/options mentions:
defaultroute
noipdefault

Further -- once connected, "netstat -rn" output only lists that one line starting with 127.0.0.1 for the lo interface. That's the same as when I'm *not* connected.

Last edited by johnMG; 04-19-2004 at 08:59 PM.
 
Old 04-19-2004, 08:57 PM   #2
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Original Poster
Rep: Reputation: 31
I mistakenly wrote:
Running 'ifconfig -a' lists eth0, lo, and ppp0. In the ppp0 section, there's no "inet" or "UP" lines present like there are when I haven't run ppp-on.

Apologies -- I read it wrong. Of course, there's no entry for ppp0 when I'm not connected. The "inet" and "UP" lines I was looking at were in the lo section of output.
 
Old 04-20-2004, 09:21 PM   #3
diether
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
could easily be wrong but I don't think this is a dns issue. Do you ever receive notification that you have been assigned an ip address? For example is there something like the following in /var/log/messages ?

Connect: ppp0 <--> /dev/modem
PAP authentication succeeded
local IP address 128.146.247.11
remote IP address 128.146.244.4

Based on the information you give I don't think you are ever assigned an IP address (for example, your ifconfig output also suggests this is the problem). Is the ppp server expecting PAP authentication or
maybe it is expecting you to send a command like "ppp" or "ppp go"?
 
Old 04-21-2004, 12:44 AM   #4
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Original Poster
Rep: Reputation: 31
Thanks for the reply diether.

Do you ever receive notification that you have been assigned an ip address?

No.

For example is there something like the following in /var/log/messages ?

Connect: ppp0 <--> /dev/modem
PAP authentication succeeded
local IP address 128.146.247.11
remote IP address 128.146.244.4


Nope. I get nothing like that.

Based on the information you give I don't think you are ever assigned an IP address (for example, your ifconfig output also suggests this is the problem).

Ahhh... It sounds like you are correct.

Is the ppp server expecting PAP authentication

Yes. Well, I'm pretty sure that's the case, though I'll double-check on it.

or maybe it is expecting you to send a command like "ppp" or "ppp go"?

Not sure what you mean there. Slack's ppp system comes equipped with ppp-go/ppp-on and ppp-off/ppp-stop scripts to be used when you want to connect (and disconnect) via dialup ppp to your ISP.

I guess I need to find out at which point I'm supposed to be getting assigned an IP address (i.e. within which script and where). I suppose this should happen in ppp-go, but looking through it, I'm not quite sure what I'm looking for. Or maybe it's something pppd handle's on its own? The pppd line in ppp-go looks like:
Code:
/usr/sbin/pppd -detach connect "/usr/sbin/chat -v -f /etc/ppp/pppscript" &
My /etc/ppp/pppscript file is short and ends with:
Code:
OK "atdtxxxxxxx"
TIMEOUT 75
CONNECT
***A side note that's possibly relevant: I've got a PCI ethernet NIC installed on the machine but I'm not currently using it. I know it's being properly detected by looking at the dmesg output. Could the system be configuring something behind my back that's causing a problem with dialup ppp?

I'm just using a standard US Robotics external 56k modem on /dev/ttyS0.

Last edited by johnMG; 04-21-2004 at 12:48 AM.
 
Old 04-21-2004, 01:01 PM   #5
diether
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
>> Is the ppp server expecting PAP authentication?

>Yes. Well, I'm pretty sure that's the case, though I'll double-check on it.

From you description it does not look like you have PAP authentication
enable in your pppd options. I would enable pap authentication (maybe
the easiest way to do this is to rerun the pppsetup script and enable pap
when it asks about it. If you have additional trouble I will post an
example later.

>> or maybe it is expecting you to send a command like "ppp" or "ppp go"?

> Not sure what you mean there. Slack's ppp system comes equipped with
> ppp-go/ppp-on and > ppp-off/ppp-stop scripts to be used when you want
> to connect (and disconnect) via dialup ppp to your ISP.

Sorry, confusing language on my part. If your authentication is not PAP
or CHAP based then it is just script based. Sometimes as part of a script
based login (after sending your username and password) the server expects
an additional command to get the ppp server to finalize the the
connection. The command the ppp server is often looking for is something
like "ppp". This has nothing to do with the "ppp-on" or "ppp-go" scripts
(you would send the command via the chat script).

Summary: my best guess is that you need to enable PAP authentication.
 
Old 04-21-2004, 04:50 PM   #6
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Original Poster
Rep: Reputation: 31
Thanks for your help diether.

If your authentication is not PAP
or CHAP based then it is just script based.


Well, I just heard back from my ISP's support, and it's definitely PAP.

Summary: my best guess is that you need to enable PAP authentication.

Hmm... I think I'm already using PAP.

Say, I'm just now getting some help on this from a post to alt.os.linux.slackware. Let this thread simmer for a bit, and I'll see what turns up there. Either way, I'll post again to give any results I get (and also maybe put some info into the wiki about this! :)

Last edited by johnMG; 04-21-2004 at 06:37 PM.
 
Old 04-21-2004, 07:42 PM   #7
diether
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
I don't think PAP is set up correctly, you should have something like the following option set in /etc/ppp/options:

name "isp_user_name"

Also make sure pap-secrets file is set up with your username and password
 
Old 04-21-2004, 10:29 PM   #8
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Original Poster
Rep: Reputation: 31
I don't think PAP is set up correctly, you should have something like the following option set in /etc/ppp/options:

name "isp_user_name"

Also make sure pap-secrets file is set up with your username and password


Yup. Both of those were (and still are) all set up as you specify.

My /etc/ppp/pap-secrets file has "my_username@myisp" * "password" in it and the file's permissions are set to 600 (as specified in the comment at the top of the file).

My /etc/ppp/options file has name "my_username@myisp" in it.

(Note, the isp specifically requests that you use the whole enchilada (my_username@myisp rather than just my_username) to log in.)

Hmm... it looks like ip-up is never getting run.
 
Old 05-06-2004, 10:09 AM   #9
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Original Poster
Rep: Reputation: 31
--- Epilogue ---

I had a long discourse with some very experienced folks on usenet about this, and in the end, found no solution. I've since installed Redhat 9 and dialup now works. I may try Slackware again next release (unless Fedora turns out to be very stable).

The problem, as near as I can tell, was that my ISP was expecting something from my end, maybe for my PPP client to use a login chat rather than PAP. After the fact, it ocurred to me to try and run pppsetup once more, but this time to use a login chat script rather than PAP (since my ISP claimed to support both -- on the same dialup number). If you're having the same problem as I've described, you might try that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ppp dialup problem cch2cch Linux - Software 0 04-10-2005 02:15 PM
ppp dialup problem for users gescom Slackware 6 08-05-2004 10:51 AM
PPP dialup problem Xreagan Linux - Networking 8 02-20-2003 01:47 PM
ppp dialup problem xiefs Linux - General 4 05-27-2002 04:55 AM
Need PPP Dialup solution David Linux - Newbie 3 05-03-2001 12:19 PM


All times are GMT -5. The time now is 03:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration