LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-26-2005, 07:50 AM   #1
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Rep: Reputation: 30
postfix mail delivery


hi i am trying to set up a mail server agian on sles9 (suse linux enterprise server 9) i have done this many times in windows 2000/2003 and a few times in RH9 but i think this is the firs time i have used postfix i have got it kind of working but not compleatly

so far i have got it accepting mail but once it is in the mail cue thats it it wont go any further

i have configured postfix through webmin as i find it easyest and have checked the mail cou in webmin aswell i have sent an e-mail to a user on my server the server handles that domain and the user is existent on my server but when i check the postfix mail cue through webmin i get the following

connect to localhost[127.0.0.1]: Connection refused

i have temporely removed all rules from ip tables and there shouldnt be anything blocking any port on the machine that postfix is on

any ideas?

thanks for any help

berrance
 
Old 02-26-2005, 03:10 PM   #2
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Original Poster
Rep: Reputation: 30
could it be because my users are ldap?

just a thought!

thanks

berrance
 
Old 02-27-2005, 10:52 AM   #3
R4z0r
Member
 
Registered: Jan 2002
Distribution: CentOS 3.1
Posts: 119

Rep: Reputation: 15
What does it say in /var/log/maillog ?
 
Old 02-28-2005, 06:37 AM   #4
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Original Poster
Rep: Reputation: 30
Feb 26 13:20:41 hull postfix/smtpd[8113]: connect from unknown[65.54.233.95]
Feb 26 13:20:41 hull postfix/smtpd[8113]: E786B187C2: client=unknown[65.54.233.95]
Feb 26 13:20:42 hull postfix/cleanup[7679]: E786B187C2: message-id=<BAY21-F61408B37EC5A04174FFFFD5660@phx.gbl>
Feb 26 13:20:42 hull postfix/qmgr[7617]: E786B187C2: from=<my-email@hotmail.com>, size=1182, nrcpt=1 (queue active)
Feb 26 13:20:42 hull postfix/smtp[8078]: connect to localhost[::1]: Connection refused (port 10024)
Feb 26 13:20:42 hull postfix/smtp[8078]: connect to localhost[127.0.0.1]: Connection refused (port 10024)
Feb 26 13:20:42 hull postfix/smtp[8078]: E786B187C2: to=<my-email@hull.berrancenetworks.co.uk>, relay=none, delay=1, status=deferred (connect to localhost[127.0.0.1]: Connection refused)
Feb 26 13:20:42 hull postfix/smtpd[8113]: disconnect from unknown[65.54.233.95]
Feb 26 13:20:42 hull postfix/qmgr[7617]: E786B187C2: skipped, still being delivered

thats what appears in my log from sending an email to an account on my server hull is the server name

thanks for any help

but i was a littsuprised to se it using port 10024 is this normal and if it should be something els how can i chang it?

and i am sure ip tables isnt even running (i turned it of hoping it was that that was blocking thing)

thanks

berrance
 
Old 02-28-2005, 06:46 AM   #5
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Original Poster
Rep: Reputation: 30
i hav just created a test user called t33 which is an ldap user i can send emails localy to from root and it will recieve it and i can send on back to root and root will also recieve it however i just did an email test at www.dnsstuff.com and got the following responce with the email addres t33@berrancenetworks.co.uk

mail.berrancenetworks.co.uk. - 83.100.157.157 [Could not connect: Got an unknown RCPT TO response: 550 : Recipient address rejected: User unknown in local recipient table

i seem to get that result no matter what user i do the test with.

EDIT ok i hav fixed this problem of the error on dns stuff i was using the wrong email addy i hav to use t33@hull.berrancenetworks.co.uk but i still cannot recive an email from outside my network

what is strange though even when i try sending an email localy to the acount my-email@hull.berrancenetworks.co.uk it will not recieve it! but when i send to it from hotmail it will go into my mail cue but what is even stranger is if i sent to the t33@hull.berrancenetworks.co.uk form my hotmail account it doesnt recieve it and it doesnt appear to go into my mail queue

Last edited by berrance; 02-28-2005 at 07:06 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix suspending mail delivery(configured with clamav and amavis) myguest Red Hat 0 08-02-2005 01:17 AM
Postfix: restrict delivery of mail to users in alias table noeffred Linux - Software 1 02-02-2005 04:05 PM
confuguring postfix to use procmail for system wide mail delivery jomy Linux - Networking 0 01-23-2005 07:47 AM
Postfix + Procmail delivery issues lhoff Mandriva 0 02-28-2004 09:23 PM
Postfix mail delivery issue kokke Linux - Software 6 05-13-2003 05:50 AM


All times are GMT -5. The time now is 02:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration